aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libmsocket/Makefile40
-rw-r--r--devel/libmsocket/distinfo3
-rw-r--r--devel/libmsocket/pkg-descr7
4 files changed, 51 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4c9fa836300b..b3c16732b590 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -657,6 +657,7 @@
SUBDIR += libmimedir
SUBDIR += libmowgli
SUBDIR += libmpcbdm
+ SUBDIR += libmsocket
SUBDIR += libmtrie
SUBDIR += libnaji
SUBDIR += libnotify
diff --git a/devel/libmsocket/Makefile b/devel/libmsocket/Makefile
new file mode 100644
index 000000000000..503f2c8b66ab
--- /dev/null
+++ b/devel/libmsocket/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: libmsocket
+# Date created: 2008-10-14
+# Whom: Matt Harris <mattdharris@users.sourceforge.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libmsocket
+PORTVERSION= 0.4
+CATEGORIES= devel net
+MASTER_SITES= SF/kageki
+
+MAINTAINER= mattdharris@users.sourceforge.net
+COMMENT= A socket abstraction library for C programmers
+
+LIB_DEPENDS= event:${PORTSDIR}/devel/libevent
+
+USE_BZIP2= yes
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-throttling \
+ --with-libevent=${LOCALBASE}
+
+PLIST_FILES= lib/libmsocket.so \
+ lib/libmsocket.so.0.1 \
+ lib/libmsocket.a \
+ include/msocket.h \
+ include/msocketutils.h
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+CFLAGS+= -fPIC -DPIC
+.endif
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/libmsocket/distinfo b/devel/libmsocket/distinfo
new file mode 100644
index 000000000000..2293fa7e7c74
--- /dev/null
+++ b/devel/libmsocket/distinfo
@@ -0,0 +1,3 @@
+MD5 (libmsocket-0.4.tar.bz2) = 7ce86cfc7ba06ced17719b84018ddef6
+SHA256 (libmsocket-0.4.tar.bz2) = 39b8b7a7e222f87bcebfa28ed053489df810f7f7141bbcb2ae8a1ae0c27406fc
+SIZE (libmsocket-0.4.tar.bz2) = 69281
diff --git a/devel/libmsocket/pkg-descr b/devel/libmsocket/pkg-descr
new file mode 100644
index 000000000000..86be7b280590
--- /dev/null
+++ b/devel/libmsocket/pkg-descr
@@ -0,0 +1,7 @@
+libmsocket is a socket abstraction library for C programmers.
+
+In addition to simple TCP sockets, it is moving towards transparent
+support for additional abstractions in a seamless manner, such as
+SSL and Socks5 proxies.
+
+WWW: http://sourceforge.net/projects/kageki