aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Sledge-SessionManager-CookieStore/Makefile32
-rw-r--r--www/p5-Sledge-SessionManager-CookieStore/distinfo1
-rw-r--r--www/p5-Sledge-SessionManager-CookieStore/pkg-descr4
-rw-r--r--www/p5-Sledge-SessionManager-CookieStore/pkg-plist5
5 files changed, 43 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 1644a7189e30..eecf2d4a6200 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -344,6 +344,7 @@
SUBDIR += p5-Sledge-Plugin-NoCache
SUBDIR += p5-Sledge-Plugin-ScratchPad
SUBDIR += p5-Sledge-Plugin-SessionAutoCleanup
+ SUBDIR += p5-Sledge-SessionManager-CookieStore
SUBDIR += p5-Template-Toolkit
SUBDIR += p5-URI-Sequin
SUBDIR += p5-WWW-Automate
diff --git a/www/p5-Sledge-SessionManager-CookieStore/Makefile b/www/p5-Sledge-SessionManager-CookieStore/Makefile
new file mode 100644
index 000000000000..34f02066f647
--- /dev/null
+++ b/www/p5-Sledge-SessionManager-CookieStore/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Sledge-SessionManager-CookieStore
+# Date created: 27 February 2003
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sledge-SessionManager-CookieStore
+PORTVERSION= 0.01
+CATEGORIES= www perl5
+MASTER_SITES= http://downloads.sourceforge.jp/sledge/2367/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= A Sledge extension that stores session data to HTTP cookies
+
+BUILD_DEPENDS= ${PM_DEPENDS}
+RUN_DEPENDS= ${PM_DEPENDS}
+
+PM_DEPENDS= ${SITE_PERL}/Sledge.pm:${PORTSDIR}/www/p5-Sledge
+PM_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Crypt/Blowfish.pm:${PORTSDIR}/security/p5-Crypt-Blowfish
+PM_DEPENDS+= ${SITE_PERL}/Crypt/CBC.pm:${PORTSDIR}/security/p5-Crypt-CBC
+PM_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+
+PERL_CONFIGURE= yes
+
+MAN3= Sledge::SessionManager::CookieStore.3
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/www/p5-Sledge-SessionManager-CookieStore/distinfo b/www/p5-Sledge-SessionManager-CookieStore/distinfo
new file mode 100644
index 000000000000..bb3035d54249
--- /dev/null
+++ b/www/p5-Sledge-SessionManager-CookieStore/distinfo
@@ -0,0 +1 @@
+MD5 (Sledge-SessionManager-CookieStore-0.01.tar.gz) = b70406961bb090542c837f038633e01d
diff --git a/www/p5-Sledge-SessionManager-CookieStore/pkg-descr b/www/p5-Sledge-SessionManager-CookieStore/pkg-descr
new file mode 100644
index 000000000000..f3d3107eb14d
--- /dev/null
+++ b/www/p5-Sledge-SessionManager-CookieStore/pkg-descr
@@ -0,0 +1,4 @@
+Sledge::SessionManager::CookieStore is a Sledge extension that stores
+session data to HTTP cookies.
+
+WWW: http://sl.edge.jp/
diff --git a/www/p5-Sledge-SessionManager-CookieStore/pkg-plist b/www/p5-Sledge-SessionManager-CookieStore/pkg-plist
new file mode 100644
index 000000000000..5f1d64a34309
--- /dev/null
+++ b/www/p5-Sledge-SessionManager-CookieStore/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/Sledge/SessionManager/CookieStore.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Sledge/SessionManager/CookieStore/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Sledge/SessionManager/CookieStore
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Sledge/SessionManager 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Sledge/SessionManager 2>/dev/null || true