aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/py-soupsieve/Makefile18
1 files changed, 17 insertions, 1 deletions
diff --git a/www/py-soupsieve/Makefile b/www/py-soupsieve/Makefile
index a0828d5709cc..fa2fee055062 100644
--- a/www/py-soupsieve/Makefile
+++ b/www/py-soupsieve/Makefile
@@ -2,6 +2,7 @@
PORTNAME= soupsieve
PORTVERSION= 1.9
+PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,8 +13,23 @@ COMMENT= CSS4 selector implementation for BeautifulSoup
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.md
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}html5lib>0:www/py-html5lib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}lxml>0:devel/py-lxml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}beautifulsoup>4:www/py-beautifulsoup@${PY_FLAVOR}
+
USES= python
USE_PYTHON= autoplist concurrent distutils
+
NO_ARCH= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_VER} < 3
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}backports.functools_lru_cache>0:devel/py-backports.functools_lru_cache@${PY_FLAVOR}
+.endif
+
+do-test:
+ cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -v -rs
+
+.include <bsd.port.post.mk>