aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/apr/Makefile7
-rw-r--r--devel/apr0/Makefile7
-rw-r--r--devel/apr1/Makefile7
-rw-r--r--devel/apr2/Makefile7
4 files changed, 24 insertions, 4 deletions
diff --git a/devel/apr/Makefile b/devel/apr/Makefile
index acf2479c9074..6959b03be4a8 100644
--- a/devel/apr/Makefile
+++ b/devel/apr/Makefile
@@ -120,7 +120,12 @@ post-extract:
${LN} -s apr-util-APU_0_9_BRANCH apr-util-${PORTVERSION}
pre-configure:
- ${DO_NADA}
+.for d in apr apr-util
+.for f in config.guess config.sub
+ ${CP} -f ${TEMPLATES}/${f} ${WRKDIR}/${d}-${PORTVERSION}/build/${f}
+ ${CHMOD} a+rx ${WRKDIR}/${d}-${PORTVERSION}/build/${f}
+.endfor
+.endfor
run-autotools:
cd ${WRKDIR}/apr-${PORTVERSION}; ${SETENV} ${SCRIPTS_ENV} LIBTOOL_M4=${LIBTOOL_M4} ${SH} ./buildconf
diff --git a/devel/apr0/Makefile b/devel/apr0/Makefile
index acf2479c9074..6959b03be4a8 100644
--- a/devel/apr0/Makefile
+++ b/devel/apr0/Makefile
@@ -120,7 +120,12 @@ post-extract:
${LN} -s apr-util-APU_0_9_BRANCH apr-util-${PORTVERSION}
pre-configure:
- ${DO_NADA}
+.for d in apr apr-util
+.for f in config.guess config.sub
+ ${CP} -f ${TEMPLATES}/${f} ${WRKDIR}/${d}-${PORTVERSION}/build/${f}
+ ${CHMOD} a+rx ${WRKDIR}/${d}-${PORTVERSION}/build/${f}
+.endfor
+.endfor
run-autotools:
cd ${WRKDIR}/apr-${PORTVERSION}; ${SETENV} ${SCRIPTS_ENV} LIBTOOL_M4=${LIBTOOL_M4} ${SH} ./buildconf
diff --git a/devel/apr1/Makefile b/devel/apr1/Makefile
index acf2479c9074..6959b03be4a8 100644
--- a/devel/apr1/Makefile
+++ b/devel/apr1/Makefile
@@ -120,7 +120,12 @@ post-extract:
${LN} -s apr-util-APU_0_9_BRANCH apr-util-${PORTVERSION}
pre-configure:
- ${DO_NADA}
+.for d in apr apr-util
+.for f in config.guess config.sub
+ ${CP} -f ${TEMPLATES}/${f} ${WRKDIR}/${d}-${PORTVERSION}/build/${f}
+ ${CHMOD} a+rx ${WRKDIR}/${d}-${PORTVERSION}/build/${f}
+.endfor
+.endfor
run-autotools:
cd ${WRKDIR}/apr-${PORTVERSION}; ${SETENV} ${SCRIPTS_ENV} LIBTOOL_M4=${LIBTOOL_M4} ${SH} ./buildconf
diff --git a/devel/apr2/Makefile b/devel/apr2/Makefile
index acf2479c9074..6959b03be4a8 100644
--- a/devel/apr2/Makefile
+++ b/devel/apr2/Makefile
@@ -120,7 +120,12 @@ post-extract:
${LN} -s apr-util-APU_0_9_BRANCH apr-util-${PORTVERSION}
pre-configure:
- ${DO_NADA}
+.for d in apr apr-util
+.for f in config.guess config.sub
+ ${CP} -f ${TEMPLATES}/${f} ${WRKDIR}/${d}-${PORTVERSION}/build/${f}
+ ${CHMOD} a+rx ${WRKDIR}/${d}-${PORTVERSION}/build/${f}
+.endfor
+.endfor
run-autotools:
cd ${WRKDIR}/apr-${PORTVERSION}; ${SETENV} ${SCRIPTS_ENV} LIBTOOL_M4=${LIBTOOL_M4} ${SH} ./buildconf