aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/acovea/Makefile29
-rw-r--r--devel/acovea/distinfo3
-rw-r--r--devel/acovea/files/patch-Makefile.in11
-rw-r--r--devel/acovea/files/patch-libacovea-acovea.cpp11
-rw-r--r--devel/acovea/pkg-descr9
-rw-r--r--devel/acovea/pkg-plist41
7 files changed, 105 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 77c3b4dc1af4..c2e974c0f232 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -15,6 +15,7 @@
SUBDIR += ace
SUBDIR += ace+tao
SUBDIR += ace+tao-doc
+ SUBDIR += acovea
SUBDIR += acpicatools
SUBDIR += activitymail
SUBDIR += adabindx
diff --git a/devel/acovea/Makefile b/devel/acovea/Makefile
new file mode 100644
index 000000000000..b580ea46804d
--- /dev/null
+++ b/devel/acovea/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: acovea
+# Date created: 2006-08-01
+# Whom: trasz <trasz@pin.if.uz.zgora.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= acovea
+PORTVERSION= 5.1.1
+CATEGORIES= devel
+MASTER_SITES= http://www.coyotegulch.com/distfiles/
+DISTNAME= libacovea-${PORTVERSION}
+
+MAINTAINER= trasz@pin.if.uz.zgora.pl
+COMMENT= Tool to find the "best" compiler options using genetic algorithm
+
+LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2 \
+ evocosm-3.1.1:${PORTSDIR}/devel/libevocosm
+
+INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= CPPFLAGS=-I${PREFIX}/include/ LDFLAGS=-L${PREFIX}/lib/
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,-lrt,,g' ${WRKSRC}/config/*
+
+.include <bsd.port.post.mk>
diff --git a/devel/acovea/distinfo b/devel/acovea/distinfo
new file mode 100644
index 000000000000..c99999378eea
--- /dev/null
+++ b/devel/acovea/distinfo
@@ -0,0 +1,3 @@
+MD5 (libacovea-5.1.1.tar.gz) = e3bfa6b782205bad083ba58a8b882158
+SHA256 (libacovea-5.1.1.tar.gz) = e84167ac683e6bf7720bd3edf1fc60e77961eb489d31fa2c1d0a34e7d67ae079
+SIZE (libacovea-5.1.1.tar.gz) = 363048
diff --git a/devel/acovea/files/patch-Makefile.in b/devel/acovea/files/patch-Makefile.in
new file mode 100644
index 000000000000..9eda7eaf3891
--- /dev/null
+++ b/devel/acovea/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Wed Aug 2 11:29:14 2006
++++ Makefile.in Wed Aug 2 11:30:00 2006
+@@ -600,7 +600,7 @@
+ @$(NORMAL_INSTALL)
+ if test -d $(srcdir)/config; then \
+ $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/config; \
+- for cfgfile in $(srcdir)/config/*; do \
++ for cfgfile in $(srcdir)/config/*.acovea $(srcdir)/config/*.example; do \
+ if test -f $$cfgfile; then \
+ $(INSTALL_DATA) $$cfgfile $(DESTDIR)$(pkgdatadir)/config; \
+ fi \
diff --git a/devel/acovea/files/patch-libacovea-acovea.cpp b/devel/acovea/files/patch-libacovea-acovea.cpp
new file mode 100644
index 000000000000..2f1fe5504639
--- /dev/null
+++ b/devel/acovea/files/patch-libacovea-acovea.cpp
@@ -0,0 +1,11 @@
+diff -urN libacovea.orig/acovea.cpp libacovea/acovea.cpp
+--- libacovea.orig/acovea.cpp Tue Aug 1 19:58:27 2006
++++ libacovea/acovea.cpp Tue Aug 1 19:58:38 2006
+@@ -43,6 +43,7 @@
+ #include <fcntl.h>
+ #include <unistd.h>
+ #include <sys/types.h>
++#include <sys/stat.h>
+ #include <sys/wait.h>
+
+ #include <vector>
diff --git a/devel/acovea/pkg-descr b/devel/acovea/pkg-descr
new file mode 100644
index 000000000000..089685b6fb50
--- /dev/null
+++ b/devel/acovea/pkg-descr
@@ -0,0 +1,9 @@
+ACOVEA (Analysis of Compiler Options via Evolutionary Algorithm)
+implements a genetic algorithm to find the "best" options for
+compiling programs with the GNU Compiler Collection (GCC) C and C++
+compilers. "Best", in this context, is defined as those options
+that produce the fastest executable program from a given source
+code. Acovea is a C++ framework that can be extended to test other
+programming languages and non-GCC compilers.
+
+WWW: http://www.coyotegulch.com/products/acovea/index.html
diff --git a/devel/acovea/pkg-plist b/devel/acovea/pkg-plist
new file mode 100644
index 000000000000..95025145a722
--- /dev/null
+++ b/devel/acovea/pkg-plist
@@ -0,0 +1,41 @@
+bin/runacovea
+lib/libacovea.so
+lib/libacovea-5.1.so
+lib/libacovea-5.1.so.5
+lib/libacovea.la
+lib/libacovea.a
+include/libacovea/acovea.h
+share/libacovea/config/Makefile.example
+share/libacovea/config/g++34_opteron.acovea
+share/libacovea/config/g++34_pentium3.acovea
+share/libacovea/config/g++34_pentium4.acovea
+share/libacovea/config/g++40_opteron.acovea
+share/libacovea/config/g++40_pentium4.acovea
+share/libacovea/config/g9540_opteron.acovea
+share/libacovea/config/g9540_pentium3.acovea
+share/libacovea/config/g9540_pentium4.acovea
+share/libacovea/config/gcc34_intel.acovea
+share/libacovea/config/gcc34_opteron.acovea
+share/libacovea/config/gcc34_opteron_makefile.acovea
+share/libacovea/config/gcc34_opteron_size.acovea
+share/libacovea/config/gcc34_pentium3.acovea
+share/libacovea/config/gcc34_pentium4.acovea
+share/libacovea/config/gcc40_opteron.acovea
+share/libacovea/config/gcc40_opteron_makefile.acovea
+share/libacovea/config/gcc40_opteron_nofm.acovea
+share/libacovea/config/gcc40_opteron_size.acovea
+share/libacovea/config/gcc40_pentium4.acovea
+share/libacovea/config/gcc41_opteron_nofm.acovea
+share/libacovea/benchmarks/almabench.c
+share/libacovea/benchmarks/distbench.c
+share/libacovea/benchmarks/evobench.c
+share/libacovea/benchmarks/fftbench.c
+share/libacovea/benchmarks/huffbench.c
+share/libacovea/benchmarks/linbench.c
+share/libacovea/benchmarks/linsmall.c
+share/libacovea/benchmarks/mat1bench.c
+share/libacovea/benchmarks/treebench.c
+@dirrm share/libacovea/config
+@dirrm share/libacovea/benchmarks
+@dirrm share/libacovea
+@dirrm include/libacovea