aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/Makefile1
-rw-r--r--games/freedink-engine/Makefile39
-rw-r--r--games/freedink-engine/distinfo3
-rw-r--r--games/freedink-engine/pkg-descr10
-rw-r--r--games/freedink-engine/pkg-plist12
-rw-r--r--games/freedink/Makefile33
-rw-r--r--games/freedink/distinfo3
-rw-r--r--games/freedink/pkg-descr10
8 files changed, 111 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index c66dc2fb5589..469761a1d51b 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -248,6 +248,7 @@
SUBDIR += freeciv-nox11
SUBDIR += freeciv-sounds
SUBDIR += freecol
+ SUBDIR += freedink
SUBDIR += freedink-data
SUBDIR += freedink-dfarc
SUBDIR += freedink-engine
diff --git a/games/freedink-engine/Makefile b/games/freedink-engine/Makefile
new file mode 100644
index 000000000000..dc895ab2c8c4
--- /dev/null
+++ b/games/freedink-engine/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: syncterm
+# Date created: 3 October 2006
+# Whom: shurd
+#
+# $FreeBSD$
+#
+
+PORTNAME= freedink
+PORTVERSION= 1.08.${PORTVER}
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= freedink
+PKGNAMESUFFIX= -engine
+
+MAINTAINER= shurd@sasktel.net
+COMMENT= Dink Smallwood RPG and RPG Construction Set
+
+LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
+
+USE_GMAKE= yes
+USE_SDL= sdl gfx ttf image mixer
+GNU_CONFIGURE= yes
+PORTVER= 20080920
+CONFIGURE_ARGS= --disable-static --disable-upx
+
+MAN6= freedink.6 freedinkedit.6 dink.6 dinkedit.6
+
+OPTIONS= EMBEDDED "Enable Embedded Resources" on
+
+.include <bsd.port.pre.mk>
+
+.ifdef WITHOUT_EMBEDDED
+CONFIGURE_ARGS+= --enable-embedded-resources
+LIB_DEPENDS+= libzip.0:${PORTSDIR}/archivers/libzip
+.else
+CONFIGURE_ARGS+= --disable-embedded-resources
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/freedink-engine/distinfo b/games/freedink-engine/distinfo
new file mode 100644
index 000000000000..cbafc0840c8c
--- /dev/null
+++ b/games/freedink-engine/distinfo
@@ -0,0 +1,3 @@
+MD5 (freedink-1.08.20080920.tar.gz) = 0e7a2a5af1c2e3498c7179e6cad02de9
+SHA256 (freedink-1.08.20080920.tar.gz) = deda4e5b992c514b6ccde3bfbff98880c28c6d91dfc67ca50ee0d0fa77d8bea8
+SIZE (freedink-1.08.20080920.tar.gz) = 785661
diff --git a/games/freedink-engine/pkg-descr b/games/freedink-engine/pkg-descr
new file mode 100644
index 000000000000..e3b8488b737b
--- /dev/null
+++ b/games/freedink-engine/pkg-descr
@@ -0,0 +1,10 @@
+Dink Smallwood is an adventure/role-playing game, similar to Zelda,
+made by RTsoft. Besides twisted humour, it includes the actual game
+editor, allowing players to create hundreds of new adventures called
+Dink Modules or D-Mods for short.
+
+GNU FreeDink is a new and portable version of the game engine, which
+runs the original game as well as its D-Mods, with close
+compatibility, under multiple platforms.
+
+This package contains the game engine alone.
diff --git a/games/freedink-engine/pkg-plist b/games/freedink-engine/pkg-plist
new file mode 100644
index 000000000000..27a112eae0b1
--- /dev/null
+++ b/games/freedink-engine/pkg-plist
@@ -0,0 +1,12 @@
+bin/dink
+bin/dinkedit
+bin/freedink
+bin/freedinkedit
+share/applications/freedink.desktop
+share/applications/freedinkedit.desktop
+%%DATADIR%%/LiberationSans-Regular.ttf
+%%DATADIR%%/jump.wav
+%%DATADIR%%/stop.wav
+share/pixmaps/freedink.png
+@dirrmtry %%DATADIR%%
+@dirrmtry share/applications
diff --git a/games/freedink/Makefile b/games/freedink/Makefile
new file mode 100644
index 000000000000..77ff4a04eacf
--- /dev/null
+++ b/games/freedink/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: syncterm
+# Date created: 3 October 2006
+# Whom: shurd
+#
+# $FreeBSD$
+#
+
+PORTNAME= freedink
+PORTVERSION= 1.08.${PORTVER}
+CATEGORIES= games
+MASTER_SITES= # none
+DISTFILES= # none
+EXTRACT_ONLY= # none
+
+MAINTAINER= shurd@sasktel.net
+COMMENT= Metaport for FreeDink engine and data
+
+RUN_DEPENDS= freedink:${PORTSDIR}/games/freedink-engine \
+ freedink-data>0:${PORTSDIR}/games/freedink-data \
+ dfarc:${PORTSDIR}/games/freedink-dfarc
+
+NO_BUILD= yes
+PORTVER= 20080920
+
+do-install: # empty
+
+pre-everything::
+ @${ECHO_MSG} "This is a meta-port, meaning that it just depends on its subparts of the port."
+ @${ECHO_MSG} "It won't build and install all the parts until you have typed make install"
+ @${ECHO_MSG} "This port does not ensure things are upgraded; use portupgrade if you want to"
+ @${ECHO_MSG} "upgrade FreeDink."
+
+.include <bsd.port.mk>
diff --git a/games/freedink/distinfo b/games/freedink/distinfo
new file mode 100644
index 000000000000..c6a9832b748a
--- /dev/null
+++ b/games/freedink/distinfo
@@ -0,0 +1,3 @@
+MD5 (freedink-1.08.20080920.zip) = 86ce05c2c31da54eb5851bb36cc690e2
+SHA256 (freedink-1.08.20080920.zip) = 8a3dc746e22c4902d392af5b4d16829911da583d7f2f47c65307afcaa74d4677
+SIZE (freedink-1.08.20080920.zip) = 1024328
diff --git a/games/freedink/pkg-descr b/games/freedink/pkg-descr
new file mode 100644
index 000000000000..e3b8488b737b
--- /dev/null
+++ b/games/freedink/pkg-descr
@@ -0,0 +1,10 @@
+Dink Smallwood is an adventure/role-playing game, similar to Zelda,
+made by RTsoft. Besides twisted humour, it includes the actual game
+editor, allowing players to create hundreds of new adventures called
+Dink Modules or D-Mods for short.
+
+GNU FreeDink is a new and portable version of the game engine, which
+runs the original game as well as its D-Mods, with close
+compatibility, under multiple platforms.
+
+This package contains the game engine alone.