aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/supertuxkart/Makefile1
-rw-r--r--games/supertuxkart/files/patch-lib_angelscript_source_as__config.h12
2 files changed, 12 insertions, 1 deletions
diff --git a/games/supertuxkart/Makefile b/games/supertuxkart/Makefile
index 1589a15fd52d..ccf2c71594d0 100644
--- a/games/supertuxkart/Makefile
+++ b/games/supertuxkart/Makefile
@@ -27,7 +27,6 @@ BROKEN_armv7= invokes x86 assembler
BROKEN_mips= invokes x86 assembler
BROKEN_mips64= invokes x86 assembler
BROKEN_sparc64= invokes x86 assembler
-BROKEN_powerpc64= invokes x86 assembler
BROKEN_i386= does not build (error: this directive must appear between .cfi_startproc and .cfi_endproc directives)
USES= alias cmake compiler:c++11-lib gettext gl \
diff --git a/games/supertuxkart/files/patch-lib_angelscript_source_as__config.h b/games/supertuxkart/files/patch-lib_angelscript_source_as__config.h
new file mode 100644
index 000000000000..029c1d2832b1
--- /dev/null
+++ b/games/supertuxkart/files/patch-lib_angelscript_source_as__config.h
@@ -0,0 +1,12 @@
+--- lib/angelscript/source/as_config.h.orig 2019-04-20 16:40:12 UTC
++++ lib/angelscript/source/as_config.h
+@@ -953,7 +953,9 @@
+ #define COMPLEX_RETURN_MASK (asOBJ_APP_CLASS_DESTRUCTOR | asOBJ_APP_CLASS_COPY_CONSTRUCTOR | asOBJ_APP_ARRAY)
+ #define THISCALL_PASS_OBJECT_POINTER_ON_THE_STACK
+ #define AS_X86
++ #elif defined(__powerpc64__)
++ #define AS_MAX_PORTABILITY
+ #elif defined(__LP64__)
+ #define AS_X64_GCC
+ #define HAS_128_BIT_PRIMITIVES
+ #define SPLIT_OBJS_BY_MEMBER_TYPES