aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/python26/Makefile7
-rw-r--r--lang/python27/Makefile7
-rw-r--r--lang/python31/Makefile3
-rw-r--r--lang/python32/Makefile9
4 files changed, 12 insertions, 14 deletions
diff --git a/lang/python26/Makefile b/lang/python26/Makefile
index 0297063930e4..a27aa08f3d3d 100644
--- a/lang/python26/Makefile
+++ b/lang/python26/Makefile
@@ -7,6 +7,7 @@
PORTNAME= python26
PORTVERSION= 2.6.8
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -50,10 +51,10 @@ BINLINKS_SUB= -e 's,smtpd,smtpd${PYTHON_VER},' \
-e 's,(idle|pydoc|python-shared|python),\1${PYTHON_VER},'
OPTIONS_DEFINE= THREADS SEM PTH PYMALLOC IPV6 FPECTL EXAMPLES
-OPTIONS_DEFAULT= THREADS UCS4 PYMALLOC IPV6
+OPTIONS_DEFAULT= THREADS UCS2 PYMALLOC IPV6
OPTIONS_SINGLE= UCS
-OPTIONS_SINGLE_UCS= UCS4 UCS2
+OPTIONS_SINGLE_UCS= UCS2 UCS4
.include <bsd.port.pre.mk>
@@ -105,7 +106,7 @@ CONFIGURE_ARGS+= --enable-unicode=ucs4
CONFIGURE_ARGS+= --enable-unicode=ucs2
.endif
-.if ${PORT_OPTIONS:MPYMALLOC}
+.if empty(PORT_OPTIONS:MPYMALLOC)
CONFIGURE_ARGS+= --without-pymalloc
.endif
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index cf57c895186e..94ed7116127a 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -7,6 +7,7 @@
PORTNAME= python27
PORTVERSION= 2.7.3
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -50,10 +51,10 @@ BINLINKS_SUB= -e 's,smtpd,smtpd${PYTHON_VER},' \
-e 's,(idle|pydoc|python-shared|python),\1${PYTHON_VER},'
OPTIONS_DEFINE= THREADS SEM PTH PYMALLOC IPV6 FPECTL EXAMPLES
-OPTIONS_DEFAULT= THREADS UCS4 PYMALLOC IPV6
+OPTIONS_DEFAULT= THREADS UCS2 PYMALLOC IPV6
OPTIONS_SINGLE= UCS
-OPTIONS_SINGLE_UCS= UCS4 UCS2
+OPTIONS_SINGLE_UCS= UCS2 UCS4
.include <bsd.port.pre.mk>
@@ -106,7 +107,7 @@ CONFIGURE_ARGS+= --enable-unicode=ucs4
CONFIGURE_ARGS+= --enable-unicode=ucs2
.endif
-.if ${PORT_OPTIONS:MPYMALLOC}
+.if empty(PORT_OPTIONS:MPYMALLOC)
CONFIGURE_ARGS+= --without-pymalloc
.endif
diff --git a/lang/python31/Makefile b/lang/python31/Makefile
index c1e6fb520ce3..24b14189dae3 100644
--- a/lang/python31/Makefile
+++ b/lang/python31/Makefile
@@ -7,6 +7,7 @@
PORTNAME= python31
PORTVERSION= 3.1.5
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -75,7 +76,7 @@ CONFIGURE_ARGS+= --without-threads
CONFIGURE_ARGS+= --with-wide-unicode
.endif
-.if ${PORT_OPTIONS:MPYMALLOC}
+.if empty(PORT_OPTIONS:MPYMALLOC)
CONFIGURE_ARGS+= --without-pymalloc
.endif
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 86c2fab26649..c0e33286ebcf 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -7,6 +7,7 @@
PORTNAME= python32
PORTVERSION= 3.2.3
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -50,12 +51,6 @@ BIN_FILES= python python-shared python-config python-shared-config \
BINLINKS_SUB= -e 's,(2to3|idle3|pydoc3),\1-${PYTHON_VER},' \
-e 's,(python-shared|python),\1${PYTHON_VER},'
-OPTIONS= THREADS "Enable thread support" on \
- UCS4 "Use UCS4 for unicode support" on \
- PYMALLOC "Use python's internal malloc" on \
- IPV6 "Enable IPv6 support" on \
- FPECTL "Enable floating point exception handling" off
-
OPTIONS_DEFINE= THREADS UCS4 PYMALLOC IPV6 FPECTL EXAMPLES
OPTIONS_DEFAULT= THREADS UCS4 PYMALLOC IPV6
@@ -83,7 +78,7 @@ CONFIGURE_ARGS+= --with-wide-unicode
PYABIVER:= ${PYABIVER}u
.endif
-.if ${PORT_OPTIONS:MPYMALLOC}
+.if empty(PORT_OPTIONS:MPYMALLOC)
CONFIGURE_ARGS+= --without-pymalloc
.else
PYABIVER:= m${PYABIVER}