aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--archivers/sharutils/Makefile3
-rw-r--r--ftp/ftpmirror/Makefile3
-rw-r--r--mail/mb2md/Makefile3
-rw-r--r--net/wmnd/Makefile2
-rw-r--r--net/xmlrpc-c-devel/Makefile2
-rw-r--r--net/xmlrpc-c/Makefile3
-rw-r--r--security/keychain/Makefile4
-rw-r--r--textproc/cdiff/Makefile2
-rw-r--r--textproc/po4a/Makefile5
-rw-r--r--www/sarg/Makefile2
-rw-r--r--x11/gmrun/Makefile2
-rw-r--r--x11/xcb-util-image/Makefile2
-rw-r--r--x11/xcb-util-keysyms/Makefile2
-rw-r--r--x11/xcb-util-renderutil/Makefile2
-rw-r--r--x11/xcb-util-wm/Makefile2
-rw-r--r--x11/xcb-util/Makefile2
16 files changed, 18 insertions, 23 deletions
diff --git a/archivers/sharutils/Makefile b/archivers/sharutils/Makefile
index 771df2dbf65c..4f30551c46d5 100644
--- a/archivers/sharutils/Makefile
+++ b/archivers/sharutils/Makefile
@@ -15,13 +15,12 @@ LICENSE= GPLv3
OPTIONS_DEFINE= NLS
USE_XZ= yes
-USE_PERL5= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-prefix=g --disable-uucode
INSTALL_TARGET= install install-man
MAN1= gshar.1 gunshar.1
INFO= sharutils
-USES= charsetfix
+USES= charsetfix perl5
.include <bsd.port.pre.mk>
diff --git a/ftp/ftpmirror/Makefile b/ftp/ftpmirror/Makefile
index 2da0d715718d..9a3664b53917 100644
--- a/ftp/ftpmirror/Makefile
+++ b/ftp/ftpmirror/Makefile
@@ -14,10 +14,9 @@ RUN_DEPENDS= p5-Socket6>=0:${PORTSDIR}/net/p5-Socket6
OPTIONS_DEFINE= DOCS
-USE_PERL5= yes
GNU_CONFIGURE= yes
-USES= shebangfix
+USES= shebangfix perl5
SHEBANG_FILES= ftpmirror rotate
CONFIGURE_ENV+= PERL="${PERL}" INSTALL_PROGRAM="${INSTALL_SCRIPT}"
diff --git a/mail/mb2md/Makefile b/mail/mb2md/Makefile
index 718b7a917875..e1e2b4822922 100644
--- a/mail/mb2md/Makefile
+++ b/mail/mb2md/Makefile
@@ -20,8 +20,7 @@ EXTRACT_AFTER_ARGS= > ${WRKDIR}/${PORTNAME}
NO_WRKSUBDIR= yes
NO_BUILD= yes
-USE_PERL5= yes
-USES= shebangfix
+USES= shebangfix perl5
SHEBANG_FILES= mb2md
PLIST_FILES= bin/mb2md
diff --git a/net/wmnd/Makefile b/net/wmnd/Makefile
index 84e842cb71af..b0a7441a0cf5 100644
--- a/net/wmnd/Makefile
+++ b/net/wmnd/Makefile
@@ -14,8 +14,8 @@ LICENSE= GPLv2
OPTIONS_DEFINE= EXAMPLES
+USES= gmake
USE_XORG= ice sm x11 xext xpm
-USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-dummy-driver
diff --git a/net/xmlrpc-c-devel/Makefile b/net/xmlrpc-c-devel/Makefile
index fb67fe7316d7..bc9e1013c891 100644
--- a/net/xmlrpc-c-devel/Makefile
+++ b/net/xmlrpc-c-devel/Makefile
@@ -21,8 +21,8 @@ CPLUSPLUS_DESC= Build xmlrpc-c c++ libs and tools
CONFLICTS= xmlrpc-epi-0.* xmlrpc-c-[0-9]*
+USES= gmake
USE_XZ= yes
-USE_GMAKE= yes
GNU_CONFIGURE= yes
MAKEFILE= GNUmakefile
MAKE_JOBS_UNSAFE= yes
diff --git a/net/xmlrpc-c/Makefile b/net/xmlrpc-c/Makefile
index 10a5b2af30bc..5df32ae647e9 100644
--- a/net/xmlrpc-c/Makefile
+++ b/net/xmlrpc-c/Makefile
@@ -20,8 +20,7 @@ LIBWWW_DESC= Compile with libwww support
CONFLICTS= xmlrpc-epi-0.* xmlrpc-c-devel-[0-9]*
-USE_PERL5= yes
-USE_GMAKE= yes
+USES= gmake perl5
USE_AUTOTOOLS= libtool:env
GNU_CONFIGURE= yes
MAKEFILE= GNUmakefile
diff --git a/security/keychain/Makefile b/security/keychain/Makefile
index 60984534418c..19063e518f9c 100644
--- a/security/keychain/Makefile
+++ b/security/keychain/Makefile
@@ -12,11 +12,11 @@ COMMENT= User-friendly front-end to ssh-agent(1)
LICENSE= GPLv2
+USES= gmake perl5
+USE_PERL5= build
OPTIONS_DEFINE= DOCS
FETCH_ARGS?= -Fpr
USE_BZIP2= yes
-USE_GMAKE= yes
-USE_PERL5_BUILD=yes
MAN1= keychain.1
diff --git a/textproc/cdiff/Makefile b/textproc/cdiff/Makefile
index 9b5930f4c693..e2eff84e7fce 100644
--- a/textproc/cdiff/Makefile
+++ b/textproc/cdiff/Makefile
@@ -14,7 +14,7 @@ COMMENT= Diff readability enhancer for color terminals
NO_BUILD= yes
NO_WRKSUBDIR= yes
-USE_PERL5= yes
+USES= perl5
SRC= ${.CURDIR}/src
diff --git a/textproc/po4a/Makefile b/textproc/po4a/Makefile
index 2327503258c9..acafecffdbae 100644
--- a/textproc/po4a/Makefile
+++ b/textproc/po4a/Makefile
@@ -17,9 +17,8 @@ BUILD_DEPENDS= p5-Term-ReadKey>=2.30:${PORTSDIR}/devel/p5-Term-ReadKey \
jade>=0:${PORTSDIR}/textproc/jade
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= gettext
-USE_PERL5= yes
-PERL_MODBUILD= yes
+USES= gettext perl5
+USE_PERL5= modbuild
WRKSRC= ${WRKDIR}/${PORTNAME}-v0.40.1
MANPREFIX= ${PREFIX}
diff --git a/www/sarg/Makefile b/www/sarg/Makefile
index 383980dc48f5..7813ef2e3815 100644
--- a/www/sarg/Makefile
+++ b/www/sarg/Makefile
@@ -18,8 +18,8 @@ OPTIONS_DEFAULT=GD PHP NLS PCRE LDAP ICONV
PHP_DESC= Install PHP for reporting generating
+USES= gmake
USE_AUTOTOOLS= autoconf aclocal
-USE_GMAKE= yes
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= CPPFLAGS=-I${LOCALBASE}/include \
diff --git a/x11/gmrun/Makefile b/x11/gmrun/Makefile
index c043192edc35..f455175b9fe6 100644
--- a/x11/gmrun/Makefile
+++ b/x11/gmrun/Makefile
@@ -14,8 +14,8 @@ LIB_DEPENDS= popt:${PORTSDIR}/devel/popt
OPTIONS_DEFINE= DOCS
+USES= gmake
USE_GNOME= gtk20
-USE_GMAKE= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/x11/xcb-util-image/Makefile b/x11/xcb-util-image/Makefile
index b5d61a175428..68032558bafd 100644
--- a/x11/xcb-util-image/Makefile
+++ b/x11/xcb-util-image/Makefile
@@ -11,8 +11,8 @@ COMMENT= A port of Xlib's XImage and XShmImage functions
LIB_DEPENDS= xcb-util:${PORTSDIR}/x11/xcb-util
#BUILD_DEPENDS= ${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf
+USES= gmake
USE_BZIP2= yes
-USE_GMAKE= yes
USE_LDCONFIG= yes
USE_XORG= xcb xorg-macros
#USE_XORG= xau xdmcp
diff --git a/x11/xcb-util-keysyms/Makefile b/x11/xcb-util-keysyms/Makefile
index 007e87bf60e7..90a56c613efe 100644
--- a/x11/xcb-util-keysyms/Makefile
+++ b/x11/xcb-util-keysyms/Makefile
@@ -11,8 +11,8 @@ COMMENT= Standard X key constants and conversion to/from keycodes
LIB_DEPENDS= xcb-util:${PORTSDIR}/x11/xcb-util
#BUILD_DEPENDS= ${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf
+USES= gmake
USE_BZIP2= yes
-USE_GMAKE= yes
USE_LDCONFIG= yes
USE_XORG= xcb xorg-macros
#USE_XORG= xau xdmcp
diff --git a/x11/xcb-util-renderutil/Makefile b/x11/xcb-util-renderutil/Makefile
index b8c3014e7f73..b40b77e958cb 100644
--- a/x11/xcb-util-renderutil/Makefile
+++ b/x11/xcb-util-renderutil/Makefile
@@ -11,8 +11,8 @@ COMMENT= Convenience functions for the Render extension
LIB_DEPENDS= xcb-util:${PORTSDIR}/x11/xcb-util
#BUILD_DEPENDS= ${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf
+USES= gmake
USE_BZIP2= yes
-USE_GMAKE= yes
USE_XORG= xcb xorg-macros
USE_LDCONFIG= yes
#USE_XORG= xau xdmcp
diff --git a/x11/xcb-util-wm/Makefile b/x11/xcb-util-wm/Makefile
index 5fa88f63d2ba..25904f51b721 100644
--- a/x11/xcb-util-wm/Makefile
+++ b/x11/xcb-util-wm/Makefile
@@ -11,8 +11,8 @@ COMMENT= Framework for window manager implementation
LIB_DEPENDS= xcb-util:${PORTSDIR}/x11/xcb-util
#BUILD_DEPENDS= ${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf
+USES= gmake
USE_BZIP2= yes
-USE_GMAKE= yes
USE_LDCONFIG= yes
USE_XORG= xcb xorg-macros
#USE_XORG= xau xdmcp
diff --git a/x11/xcb-util/Makefile b/x11/xcb-util/Makefile
index 6499b0577cd3..1cfc8301e67e 100644
--- a/x11/xcb-util/Makefile
+++ b/x11/xcb-util/Makefile
@@ -11,8 +11,8 @@ MASTER_SITES= http://xcb.freedesktop.org/dist/
MAINTAINER= garga@FreeBSD.org
COMMENT= A module with libxcb/libX11 extension/replacement libraries
+USES= gmake
USE_BZIP2= yes
-USE_GMAKE= yes
USE_LDCONFIG= yes
USE_XORG= xau xcb xdmcp xorg-macros
USE_AUTOTOOLS= libtool