aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--german/Makefile1
-rw-r--r--german/ding/Makefile32
-rw-r--r--german/ding/distinfo1
-rw-r--r--german/ding/pkg-comment1
-rw-r--r--german/ding/pkg-descr13
-rw-r--r--german/ding/pkg-plist3
6 files changed, 51 insertions, 0 deletions
diff --git a/german/Makefile b/german/Makefile
index ee75420d1547..0d0bac327984 100644
--- a/german/Makefile
+++ b/german/Makefile
@@ -5,6 +5,7 @@
SUBDIR += cheapcall
SUBDIR += citrix_ica
SUBDIR += dict
+ SUBDIR += ding
SUBDIR += ispell
SUBDIR += ispell-alt
SUBDIR += ispell-neu
diff --git a/german/ding/Makefile b/german/ding/Makefile
new file mode 100644
index 000000000000..0b3a6e45e240
--- /dev/null
+++ b/german/ding/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: ding
+# Date created: 5/25/2001
+# Whom: n@nectar.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= ding
+PORTVERSION= 1.1
+CATEGORIES= german
+MASTER_SITES= http://cgi.tu-chemnitz.de/ftp-home/pub/Local/urz/ding/ \
+ ftp://ftp.tu-chemnitz.de/pub/Local/urz/ding/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= nectar@FreeBSD.ORG
+
+RUN_DEPENDS= wish8.3:${PORTSDIR}/x11-toolkits/tk83 \
+ agrep:${PORTSDIR}/textproc/agrep
+
+USE_X_PREFIX= yes
+
+do-build:
+ ${SED} -E -e '1,/^exec/ s!wish!wish8.3!' \
+ -e 's!/usr/dict/ger-eng.txt!${PREFIX}/share/ding/ger-eng.txt!' \
+ ${WRKSRC}/ding > ${WRKSRC}/dingX
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/ding
+ ${INSTALL_SCRIPT} ${WRKSRC}/dingX ${PREFIX}/bin/ding
+ ${INSTALL_DATA} ${WRKSRC}/ger-eng.txt ${PREFIX}/share/ding/ger-eng.txt
+
+.include <bsd.port.mk>
diff --git a/german/ding/distinfo b/german/ding/distinfo
new file mode 100644
index 000000000000..be3a092d9bc0
--- /dev/null
+++ b/german/ding/distinfo
@@ -0,0 +1 @@
+MD5 (ding-1.1.tgz) = db04e4ef19b6d891e811f84b92b7c581
diff --git a/german/ding/pkg-comment b/german/ding/pkg-comment
new file mode 100644
index 000000000000..36cdb6b4565e
--- /dev/null
+++ b/german/ding/pkg-comment
@@ -0,0 +1 @@
+A German-English dictionary program for X windows/Unix
diff --git a/german/ding/pkg-descr b/german/ding/pkg-descr
new file mode 100644
index 000000000000..2a8f792a7424
--- /dev/null
+++ b/german/ding/pkg-descr
@@ -0,0 +1,13 @@
+Ding is a Dictionary lookup program for X windows/Unix. It comes with
+a German-English Dictionary with ca. 120,000 entries. It is an
+offline version of the dictionary found at:
+ <URL:http://dict.tu-chemnitz.de/>.
+
+It is based on Tk version >= 8.0 and uses the agrep for searching.
+
+It has many configuration options, such as search preferences,
+interface language (English or German), colors. It has history and
+help functions and comes with useful key and mouse bindings for quick
+and easy lookups.
+
+WWW: http://www-user.tu-chemnitz.de/~fri/ding/
diff --git a/german/ding/pkg-plist b/german/ding/pkg-plist
new file mode 100644
index 000000000000..ccfef01c6228
--- /dev/null
+++ b/german/ding/pkg-plist
@@ -0,0 +1,3 @@
+bin/ding
+share/ding/ger-eng.txt
+@dirrm share/ding