aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/xerces-c2-devel/Makefile2
-rw-r--r--textproc/xerces-c2-devel/files/patch-ab14
-rw-r--r--textproc/xerces-c2/Makefile2
-rw-r--r--textproc/xerces-c2/files/patch-ab14
-rw-r--r--textproc/xerces-c27/Makefile2
-rw-r--r--textproc/xerces-c27/files/patch-ab14
6 files changed, 45 insertions, 3 deletions
diff --git a/textproc/xerces-c2-devel/Makefile b/textproc/xerces-c2-devel/Makefile
index 1b8d9cf1e27e..14515e8ad5e0 100644
--- a/textproc/xerces-c2-devel/Makefile
+++ b/textproc/xerces-c2-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xerces-c2
PORTVERSION= 2.5.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_APACHE_XML}
MASTER_SITE_SUBDIR= xerces-c/source
diff --git a/textproc/xerces-c2-devel/files/patch-ab b/textproc/xerces-c2-devel/files/patch-ab
new file mode 100644
index 000000000000..dc9393db3e6e
--- /dev/null
+++ b/textproc/xerces-c2-devel/files/patch-ab
@@ -0,0 +1,14 @@
+--- src/xercesc/util/Transcoders/IconvFBSD/IconvFBSDTransService.cpp.orig Thu Mar 18 10:44:13 2004
++++ src/xercesc/util/Transcoders/IconvFBSD/IconvFBSDTransService.cpp Thu Mar 18 10:47:04 2004
+@@ -1340,6 +1340,11 @@
+ if (wBufPtr)
+ manager->deallocate(wBufPtr);//delete [] wBufPtr;
+
++ // iconvTo resp. iconv(3) doe NOT return number of characters
++ // converted but only number of non-reversible conversions;
++ // thus we need to calculate correct mblen on our own
++ mblen = ptr - toFill;
++
+ #endif /* !XML_USE_LIBICONV */
+
+ // Cap it off just in case
diff --git a/textproc/xerces-c2/Makefile b/textproc/xerces-c2/Makefile
index 1b8d9cf1e27e..14515e8ad5e0 100644
--- a/textproc/xerces-c2/Makefile
+++ b/textproc/xerces-c2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xerces-c2
PORTVERSION= 2.5.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_APACHE_XML}
MASTER_SITE_SUBDIR= xerces-c/source
diff --git a/textproc/xerces-c2/files/patch-ab b/textproc/xerces-c2/files/patch-ab
new file mode 100644
index 000000000000..dc9393db3e6e
--- /dev/null
+++ b/textproc/xerces-c2/files/patch-ab
@@ -0,0 +1,14 @@
+--- src/xercesc/util/Transcoders/IconvFBSD/IconvFBSDTransService.cpp.orig Thu Mar 18 10:44:13 2004
++++ src/xercesc/util/Transcoders/IconvFBSD/IconvFBSDTransService.cpp Thu Mar 18 10:47:04 2004
+@@ -1340,6 +1340,11 @@
+ if (wBufPtr)
+ manager->deallocate(wBufPtr);//delete [] wBufPtr;
+
++ // iconvTo resp. iconv(3) doe NOT return number of characters
++ // converted but only number of non-reversible conversions;
++ // thus we need to calculate correct mblen on our own
++ mblen = ptr - toFill;
++
+ #endif /* !XML_USE_LIBICONV */
+
+ // Cap it off just in case
diff --git a/textproc/xerces-c27/Makefile b/textproc/xerces-c27/Makefile
index 1b8d9cf1e27e..14515e8ad5e0 100644
--- a/textproc/xerces-c27/Makefile
+++ b/textproc/xerces-c27/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xerces-c2
PORTVERSION= 2.5.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_APACHE_XML}
MASTER_SITE_SUBDIR= xerces-c/source
diff --git a/textproc/xerces-c27/files/patch-ab b/textproc/xerces-c27/files/patch-ab
new file mode 100644
index 000000000000..dc9393db3e6e
--- /dev/null
+++ b/textproc/xerces-c27/files/patch-ab
@@ -0,0 +1,14 @@
+--- src/xercesc/util/Transcoders/IconvFBSD/IconvFBSDTransService.cpp.orig Thu Mar 18 10:44:13 2004
++++ src/xercesc/util/Transcoders/IconvFBSD/IconvFBSDTransService.cpp Thu Mar 18 10:47:04 2004
+@@ -1340,6 +1340,11 @@
+ if (wBufPtr)
+ manager->deallocate(wBufPtr);//delete [] wBufPtr;
+
++ // iconvTo resp. iconv(3) doe NOT return number of characters
++ // converted but only number of non-reversible conversions;
++ // thus we need to calculate correct mblen on our own
++ mblen = ptr - toFill;
++
+ #endif /* !XML_USE_LIBICONV */
+
+ // Cap it off just in case