aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/impressive/Makefile3
-rw-r--r--graphics/impressive/distinfo6
-rw-r--r--graphics/impressive/files/patch-impressive.py18
3 files changed, 4 insertions, 23 deletions
diff --git a/graphics/impressive/Makefile b/graphics/impressive/Makefile
index 103b07c6c388..4b9aae702612 100644
--- a/graphics/impressive/Makefile
+++ b/graphics/impressive/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= impressive
-PORTVERSION= 0.12.0
-PORTREVISION= 1
+PORTVERSION= 0.12.1
CATEGORIES= graphics python
MASTER_SITES= SF/${PORTNAME}/Impressive/${PORTVERSION}/
DISTNAME= Impressive-${PORTVERSION}
diff --git a/graphics/impressive/distinfo b/graphics/impressive/distinfo
index 0b8f8db237b3..4d82ffff6ddb 100644
--- a/graphics/impressive/distinfo
+++ b/graphics/impressive/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1558123299
-SHA256 (Impressive-0.12.0.tar.gz) = 7dc78de333e4a942036ba4bda53358799f493114f2f655b2ab2689b6fdc0587d
-SIZE (Impressive-0.12.0.tar.gz) = 209514
+TIMESTAMP = 1567453628
+SHA256 (Impressive-0.12.1.tar.gz) = 74a331f41e39a363b362dcadf861e3a300351d5ad5cfe033b5d47215c886f1e4
+SIZE (Impressive-0.12.1.tar.gz) = 210928
diff --git a/graphics/impressive/files/patch-impressive.py b/graphics/impressive/files/patch-impressive.py
deleted file mode 100644
index 094df9ec5c13..000000000000
--- a/graphics/impressive/files/patch-impressive.py
+++ /dev/null
@@ -1,18 +0,0 @@
---- impressive.py.orig 2018-02-04 20:31:39 UTC
-+++ impressive.py
-@@ -6332,7 +6332,14 @@ def run_main():
- print >>sys.stderr, "Impressive version:", __version__
- print >>sys.stderr, "Python version:", sys.version
- print >>sys.stderr, "PyGame version:", pygame.__version__
-- print >>sys.stderr, "PIL version:", Image.VERSION
-+ if hasattr(Image, "__version__"): # Pillow >= 5.2
-+ print >>sys.stderr, "PIL version: Pillow", Image.__version__
-+ elif hasattr(Image, "PILLOW_VERSION"): # Pillow < 7.0
-+ print >>sys.stderr, "PIL version: Pillow", Image.PILLOW_VERSION
-+ elif hasattr(Image, "VERSION"): # classic PIL or Pillow 1.x
-+ print >>sys.stderr, "PIL version: classic", Image.VERSION
-+ else:
-+ print >>sys.stderr, "PIL version: unknown"
- if PDFRenderer:
- print >>sys.stderr, "PDF renderer:", PDFRenderer.name
- else: