aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/soundtracker/Makefile45
-rw-r--r--audio/soundtracker/distinfo6
-rw-r--r--audio/soundtracker/files/patch-app__sample-editor.c21
-rw-r--r--audio/soundtracker/files/patch-app__tracer.c41
-rw-r--r--audio/soundtracker/files/patch-app__track-editor.c29
-rw-r--r--audio/soundtracker/files/patch-po::ja.po39
-rw-r--r--audio/soundtracker/pkg-plist11
7 files changed, 155 insertions, 37 deletions
diff --git a/audio/soundtracker/Makefile b/audio/soundtracker/Makefile
index 8060c123d2e6..aaba3e0dcf08 100644
--- a/audio/soundtracker/Makefile
+++ b/audio/soundtracker/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= soundtracker
-PORTVERSION= 0.6.7
-PORTREVISION= 3
+PORTVERSION= 0.6.8
CATEGORIES= audio gnome
MASTER_SITES= http://www.soundtracker.org/dl/%SUBDIR%/
MASTER_SITE_SUBDIR= v${PORTVERSION:R}
@@ -15,8 +14,7 @@ MASTER_SITE_SUBDIR= v${PORTVERSION:R}
MAINTAINER= ports@FreeBSD.org
COMMENT= Mod player/tracking tool which supports XM and MOD formats
-LIB_DEPENDS= sndfile.1:${PORTSDIR}/audio/libsndfile \
- jack.0:${PORTSDIR}/audio/jack
+LIB_DEPENDS= sndfile.1:${PORTSDIR}/audio/libsndfile
USE_X_PREFIX= yes
WANT_GNOME= yes
@@ -25,16 +23,12 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
.include <bsd.port.pre.mk>
+.if ${ARCH} != "i386" || defined(WITHOUT_X86_ASM)
+CONFIGURE_ARGS+= --disable-asm
+.endif
+
.if ${HAVE_GNOME:Mgnomelibs}!=""
PKGNAMESUFFIX= -gnome
USE_GNOME+= gnomelibs gnomeprefix
@@ -44,13 +38,34 @@ DATADIR= ${PREFIX}/share/gnome/${PORTNAME}
CONFIGURE_ARGS+= --disable-gnome
.endif
-.if ${ARCH} != "i386" || defined(WITHOUT_X86_ASM)
-CONFIGURE_ARGS+= --disable-asm
+.if defined(WITH_JACK)
+LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
+.else
+CONFIGURE_ARGS+= --disable-jack
+.endif
+
+.if defined(WITH_SDL)
+USE_SDL= sdl
+.else
+CONFIGURE_ARGS+= --disable-sdl
+.endif
+
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
.endif
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's| install-exec-local||g'
- ${REINPLACE_CMD} -e "s,-ldl,," ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-pthread -ldl||g' ${WRKSRC}/configure
+
+pre-build:
+.if !defined(WITHOUT_NLS)
+ cd ${WRKSRC}/po && ${LOCALBASE}/bin/msgfmt -c -o ja.gmo ja.po
+.endif
.include <bsd.port.post.mk>
diff --git a/audio/soundtracker/distinfo b/audio/soundtracker/distinfo
index 8e88426bbcb3..28d36a1c9ad3 100644
--- a/audio/soundtracker/distinfo
+++ b/audio/soundtracker/distinfo
@@ -1,3 +1,3 @@
-MD5 (soundtracker-0.6.7.tar.gz) = 9a5685e0a79fb10066d29baed652d324
-SHA256 (soundtracker-0.6.7.tar.gz) = 698ce17bdbb0712ca21d8bd9fca084505d435c5bc23d584eefc29d470931d999
-SIZE (soundtracker-0.6.7.tar.gz) = 875235
+MD5 (soundtracker-0.6.8.tar.gz) = 1e5a2ef689e214933e53f687b3a199bb
+SHA256 (soundtracker-0.6.8.tar.gz) = 03b2f2c0edba48457ec6178b0a10edfe3481254112936715603a21f638822f50
+SIZE (soundtracker-0.6.8.tar.gz) = 1016718
diff --git a/audio/soundtracker/files/patch-app__sample-editor.c b/audio/soundtracker/files/patch-app__sample-editor.c
new file mode 100644
index 000000000000..6db65ed09d6b
--- /dev/null
+++ b/audio/soundtracker/files/patch-app__sample-editor.c
@@ -0,0 +1,21 @@
+--- app/sample-editor.c.orig Sat Feb 25 21:26:05 2006
++++ app/sample-editor.c Sun Feb 26 13:05:51 2006
+@@ -2647,13 +2647,15 @@
+ static void
+ sample_editor_crop()
+ {
+- int start = sampledisplay->sel_start, end = sampledisplay->sel_end;
++ int start, end, l;
++
++ start = sampledisplay->sel_start, end = sampledisplay->sel_end;
+
+ if(current_sample == NULL || start == -1)
+ return;
+-
+- int l = current_sample->sample.length;
+
++ l = current_sample->sample.length;
++
+ sample_editor_lock_sample();
+ sample_editor_delete(current_sample, 0, start);
+ sample_editor_delete(current_sample, end - start, l - start);
diff --git a/audio/soundtracker/files/patch-app__tracer.c b/audio/soundtracker/files/patch-app__tracer.c
new file mode 100644
index 000000000000..393c41bc9cf4
--- /dev/null
+++ b/audio/soundtracker/files/patch-app__tracer.c
@@ -0,0 +1,41 @@
+--- app/tracer.c.orig Sat Feb 25 21:30:54 2006
++++ app/tracer.c Sun Feb 26 13:14:18 2006
+@@ -361,15 +361,19 @@
+ void
+ tracer_trace (int mixfreq, int songpos, int patpos)
+ {
++ st_mixer *real_mixer;
++ int stopsongpos, stoppatpos;
++ double rest, previous;
++
+ /* Attemp to take pitchband into account */
+ /* Test if tempo and BPM are traced */
+- st_mixer *real_mixer = mixer;
++ real_mixer = mixer;
+ mixer = &mixer_tracer;
+
+- int stopsongpos = songpos;
+- int stoppatpos = patpos;
++ stopsongpos = songpos;
++ stoppatpos = patpos;
+
+- double rest = 0, previous = 0; /* Fractional part of the samples */
++ rest = 0, previous = 0; /* Fractional part of the samples */
+
+ if((stoppatpos -= 1) < 0){
+ stopsongpos -= 1;
+@@ -381,12 +385,13 @@
+
+ while(1) {
+ double t;
++ guint32 samples;
+
+ double current = xmplayer_play();
+ t = current - previous + rest;
+ previous = current;
+
+- guint32 samples = t * mixfreq;
++ samples = t * mixfreq;
+ rest = t - (double)samples / (double)mixfreq;
+
+ tracer_mix(NULL, samples, NULL, 0);
diff --git a/audio/soundtracker/files/patch-app__track-editor.c b/audio/soundtracker/files/patch-app__track-editor.c
new file mode 100644
index 000000000000..c2f5ed22afd7
--- /dev/null
+++ b/audio/soundtracker/files/patch-app__track-editor.c
@@ -0,0 +1,29 @@
+--- app/track-editor.c.orig Sat Feb 25 21:30:54 2006
++++ app/track-editor.c Sun Feb 26 13:08:32 2006
+@@ -603,6 +603,8 @@
+ }
+
+ if(!GUI_ENABLED && !ASYNCEDIT) { // Recording mode
++ XMNote *note;
++
+ if(pressed){ // Insert note
+
+ for(c = 0; c < 32; c++){ // Cleanup
+@@ -624,7 +626,7 @@
+ reckey[c].chn = t->cursor_ch;
+ reckey[c].act = TRUE;
+
+- XMNote *note = &t->curpattern->channels[t->cursor_ch][t->patpos];
++ note = &t->curpattern->channels[t->cursor_ch][t->patpos];
+ note->note = i;
+ note->instrument = gui_get_current_instrument();
+ tracker_redraw_current_row(t);
+@@ -645,7 +647,7 @@
+ if (!insert_noteoff)
+ goto fin_note;
+
+- XMNote *note = &t->curpattern->channels[reckey[c].chn][t->patpos];
++ note = &t->curpattern->channels[reckey[c].chn][t->patpos];
+ note->note = 97;
+ note->instrument = 0;
+ tracker_redraw_current_row(t);
diff --git a/audio/soundtracker/files/patch-po::ja.po b/audio/soundtracker/files/patch-po::ja.po
index bf432fc77cf4..360d66a7d0fc 100644
--- a/audio/soundtracker/files/patch-po::ja.po
+++ b/audio/soundtracker/files/patch-po::ja.po
@@ -1,6 +1,6 @@
---- po/ja.po.orig Mon Jan 12 02:50:07 2004
-+++ po/ja.po Thu Jan 29 18:44:40 2004
-@@ -2,13 +2,13 @@
+--- po/ja.po.orig Sat Feb 25 22:25:08 2006
++++ po/ja.po Sun Feb 26 13:55:01 2006
+@@ -2,14 +2,14 @@
# Copyright (C) 1998-2000 Michael Krause <m.krause@tu-harburg.de>.
# Translators: Atsushi Yamagata <yamagata@plathome.co.jp>, 1999, 2000.
# Yuuki NINOMIYA <gm@smn.enjoy.ne.jp>, 1999, 2000.
@@ -10,55 +10,56 @@
msgid ""
msgstr ""
"Project-Id-Version: SoundTracker 0.3.10\n"
- "POT-Creation-Date: 2004-01-11 17:20+0100\n"
+ "Report-Msgid-Bugs-To: soundtracker-discuss@soundtracker.org\n"
+ "POT-Creation-Date: 2006-02-25 14:25+0100\n"
-"PO-Revision-Date: 2003-08-05 06:54+0900\n"
+"PO-Revision-Date: 2004-01-12 12:13+0900\n"
"Last-Translator: Junichi Uekawa <dancer@debian.org>\n"
"Language-Team: Debian Japanese project <debian-japanese@lists.debian.org>\n"
"MIME-Version: 1.0\n"
-@@ -549,6 +549,8 @@
+@@ -553,6 +553,8 @@
"Odd pattern rows contain data which will be lost after shrinking.\n"
"Do you want to continue anyway?"
msgstr ""
+"奇数のパターンの列は縮小すると失われます.\n"
+"続行しますか?"
- #: app/gui.c:497
+ #: app/gui.c:506
msgid ""
-@@ -556,6 +558,8 @@
- "Some data at the end of the pattern will be lost.Do you want to continue "
- "anyway?"
+@@ -560,6 +562,8 @@
+ "Some data at the end of the pattern will be lost.\n"
+ "Do you want to continue anyway?"
msgstr ""
+"拡張するにはパターンは長すぎます.\n"
+"パターンの最後のデータが一部失われる事になります.続行しますか?"
- #. No file was actually selected.
- #: app/gui.c:546 app/instrument-editor.c:212 app/sample-editor.c:1685
-@@ -1040,9 +1044,8 @@
+ #: app/gui.c:555 app/instrument-editor.c:212 app/sample-editor.c:1719
+ #: app/sample-editor.c:1915 app/sample-editor.c:1959
+@@ -1034,9 +1038,8 @@
msgstr "オクターブ下げる"
- #: app/menubar.c:520
+ #: app/menubar.c:526
-#, fuzzy
msgid "P_aste"
-msgstr "貼付"
+msgstr "貼付(_a)"
- #: app/menubar.c:525
+ #: app/menubar.c:531
msgid "_Jazz Edit Mode"
-@@ -1089,14 +1092,12 @@
+@@ -1087,14 +1090,12 @@
msgstr "パターンを読み込み(_o)"
- #: app/menubar.c:590
+ #: app/menubar.c:599
-#, fuzzy
msgid "Sh_rink Current Pattern"
-msgstr "現在のパターン"
+msgstr "現在のパターンを縮小(_r)"
- #: app/menubar.c:592
+ #: app/menubar.c:601
-#, fuzzy
msgid "_Expand Current Pattern"
-msgstr "現在のパターンを保存(_S)"
+msgstr "現在のパターンを拡張(_E)"
- #: app/menubar.c:599
- msgid "_Load XI..."
+ #: app/menubar.c:608
+ msgid "_Toggle Current Channel Permanentness"
diff --git a/audio/soundtracker/pkg-plist b/audio/soundtracker/pkg-plist
index 0026c7ef1c19..b2de5b58893f 100644
--- a/audio/soundtracker/pkg-plist
+++ b/audio/soundtracker/pkg-plist
@@ -2,6 +2,8 @@ bin/soundtracker
%%GNOME:%%share/gnome/apps/Multimedia/soundtracker.desktop
%%NLS%%share/locale/da/LC_MESSAGES/soundtracker.mo
%%NLS%%share/locale/de/LC_MESSAGES/soundtracker.mo
+%%NLS%%share/locale/en@boldquot/LC_MESSAGES/soundtracker.mo
+%%NLS%%share/locale/en@quot/LC_MESSAGES/soundtracker.mo
%%NLS%%share/locale/es/LC_MESSAGES/soundtracker.mo
%%NLS%%share/locale/fr/LC_MESSAGES/soundtracker.mo
%%NLS%%share/locale/gl/LC_MESSAGES/soundtracker.mo
@@ -11,9 +13,12 @@ bin/soundtracker
%%NLS%%share/locale/no/LC_MESSAGES/soundtracker.mo
%%NLS%%share/locale/pl/LC_MESSAGES/soundtracker.mo
%%NLS%%share/locale/ru/LC_MESSAGES/soundtracker.mo
+%%NLS%%share/locale/rw/LC_MESSAGES/soundtracker.mo
%%NLS%%share/locale/sk/LC_MESSAGES/soundtracker.mo
%%NLS%%share/locale/sl/LC_MESSAGES/soundtracker.mo
%%NLS%%share/locale/sv/LC_MESSAGES/soundtracker.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/soundtracker.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/soundtracker.mo
%%DATADIR%%/downarrow.xpm
%%DATADIR%%/flat.xpm
%%DATADIR%%/lock.xpm
@@ -25,3 +30,9 @@ bin/soundtracker
%%DATADIR%%/soundtracker_splash.png
%%DATADIR%%/stop.xpm
@dirrm %%DATADIR%%
+%%NLS%%@dirrm share/locale/rw/LC_MESSAGES
+%%NLS%%@dirrm share/locale/rw
+%%NLS%%@dirrm share/locale/en@quot/LC_MESSAGES
+%%NLS%%@dirrm share/locale/en@quot
+%%NLS%%@dirrm share/locale/en@boldquot/LC_MESSAGES
+%%NLS%%@dirrm share/locale/en@boldquot