aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/nagios-check_ports/Makefile28
-rw-r--r--net-mgmt/nagios-check_ports/distinfo3
-rw-r--r--net-mgmt/nagios-check_ports/pkg-descr2
-rw-r--r--net-mgmt/nagios-check_ports/pkg-plist2
5 files changed, 36 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index c60fdd6ac8b5..9f8a64373b87 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -106,6 +106,7 @@
SUBDIR += nagios
SUBDIR += nagios-certexp-plugin
SUBDIR += nagios-check_bacula
+ SUBDIR += nagios-check_ports
SUBDIR += nagios-devel
SUBDIR += nagios-pf-plugin
SUBDIR += nagios-plugins
diff --git a/net-mgmt/nagios-check_ports/Makefile b/net-mgmt/nagios-check_ports/Makefile
new file mode 100644
index 000000000000..3f425d4eb84e
--- /dev/null
+++ b/net-mgmt/nagios-check_ports/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: nagios-check_ports
+# Date created: 13 August 2008
+# Whom: Anders Troback
+#
+# $FreeBSD$
+#
+
+PORTNAME= check_ports
+PORTVERSION= 0.5.6
+CATEGORIES= net-mgmt
+MASTER_SITES= http://code.adminlife.net/check_ports/files/
+PKGNAMEPREFIX= nagios-
+
+MAINTAINER= freebsd@troback.com
+COMMENT= Nagios Plugin to monitor your FreeBSD Ports
+
+RUN_DEPENDS= portaudit:${PORTSDIR}/ports-mgmt/portaudit \
+ portversion:${PORTSDIR}/ports-mgmt/portupgrade
+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ @${MKDIR} ${PREFIX}/libexec/nagios
+ ${INSTALL_SCRIPT} ${WRKSRC}/check_ports ${PREFIX}/libexec/nagios/
+
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/nagios-check_ports/distinfo b/net-mgmt/nagios-check_ports/distinfo
new file mode 100644
index 000000000000..8fa0dfce6a20
--- /dev/null
+++ b/net-mgmt/nagios-check_ports/distinfo
@@ -0,0 +1,3 @@
+MD5 (check_ports-0.5.6.tar.gz) = 3c8094f30e421d685472c05e1d487018
+SHA256 (check_ports-0.5.6.tar.gz) = b3611501b8655ea65b5e9f66e40acb090638a92389cc6bdca02c7e58276c87da
+SIZE (check_ports-0.5.6.tar.gz) = 3184
diff --git a/net-mgmt/nagios-check_ports/pkg-descr b/net-mgmt/nagios-check_ports/pkg-descr
new file mode 100644
index 000000000000..030d9486a684
--- /dev/null
+++ b/net-mgmt/nagios-check_ports/pkg-descr
@@ -0,0 +1,2 @@
+Nagios Plugin to monitor your FreeBSD Ports Tree for updates or
+installed packages with known security vulnerabilities.
diff --git a/net-mgmt/nagios-check_ports/pkg-plist b/net-mgmt/nagios-check_ports/pkg-plist
new file mode 100644
index 000000000000..555edb28960e
--- /dev/null
+++ b/net-mgmt/nagios-check_ports/pkg-plist
@@ -0,0 +1,2 @@
+libexec/nagios/check_ports
+@dirrmtry libexec/nagios