aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/p5-B-Hooks-Parser/Makefile9
-rw-r--r--devel/p5-Const-Fast/Makefile8
-rw-r--r--devel/p5-Mixin-Linewise/Makefile8
-rw-r--r--devel/p5-Package-Stash/Makefile8
-rw-r--r--devel/p5-Params-Check/Makefile9
-rw-r--r--devel/p5-Path-Dispatcher/Makefile8
-rw-r--r--lang/p5-Parse-Perl/Makefile8
-rw-r--r--www/p5-Catalyst-Runtime/Makefile9
8 files changed, 8 insertions, 59 deletions
diff --git a/devel/p5-B-Hooks-Parser/Makefile b/devel/p5-B-Hooks-Parser/Makefile
index ac29e5bd5491..b51fc281b541 100644
--- a/devel/p5-B-Hooks-Parser/Makefile
+++ b/devel/p5-B-Hooks-Parser/Makefile
@@ -24,11 +24,4 @@ PERL_CONFIGURE= yes
MAN3= B::Hooks::Parser.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-BUILD_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
-RUN_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-Const-Fast/Makefile b/devel/p5-Const-Fast/Makefile
index b5cae6b76bcb..bedb07f1436a 100644
--- a/devel/p5-Const-Fast/Makefile
+++ b/devel/p5-Const-Fast/Makefile
@@ -27,10 +27,4 @@ PERL_CONFIGURE= yes
MAN3= Const::Fast.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-Mixin-Linewise/Makefile b/devel/p5-Mixin-Linewise/Makefile
index 90472471f922..748e9fc6622f 100644
--- a/devel/p5-Mixin-Linewise/Makefile
+++ b/devel/p5-Mixin-Linewise/Makefile
@@ -19,17 +19,11 @@ COMMENT= Write your linewise code for handles; this does the rest
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-.include <bsd.port.pre.mk>
-
BUILD_DEPENDS+= p5-Sub-Exporter>=0.900:${PORTSDIR}/devel/p5-Sub-Exporter \
p5-IO-String>=0:${PORTSDIR}/devel/p5-IO-String
RUN_DEPENDS+= p5-Sub-Exporter>=0.900:${PORTSDIR}/devel/p5-Sub-Exporter \
p5-IO-String>=0:${PORTSDIR}/devel/p5-IO-String
-.if ${PERL_LEVEL} < 501001
-TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
PERL_CONFIGURE= yes
MAN3= Mixin::Linewise::Readers.3 \
@@ -44,4 +38,4 @@ PLIST_DIRS+= %%SITE_PERL%%/Mixin/Linewise \
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Mixin/Linewise \
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Mixin
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-Package-Stash/Makefile b/devel/p5-Package-Stash/Makefile
index 40d7e37f755b..d0c05319f92d 100644
--- a/devel/p5-Package-Stash/Makefile
+++ b/devel/p5-Package-Stash/Makefile
@@ -35,10 +35,4 @@ PERL_CONFIGURE= yes
MAN3= Package::Stash.3 \
Package::Stash::PP.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-Params-Check/Makefile b/devel/p5-Params-Check/Makefile
index 36f0e6a8414d..5865ca836ca0 100644
--- a/devel/p5-Params-Check/Makefile
+++ b/devel/p5-Params-Check/Makefile
@@ -29,11 +29,4 @@ post-install:
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501000
-BUILD_DEPENDS+= p5-Locale-Maketext-Simple>=0:${PORTSDIR}/devel/p5-Locale-Maketext-Simple
-RUN_DEPENDS+= p5-Locale-Maketext-Simple>=0:${PORTSDIR}/devel/p5-Locale-Maketext-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-Path-Dispatcher/Makefile b/devel/p5-Path-Dispatcher/Makefile
index 1e5e64f536e2..af79f9676f43 100644
--- a/devel/p5-Path-Dispatcher/Makefile
+++ b/devel/p5-Path-Dispatcher/Makefile
@@ -49,10 +49,4 @@ MAN3= Path::Dispatcher::Path.3 \
Path::Dispatcher::Rule::Regex.3 \
Path::Dispatcher::Dispatch.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/p5-Parse-Perl/Makefile b/lang/p5-Parse-Perl/Makefile
index fd01fcc77d7b..a78e45ca6316 100644
--- a/lang/p5-Parse-Perl/Makefile
+++ b/lang/p5-Parse-Perl/Makefile
@@ -27,10 +27,4 @@ MAN3= Parse::Perl.3 \
Parse::Perl::CopHintsHash.3 \
Parse::Perl::Environment.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-RUN_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-Catalyst-Runtime/Makefile b/www/p5-Catalyst-Runtime/Makefile
index a86b29fd7ed7..542b5d455d18 100644
--- a/www/p5-Catalyst-Runtime/Makefile
+++ b/www/p5-Catalyst-Runtime/Makefile
@@ -110,11 +110,4 @@ MAN3= Catalyst.3 \
post-install:
@${CAT} ${PKGDIR}/pkg-message
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-BUILD_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
-RUN_DEPENDS+= p5-Module-Pluggable>=3.9:${PORTSDIR}/devel/p5-Module-Pluggable
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>