aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/soundtouch/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/audio/soundtouch/Makefile b/audio/soundtouch/Makefile
index 231cf027dda1..a6fc91682e15 100644
--- a/audio/soundtouch/Makefile
+++ b/audio/soundtouch/Makefile
@@ -25,7 +25,7 @@ post-patch: .SILENT
.endfor
${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g; \
- s|-O3|${CFLAGS}|; s|$$(prefix)/doc|$$(datadir)/doc|; \
+ s|-O3[^I]*|${CXXFLAGS} -|; s|$$(prefix)/doc|$$(datadir)/doc|; \
s|COPYING.TXT||'
# Fix for GCC 4.x
${REINPLACE_CMD} -e 's|SoundTouch::||' ${WRKSRC}/include/SoundTouch.h