aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Getopt-Compact/Makefile22
-rw-r--r--devel/p5-Getopt-Compact/distinfo3
-rw-r--r--devel/p5-Getopt-Compact/pkg-descr6
-rw-r--r--devel/p5-Getopt-Compact/pkg-plist7
5 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4a9b372ba3fd..5eff73f76d5a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1676,6 +1676,7 @@
SUBDIR += p5-Geo-ShapeFile
SUBDIR += p5-Getargs-Long
SUBDIR += p5-Getopt-ArgvFile
+ SUBDIR += p5-Getopt-Compact
SUBDIR += p5-Getopt-Declare
SUBDIR += p5-Getopt-Euclid
SUBDIR += p5-Getopt-GUI-Long
diff --git a/devel/p5-Getopt-Compact/Makefile b/devel/p5-Getopt-Compact/Makefile
new file mode 100644
index 000000000000..7d51f42d9665
--- /dev/null
+++ b/devel/p5-Getopt-Compact/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Getopt-Compact
+# Date created: July 16th 2010
+# Whom: Evgeniy Kosov <evgeniy@kosov.su>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Getopt-Compact
+PORTVERSION= 0.04
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= getopt processing in a compact statement with both long and short options, and usage functionality
+
+PERL_CONFIGURE= yes
+
+MAN3= Getopt::Compact.3 \
+ Getopt::Compact::PodMunger.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Getopt-Compact/distinfo b/devel/p5-Getopt-Compact/distinfo
new file mode 100644
index 000000000000..80b56e36b02d
--- /dev/null
+++ b/devel/p5-Getopt-Compact/distinfo
@@ -0,0 +1,3 @@
+MD5 (Getopt-Compact-0.04.tar.gz) = 5c4a8a82828b00bbf6d9da6b59f6e57d
+SHA256 (Getopt-Compact-0.04.tar.gz) = 47a6fd8f9facb54a363b63d46617fcf18106b3b4a95f7fcbcbd08955595c1d47
+SIZE (Getopt-Compact-0.04.tar.gz) = 9658
diff --git a/devel/p5-Getopt-Compact/pkg-descr b/devel/p5-Getopt-Compact/pkg-descr
new file mode 100644
index 000000000000..ad9fe756044a
--- /dev/null
+++ b/devel/p5-Getopt-Compact/pkg-descr
@@ -0,0 +1,6 @@
+This is yet another Getopt related module. Getopt::Compact is geared towards
+compactly and yet quite powerfully describing an option syntax. Options can
+be parsed, returned as a hashref of values, and/or displayed as a usage string
+or within the script POD.
+
+WWW: http://search.cpan.org/dist/Getopt-Compact/
diff --git a/devel/p5-Getopt-Compact/pkg-plist b/devel/p5-Getopt-Compact/pkg-plist
new file mode 100644
index 000000000000..587d00f42b6b
--- /dev/null
+++ b/devel/p5-Getopt-Compact/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Getopt/Compact.pm
+%%SITE_PERL%%/Getopt/Compact/PodMunger.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Getopt/Compact/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Getopt/Compact
+@dirrm %%SITE_PERL%%/Getopt/Compact
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Getopt
+@dirrmtry %%SITE_PERL%%/Getopt