aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/Makefile1
-rw-r--r--games/pipepanic/Makefile41
-rw-r--r--games/pipepanic/distinfo3
-rw-r--r--games/pipepanic/files/patch-Makefile17
-rw-r--r--games/pipepanic/pkg-descr6
-rw-r--r--games/pipepanic/pkg-plist8
6 files changed, 76 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 7364e1216226..2b4dd616fdd8 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -489,6 +489,7 @@
SUBDIR += pinball
SUBDIR += pioneers
SUBDIR += pipenightdreams
+ SUBDIR += pipepanic
SUBDIR += plonx
SUBDIR += pmars
SUBDIR += pmars-sdl
diff --git a/games/pipepanic/Makefile b/games/pipepanic/Makefile
new file mode 100644
index 000000000000..8c61a0a514ba
--- /dev/null
+++ b/games/pipepanic/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: pipepanic
+# Date created: 20 May 2006
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pipepanic
+PORTVERSION= 0.1.3
+CATEGORIES= games
+MASTER_SITES= http://www.users.waitrose.com/~thunor/pipepanic/dload/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-source
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= A pipe connecting game using libSDL
+
+USE_SDL= sdl
+
+PORTDOCS= README
+DATAFILES= ascii15.bmp ascii30.bmp digits24.bmp \
+ digits48.bmp tiles24.bmp tiles48.bmp
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|SDL/|SDL11/|' ${WRKSRC}/main.c
+ @${REINPLACE_CMD} \
+ -e '/^#define DATADIR/ s|.*|#define DATADIR "${DATADIR}/"|' \
+ ${WRKSRC}/main.h
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+.for f in ${DATAFILES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DATADIR}
+.endfor
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/pipepanic/distinfo b/games/pipepanic/distinfo
new file mode 100644
index 000000000000..3b685bfb6910
--- /dev/null
+++ b/games/pipepanic/distinfo
@@ -0,0 +1,3 @@
+MD5 (pipepanic-0.1.3-source.tar.gz) = 99b68e990012b2f58c184b8ba9e4fb4d
+SHA256 (pipepanic-0.1.3-source.tar.gz) = 4b02249c92228b03f4cc3c1d999cacf3fe52c16df53c6bf76fc6c1e2caa74318
+SIZE (pipepanic-0.1.3-source.tar.gz) = 232200
diff --git a/games/pipepanic/files/patch-Makefile b/games/pipepanic/files/patch-Makefile
new file mode 100644
index 000000000000..f198661efc3e
--- /dev/null
+++ b/games/pipepanic/files/patch-Makefile
@@ -0,0 +1,17 @@
+--- Makefile.orig Wed May 17 00:11:29 2006
++++ Makefile Sat May 20 18:49:20 2006
+@@ -3,11 +3,10 @@
+ TARGET=pipepanic
+
+ # Settings for x86.
+-CC=gcc
+-CFLAGS=-O2 -Wall -pedantic `sdl-config --cflags`
+-LINK=gcc
++CFLAGS+=`$(SDL_CONFIG) --cflags`
++LINK=$(CC)
+ LDFLAGS=
+-LIBS=`sdl-config --libs`
++LIBS=`$(SDL_CONFIG) --libs`
+
+ all:
+ $(CC) $(CFLAGS) -c $(SOURCES)
diff --git a/games/pipepanic/pkg-descr b/games/pipepanic/pkg-descr
new file mode 100644
index 000000000000..a49d2ae7a56e
--- /dev/null
+++ b/games/pipepanic/pkg-descr
@@ -0,0 +1,6 @@
+A pipe connecting game using libSDL that is playable on Linux PCs and the Sharp
+Zaurus. Connect as many different shaped pipes together as possible within the
+time given. Comes with built-in help, is primarily mouse/stylus driven and can
+be played in different resolutions and orientations.
+
+WWW: http://thunor.org.uk/pipepanic
diff --git a/games/pipepanic/pkg-plist b/games/pipepanic/pkg-plist
new file mode 100644
index 000000000000..7d10d75fe93d
--- /dev/null
+++ b/games/pipepanic/pkg-plist
@@ -0,0 +1,8 @@
+bin/pipepanic
+%%DATADIR%%/ascii15.bmp
+%%DATADIR%%/ascii30.bmp
+%%DATADIR%%/digits24.bmp
+%%DATADIR%%/digits48.bmp
+%%DATADIR%%/tiles24.bmp
+%%DATADIR%%/tiles48.bmp
+@dirrm %%DATADIR%%