aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/dokuwiki-devel/Makefile7
-rw-r--r--www/dokuwiki/Makefile4
2 files changed, 10 insertions, 1 deletions
diff --git a/www/dokuwiki-devel/Makefile b/www/dokuwiki-devel/Makefile
index ac3324112a4c..8312b7d79005 100644
--- a/www/dokuwiki-devel/Makefile
+++ b/www/dokuwiki-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= dokuwiki
PORTVERSION= ${DIST_VER:S/${PORTNAME}//:S/-//g}
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= LOCAL/chinsan/${PORTNAME} \
http://dev.splitbrain.org/browse/snapshots/
@@ -26,6 +27,8 @@ DOKUWIKI_DIR?= www/${PORTNAME}
PLIST_SUB= DOKUWIKI_DIR=${DOKUWIKI_DIR}
TEMP_PLIST= ${WRKDIR}/temp-pkg-plist
+REINPLACE_ARGS= -i ''
+
.include <bsd.port.pre.mk>
# This target is only meant to be used by the port maintainer.
@@ -36,6 +39,10 @@ x-generate-plist:
${SED} -e 's|^|@dirrm %%DOKUWIKI_DIR%%/|' >> ${TEMP_PLIST} \
&& ${ECHO_CMD} "@dirrmtry %%DOKUWIKI_DIR%%" >> ${TEMP_PLIST}
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/bin|${LOCALBASE}/bin|' ${WRKSRC}/bin/*.php
+ @${FIND} ${WRKSRC}/bin -name '*.orig' -delete
+
do-install:
# Data files
-${MKDIR} ${PREFIX}/${DOKUWIKI_DIR}
diff --git a/www/dokuwiki/Makefile b/www/dokuwiki/Makefile
index c7dee7393b1a..6194afb7fd75 100644
--- a/www/dokuwiki/Makefile
+++ b/www/dokuwiki/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dokuwiki
PORTVERSION= ${DIST_VER:S/${PORTNAME}//:S/-//g}
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.splitbrain.org/_media/projects/dokuwiki/ \
LOCAL/chinsan/${PORTNAME}
@@ -42,6 +42,8 @@ x-generate-plist:
post-patch:
@${REINPLACE_CMD} -e 's|9|10|' ${WRKSRC}/conf/msg
@${FIND} ${WRKSRC} -name '*.orig' -delete
+ @${REINPLACE_CMD} -e 's|/usr/bin|${LOCALBASE}/bin|' ${WRKSRC}/bin/*.php
+ @${FIND} ${WRKSRC}/bin -name '*.orig' -delete
do-install:
# Data files