aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--astro/celestia/Makefile1
-rw-r--r--astro/fooseti/Makefile1
-rw-r--r--astro/jday/Makefile1
-rw-r--r--databases/db3/Makefile4
-rw-r--r--devel/fam/Makefile1
-rw-r--r--devel/gengetopt/Makefile1
6 files changed, 7 insertions, 2 deletions
diff --git a/astro/celestia/Makefile b/astro/celestia/Makefile
index 94ff44260784..2e7597ca611a 100644
--- a/astro/celestia/Makefile
+++ b/astro/celestia/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
OPTIONS= KDE "KDE support" off
OPTIONS+= LUA "Lua support" off
PLIST= ${WRKDIR}/pkg-plist
diff --git a/astro/fooseti/Makefile b/astro/fooseti/Makefile
index d0b11eacdcf7..d109291c1d38 100644
--- a/astro/fooseti/Makefile
+++ b/astro/fooseti/Makefile
@@ -16,6 +16,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= GTK+ frontend to SETI@Home
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
PLIST_FILES= bin/fooseti
USE_GETTEXT= yes
USE_GNOME= gtk12
diff --git a/astro/jday/Makefile b/astro/jday/Makefile
index c1ef3be840c2..ff70061a3250 100644
--- a/astro/jday/Makefile
+++ b/astro/jday/Makefile
@@ -14,6 +14,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Astronomical julian date calculator
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= jday.1
diff --git a/databases/db3/Makefile b/databases/db3/Makefile
index 41cffb7c8700..ac756e230cc8 100644
--- a/databases/db3/Makefile
+++ b/databases/db3/Makefile
@@ -32,8 +32,8 @@ CONFIGURE_ARGS= --enable-compat185 \
--enable-dump185 --enable-cxx \
--enable-dynamic \
--prefix=${PREFIX} \
- --includedir=${PREFIX}/include/db3 \
- --target=${ARCH}-portbld-freebsd${OSREL}
+ --includedir=${PREFIX}/include/db3
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
INSTALL_TARGET= install_include install_lib install_utilities
.if !defined(NOPORTDOCS)
INSTALL_TARGET+= install_docs docdir=${DOCSDIR}
diff --git a/devel/fam/Makefile b/devel/fam/Makefile
index 6863ebdeaf95..0ad8ed14c3c0 100644
--- a/devel/fam/Makefile
+++ b/devel/fam/Makefile
@@ -22,6 +22,7 @@ CFLAGS+= -Wno-deprecated
USE_AUTOMAKE_VER=15
USE_LIBTOOL_VER=13
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
INSTALLS_SHLIB= yes
diff --git a/devel/gengetopt/Makefile b/devel/gengetopt/Makefile
index d4dcbb281fd5..016b3fd6db27 100644
--- a/devel/gengetopt/Makefile
+++ b/devel/gengetopt/Makefile
@@ -16,6 +16,7 @@ MAINTAINER= cyrille.lefevre@laposte.net
COMMENT= A tool for generating a C function which parses command line arguments
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
MAN1= gengetopt.1