aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/audacity/Makefile1
-rw-r--r--databases/postgresql92-server/Makefile1
-rw-r--r--databases/tarantool/Makefile1
-rw-r--r--databases/tokyocabinet/Makefile1
-rw-r--r--lang/spidermonkey170/Makefile1
-rw-r--r--lang/spidermonkey185/Makefile1
-rw-r--r--lang/spidermonkey24/Makefile1
-rw-r--r--multimedia/webcamd/Makefile1
-rw-r--r--net-mgmt/collectd5/Makefile1
-rw-r--r--net/nakenchat/Makefile1
-rw-r--r--net/samba42/Makefile1
-rw-r--r--net/samba43/Makefile1
-rw-r--r--net/samba44/Makefile1
-rw-r--r--security/bro/Makefile1
-rw-r--r--security/broccoli/Makefile1
-rw-r--r--www/middleman/Makefile1
-rw-r--r--www/mongoose/Makefile1
17 files changed, 0 insertions, 17 deletions
diff --git a/audio/audacity/Makefile b/audio/audacity/Makefile
index 4aa96f7befbe..6e6749e1a2de 100644
--- a/audio/audacity/Makefile
+++ b/audio/audacity/Makefile
@@ -47,7 +47,6 @@ OPTIONS_DEFINE_i386= SSE
OPTIONS_DEFAULT_amd64= SSE
OPTIONS_DEFAULT_i386= ${MACHINE_CPU:tu:MSSE}
-DEBUG_DESC= Enable debug support
DYNLOAD_DESC= Enable dynamic loading of lame and FFmpeg
LAME_DESC= Use lame for import and export support
LV2_DESC= Add LV2 plug-in support
diff --git a/databases/postgresql92-server/Makefile b/databases/postgresql92-server/Makefile
index 9341deb76ee8..e06e95718825 100644
--- a/databases/postgresql92-server/Makefile
+++ b/databases/postgresql92-server/Makefile
@@ -106,7 +106,6 @@ MIT_KRB5_DESC= Build with MIT kerberos support
HEIMDAL_KRB5_DESC= Builds with Heimdal kerberos
GSSAPI_DESC= Build with GSSAPI support
OPTIMIZED_CFLAGS_DESC= Builds with compiler optimizations (-O3)
-DEBUG_DESC= Builds with debugging symbols
OPTIONS_DEFINE+= SSL
SSL_DESC= Build with OpenSSL support
diff --git a/databases/tarantool/Makefile b/databases/tarantool/Makefile
index 3562c65cc901..07722c177bb9 100644
--- a/databases/tarantool/Makefile
+++ b/databases/tarantool/Makefile
@@ -44,7 +44,6 @@ PLIST_SUB+= TT_USER=${USERS} \
TT_RUNDIR=${TT_RUNDIR}
OPTIONS_DEFINE= DEBUG
-DEBUG_DESC= Enable debug
NOT_FOR_ARCHS= sparc64
NOT_FOR_ARCHS_REASON= not yet ported to this architecture
diff --git a/databases/tokyocabinet/Makefile b/databases/tokyocabinet/Makefile
index d62b1d277fcb..28a4a4ab3a39 100644
--- a/databases/tokyocabinet/Makefile
+++ b/databases/tokyocabinet/Makefile
@@ -23,7 +23,6 @@ OPTIONS_DEFINE= DEBUG DEVEL FASTEST LZMA LZO PTHREAD PROFILE SHARED SWAB UYIELD
OPTIONS_DEFAULT= PTHREAD SHARED
OPTIONS_SUB= yes
-DEBUG_DESC= Debugging support
DEVEL_DESC= Development build
FASTEST_DESC= Fastest run
LZMA_DESC= LZMA codec
diff --git a/lang/spidermonkey170/Makefile b/lang/spidermonkey170/Makefile
index 00637b11cd2d..b630b211706b 100644
--- a/lang/spidermonkey170/Makefile
+++ b/lang/spidermonkey170/Makefile
@@ -31,7 +31,6 @@ OPTIONS_DEFINE= DEBUG DTRACE GCZEAL JEMALLOC METHODJIT OPTIMIZE READLINE \
OPTIONS_DEFAULT= METHODJIT OPTIMIZE READLINE THREADSAFE TRACEJIT
OPTIONS_SUB= yes
-DEBUG_DESC= Enable Debug build
DEBUG_CONFIGURE_ENABLE= debug debug-symbols
DEBUG_CONFIGURE_DISABLE=debug
DTRACE_DESC= Build with DTrace probes # move to bsd.options.desc.mk
diff --git a/lang/spidermonkey185/Makefile b/lang/spidermonkey185/Makefile
index b8e20e4d8ab5..eb5309d8ecce 100644
--- a/lang/spidermonkey185/Makefile
+++ b/lang/spidermonkey185/Makefile
@@ -40,7 +40,6 @@ OPTIONS_DEFINE= DEBUG GCZEAL JEMALLOC METHODJIT OPTIMIZE READLINE \
OPTIONS_DEFAULT= METHODJIT OPTIMIZE READLINE THREADSAFE TRACEJIT
-DEBUG_DESC= Enable Debug build
GCZEAL_DESC= Enable Zealous garbage collecting
JEMALLOC_DESC= Use jemalloc as memory allocator
METHODJIT_DESC= Enable method JIT support
diff --git a/lang/spidermonkey24/Makefile b/lang/spidermonkey24/Makefile
index fd0da5bc8067..98f0d7bb2498 100644
--- a/lang/spidermonkey24/Makefile
+++ b/lang/spidermonkey24/Makefile
@@ -33,7 +33,6 @@ OPTIONS_DEFINE= DEBUG GCZEAL JEMALLOC METHODJIT OPTIMIZE READLINE \
OPTIONS_DEFAULT= METHODJIT OPTIMIZE READLINE THREADSAFE TRACEJIT
OPTIONS_SUB= yes
-DEBUG_DESC= Enable Debug build
DEBUG_CONFIGURE_ENABLE= debug debug-symbols
DEBUG_CONFIGURE_DISABLE=debug
DTRACE_CONFIGURE_ENABLE=dtrace profiling
diff --git a/multimedia/webcamd/Makefile b/multimedia/webcamd/Makefile
index a91db7fb1e39..bb715bfe7984 100644
--- a/multimedia/webcamd/Makefile
+++ b/multimedia/webcamd/Makefile
@@ -44,7 +44,6 @@ HAL_MAKE_ARGS= HAVE_HAL="YES"
HAL_SUB_LIST= LIBHAL="${LOCALBASE}/lib/libhal.so:${LOCALBASE}/lib/libdbus-1.so:"
HAL_SUB_LIST_OFF= LIBHAL=""
-DEBUG_DESC= Build with debugging support
DEBUG_MAKE_ARGS= HAVE_DEBUG="YES"
VT_CLIENT_DESC= Build with vTuner client support
diff --git a/net-mgmt/collectd5/Makefile b/net-mgmt/collectd5/Makefile
index b9f84baf7db0..b4a1b4949e1b 100644
--- a/net-mgmt/collectd5/Makefile
+++ b/net-mgmt/collectd5/Makefile
@@ -38,7 +38,6 @@ CURL_DESC= Enable curl-based plugins (apache, nginx, etc)
CURL_JSON_DESC= Enable curl_json plugin (implies curl and json)
CURL_XML_DESC= Enable ascent, bind, curl_xml plugins (implies curl and xml)
DBI_DESC= Enable dbi plugin
-DEBUG_DESC= Enable debugging
GCRYPT_DESC= Build with libgcrypt
IPMI_DESC= Enable OpenIPMI plugin
JSON_DESC= Enable JSON plugins
diff --git a/net/nakenchat/Makefile b/net/nakenchat/Makefile
index 917ef0954fcc..d26d6bda3bc0 100644
--- a/net/nakenchat/Makefile
+++ b/net/nakenchat/Makefile
@@ -19,7 +19,6 @@ OPTIONS_DEFINE= NOKEEPALIVE NOUSERCHANLIST DEBUG HIDDENCAVES DOTQ \
NOKEEPALIVE_DESC= Disable socket keepalive option
NOUSERCHANLIST_DESC= Disable userlist based on channel
-DEBUG_DESC= Compile in debug code
HIDDENCAVES_DESC= Enable hidden caves feature
DOTQ_DESC= Compile in .Q option
FUSERLIST_DESC= Support saving current userlist to a file
diff --git a/net/samba42/Makefile b/net/samba42/Makefile
index 55971f6cda81..e5c3c632bd70 100644
--- a/net/samba42/Makefile
+++ b/net/samba42/Makefile
@@ -128,7 +128,6 @@ AIO_SUPPORT_DESC= Asyncronous IO support
DNSUPDATE_DESC= Dynamic DNS update (require ADS)
EXP_MODULES_DESC= Experimental modules
FAM_DESC= File Alteration Monitor support
-DEBUG_DESC= With debug information in the binaries
LDAP_DESC= LDAP client support
PAM_SMBPASS_DESC= PAM authentication via passdb backends
PTHREADPOOL_DESC= Pthread pool
diff --git a/net/samba43/Makefile b/net/samba43/Makefile
index fd31fa878bb6..96086cafa9e0 100644
--- a/net/samba43/Makefile
+++ b/net/samba43/Makefile
@@ -128,7 +128,6 @@ AIO_SUPPORT_DESC= Asyncronous IO support
DNSUPDATE_DESC= Dynamic DNS update (require ADS)
EXP_MODULES_DESC= Experimental modules
FAM_DESC= File Alteration Monitor support
-DEBUG_DESC= With debug information in the binaries
LDAP_DESC= LDAP client support
PAM_SMBPASS_DESC= PAM authentication via passdb backends
PTHREADPOOL_DESC= Pthread pool
diff --git a/net/samba44/Makefile b/net/samba44/Makefile
index d1a041bd5245..c5e0a234a228 100644
--- a/net/samba44/Makefile
+++ b/net/samba44/Makefile
@@ -128,7 +128,6 @@ ADS_DESC= Active Directory client support
DNSUPDATE_DESC= Dynamic DNS update (require ADS)
EXP_MODULES_DESC= Experimental modules
FAM_DESC= File Alteration Monitor support
-DEBUG_DESC= With debug information in the binaries
LDAP_DESC= LDAP client support
PAM_SMBPASS_DESC= PAM authentication via passdb backends
PTHREADPOOL_DESC= Pthread pool
diff --git a/security/bro/Makefile b/security/bro/Makefile
index 4cfac9f2cd3a..56a129d2b015 100644
--- a/security/bro/Makefile
+++ b/security/bro/Makefile
@@ -60,7 +60,6 @@ OPTIONS_SUB= yes
BROCCOLI_DESC= Build support for libbroccoli communications
BROCTL_DESC= BroControl support (implies BROCCOLI and IPSUMDUMP)
BROKER_DESC= Enable the Broker communication library
-DEBUG_DESC= Compile in debugging mode
IPSUMDUMP_DESC= Enables traffic summaries
LBL_CF_DESC= Unix time to formated time/date filter support
LBL_HF_DESC= Address to hostname filter support
diff --git a/security/broccoli/Makefile b/security/broccoli/Makefile
index e641cce9b358..30a4ee5b0372 100644
--- a/security/broccoli/Makefile
+++ b/security/broccoli/Makefile
@@ -39,7 +39,6 @@ OPTIONS_SUB=
OPTIONS_DEFAULT= PYTHON
-DEBUG_DESC= Compile in debugging mode
PYTHON_DESC= Build python bindings for broccoli
RUBY_DESC= Build ruby bindings for broccoli
diff --git a/www/middleman/Makefile b/www/middleman/Makefile
index 4da26d2b35d9..1056405a9393 100644
--- a/www/middleman/Makefile
+++ b/www/middleman/Makefile
@@ -13,7 +13,6 @@ COMMENT= Robust proxy server
OPTIONS_DEFINE= SYSLOG DEBUG MTIME DOCS
SYSLOG_DESC= Enable syslog support
-DEBUG_DESC= Enable debugging support
MTIME_DESC= Enable mtime support
SYSLOG_CONFIGURE_ON= --enable-syslog
diff --git a/www/mongoose/Makefile b/www/mongoose/Makefile
index 563e65e2add3..2df549e426a0 100644
--- a/www/mongoose/Makefile
+++ b/www/mongoose/Makefile
@@ -41,7 +41,6 @@ SSI_DESC= Enable SSI
THREADS_DESC= Enable threads
SSL_DESC= Enable SSL
IPV6_DESC= Enable IPv6 support
-DEBUG_DESC= Build with debug enabled
DEBUG_HEXDUMP_DESC= Enable hexdump of sent and received traffic
SSL_USES= ssl