aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/scr_ipfm/Makefile36
-rw-r--r--net/scr_ipfm/distinfo1
-rw-r--r--net/scr_ipfm/pkg-descr10
-rw-r--r--net/scr_ipfm/pkg-message3
-rw-r--r--net/scr_ipfm/pkg-plist55
6 files changed, 106 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index a906876e9a2e..7e4f51046e02 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -651,6 +651,7 @@
SUBDIR += scdp
SUBDIR += scli
SUBDIR += scotty3
+ SUBDIR += scr_ipfm
SUBDIR += sdl_net
SUBDIR += sendfile
SUBDIR += sendip
diff --git a/net/scr_ipfm/Makefile b/net/scr_ipfm/Makefile
new file mode 100644
index 000000000000..249daa9500e5
--- /dev/null
+++ b/net/scr_ipfm/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: scr_ipfm
+# Date created: 27 Oct 2003
+# Whom: HSIN-HSIUNG CHANG
+#
+# $FreeBSD$
+#
+
+PORTNAME= scr_ipfm
+PORTVERSION= 0.64
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= scripfm
+
+MAINTAINER= sexbear@tmu.edu.tw
+COMMENT= Use logs generated by ipfm to show data graphically
+
+NO_BUILD= yes
+MYADMDIR?= www/data/scr_ipfm
+PLIST_SUB= MYADMDIR=${MYADMDIR}
+PORTDOCS= BUGS COPYING ChangeLog README README_pl THANKS TODO
+
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../../lang/php4/bsd.php.mk"
+
+do-install:
+ @${MKDIR} ${PREFIX}/${MYADMDIR}
+ ${CP} -R ${WRKSRC}/[a-z]* ${PREFIX}/${MYADMDIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+ @${CAT} ${PKGMESSAGE}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/scr_ipfm/distinfo b/net/scr_ipfm/distinfo
new file mode 100644
index 000000000000..6eb752e119b0
--- /dev/null
+++ b/net/scr_ipfm/distinfo
@@ -0,0 +1 @@
+MD5 (scr_ipfm-0.64.tar.gz) = 5867737ef5cbade35a42c66020b4f045
diff --git a/net/scr_ipfm/pkg-descr b/net/scr_ipfm/pkg-descr
new file mode 100644
index 000000000000..cead671e11bb
--- /dev/null
+++ b/net/scr_ipfm/pkg-descr
@@ -0,0 +1,10 @@
+So scr_ipfm is a script written in php, used to graphically show amount of data
+downloaded by users in local network. To do that, it uses logs generated by
+ipfm program (ipfm is available at the address: http://robert.cheramy.net/ipfm/)
+
+scr_ipfm features:
+ - sorting by field in, out, host and total
+ - aggregated data of downloaded amount of data
+ - daily, monthly, annually and global statistics
+
+WWW: http://scripfm.sourceforge.net/
diff --git a/net/scr_ipfm/pkg-message b/net/scr_ipfm/pkg-message
new file mode 100644
index 000000000000..1900ba73b7a2
--- /dev/null
+++ b/net/scr_ipfm/pkg-message
@@ -0,0 +1,3 @@
+-------------------------------------------------------------------
+You may need to read ${PORTDOCS}/README to configure scr_ipfm
+-------------------------------------------------------------------
diff --git a/net/scr_ipfm/pkg-plist b/net/scr_ipfm/pkg-plist
new file mode 100644
index 000000000000..af0d4298f5bf
--- /dev/null
+++ b/net/scr_ipfm/pkg-plist
@@ -0,0 +1,55 @@
+%%MYADMDIR%%/conf.php
+%%MYADMDIR%%/contrib/index.php
+%%MYADMDIR%%/contrib/ipfm_renamelogs.pl
+%%MYADMDIR%%/daily-graph.php
+%%MYADMDIR%%/daily.php
+%%MYADMDIR%%/dayinmonth-graph.php
+%%MYADMDIR%%/dayinmonth.php
+%%MYADMDIR%%/functions.php
+%%MYADMDIR%%/global-graph.php
+%%MYADMDIR%%/global.php
+%%MYADMDIR%%/host.php
+%%MYADMDIR%%/images/graph.png
+%%MYADMDIR%%/images/index.php
+%%MYADMDIR%%/images/wykres-pion-end.png
+%%MYADMDIR%%/images/wykres-pion-first.png
+%%MYADMDIR%%/images/wykres-pion.png
+%%MYADMDIR%%/images/wykres-poziom-end.png
+%%MYADMDIR%%/images/wykres-poziom-first.png
+%%MYADMDIR%%/images/wykres-poziom.png
+%%MYADMDIR%%/index.php
+%%MYADMDIR%%/ipfm.conf-sample
+%%MYADMDIR%%/monthinyear-graph.php
+%%MYADMDIR%%/monthinyear.php
+%%MYADMDIR%%/monthly-graph.php
+%%MYADMDIR%%/monthly.php
+%%MYADMDIR%%/themes/blue/index.php
+%%MYADMDIR%%/themes/blue/style.css
+%%MYADMDIR%%/themes/index.php
+%%MYADMDIR%%/themes/default/index.php
+%%MYADMDIR%%/themes/default/style.css
+%%MYADMDIR%%/themes/green/index.php
+%%MYADMDIR%%/themes/green/style.css
+%%MYADMDIR%%/themes/meat/index.php
+%%MYADMDIR%%/themes/meat/style.css
+%%MYADMDIR%%/themes/orange/index.php
+%%MYADMDIR%%/themes/orange/style.css
+%%MYADMDIR%%/themes/white/index.php
+%%MYADMDIR%%/themes/white/style.css
+%%MYADMDIR%%/themes/yellow/index.php
+%%MYADMDIR%%/themes/yellow/style.css
+%%MYADMDIR%%/yearinglobal-graph.php
+%%MYADMDIR%%/yearinglobal.php
+%%MYADMDIR%%/yearly-graph.php
+%%MYADMDIR%%/yearly.php
+@dirrm %%MYADMDIR%%/themes/yellow
+@dirrm %%MYADMDIR%%/themes/white
+@dirrm %%MYADMDIR%%/themes/orange
+@dirrm %%MYADMDIR%%/themes/meat
+@dirrm %%MYADMDIR%%/themes/green
+@dirrm %%MYADMDIR%%/themes/default
+@dirrm %%MYADMDIR%%/themes/blue
+@dirrm %%MYADMDIR%%/themes
+@dirrm %%MYADMDIR%%/images
+@dirrm %%MYADMDIR%%/contrib
+@dirrm %%MYADMDIR%%