aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/fpc-gdb/Makefile4
-rw-r--r--devel/gdb52/Makefile4
-rw-r--r--games/groundhog/Makefile8
-rw-r--r--japanese/iv/Makefile4
4 files changed, 19 insertions, 1 deletions
diff --git a/devel/fpc-gdb/Makefile b/devel/fpc-gdb/Makefile
index 86c5c332a7b5..572633c89d44 100644
--- a/devel/fpc-gdb/Makefile
+++ b/devel/fpc-gdb/Makefile
@@ -32,6 +32,10 @@ COMMENT= GNU GDB 5.2.1 modified for Free Pascal
BROKEN= "Does not compile on 4.x"
.endif
+.if ${OSVERSION} > 502112
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
NO_LATEST_LINK= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/devel/gdb52/Makefile b/devel/gdb52/Makefile
index f00def16d5ef..8df002498642 100644
--- a/devel/gdb52/Makefile
+++ b/devel/gdb52/Makefile
@@ -26,6 +26,10 @@ COMMENT= GNU GDB 5.2.1 debugger
BROKEN= "Does not compile on 4.x"
.endif
+.if ${OSVERSION} > 502112
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
.if ${ARCH} == "amd64"
BROKEN= "Configure fails on amd64"
.endif
diff --git a/games/groundhog/Makefile b/games/groundhog/Makefile
index f85d6754e825..d30887b3bebb 100644
--- a/games/groundhog/Makefile
+++ b/games/groundhog/Makefile
@@ -18,4 +18,10 @@ USE_GMAKE= yes
USE_GNOME= gtk20
GNU_CONFIGURE= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 502112
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/japanese/iv/Makefile b/japanese/iv/Makefile
index cc076ddd74e9..a4679daa2755 100644
--- a/japanese/iv/Makefile
+++ b/japanese/iv/Makefile
@@ -23,6 +23,10 @@ COMMENT= A toolkit from Stanford University and Silicon Graphics + Japanese patc
.include <bsd.port.pre.mk>
+.if ${OSVERSION} > 502112
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
# Warning: we cannot use USE_IMAKE.
.if ${XFREE86_VERSION} == 3
BUILD_DEPENDS= imake:${PORTSDIR}/devel/imake