aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-wm/sawfish2/Makefile10
-rw-r--r--x11-wm/sawfish2/files/patch-src_gtk-style.c15
2 files changed, 21 insertions, 4 deletions
diff --git a/x11-wm/sawfish2/Makefile b/x11-wm/sawfish2/Makefile
index cb6cae193a3f..ada909aee287 100644
--- a/x11-wm/sawfish2/Makefile
+++ b/x11-wm/sawfish2/Makefile
@@ -7,12 +7,12 @@
PORTNAME= sawfish2
PORTVERSION= 1.2
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 2
CATEGORIES= x11-wm
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/sawfish/1.2
-DISTNAME= sawfish-${PORTVERSION}-gtk2
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/1.2
+DISTNAME= ${PORTNAME:S/2$//}-${PORTVERSION}-gtk2
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -40,11 +40,13 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= ${ARCH}-pc-freebsd${OSREL:C/\..*//}
-pre-patch:
+post-patch:
@${REINPLACE_CMD} -e 's^-l(pthread|c_r)^${PTHREAD_LIBS}^g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
s|[$$][(]top_builddir[)]/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|X11/Xft/Xft\.h|X11/Xft/Xft2.h|g' \
+ ${WRKSRC}/src/fonts.c
post-install:
install-info --section="X11 window manager" \
diff --git a/x11-wm/sawfish2/files/patch-src_gtk-style.c b/x11-wm/sawfish2/files/patch-src_gtk-style.c
new file mode 100644
index 000000000000..6279de7f770e
--- /dev/null
+++ b/x11-wm/sawfish2/files/patch-src_gtk-style.c
@@ -0,0 +1,15 @@
+--- src/gtk-style.c.orig Sat Feb 8 16:17:37 2003
++++ src/gtk-style.c Sat Feb 8 16:18:39 2003
+@@ -97,12 +97,6 @@
+ {
+ /* If GTK_MINOR_VERSION is not 2 we are using gtk+ 1.3.x or 2.0
+ so these two members are no more */
+-#if (GTK_MINOR_VERSION == 2)
+- if (rc->font_name != 0)
+- printf ("(font . \"%s\")\n", rc->font_name);
+- if (rc->fontset_name != 0)
+- printf ("(fontset . \"%s\")\n", rc->fontset_name);
+-#endif
+ if (print_rc_colors ("fg", rc->fg, 5, rc->color_flags, GTK_RC_FG))
+ print_colors ("fg", style->fg, 5);
+ if (print_rc_colors ("bg", rc->bg, 5, rc->color_flags, GTK_RC_BG))