aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/py-django-dpaste/Makefile30
-rw-r--r--www/py-django-dpaste/distinfo2
-rw-r--r--www/py-django-dpaste/files/MANIFEST.in3
-rw-r--r--www/py-django-dpaste/files/patch-setup.py11
-rw-r--r--www/py-django-dpaste/pkg-descr5
-rw-r--r--www/py-django-dpaste/pkg-plist1
7 files changed, 53 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 3c363ec4f081..3121902c26fe 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1495,6 +1495,7 @@
SUBDIR += py-django-classy-tags
SUBDIR += py-django-cms
SUBDIR += py-django-devel
+ SUBDIR += py-django-dpaste
SUBDIR += py-django-evolution
SUBDIR += py-django-extensions
SUBDIR += py-django-filer
diff --git a/www/py-django-dpaste/Makefile b/www/py-django-dpaste/Makefile
new file mode 100644
index 000000000000..a2590fe0f18a
--- /dev/null
+++ b/www/py-django-dpaste/Makefile
@@ -0,0 +1,30 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= dpaste
+PORTVERSION= 2.0
+CATEGORIES= www python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}django-
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Pastebin Django application that powers dpaste.de
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django>=1.4:${PORTSDIR}/www/py-django \
+ ${PYTHON_PKGNAMEPREFIX}django-mptt>=0.6.0:${PORTSDIR}/www/py-django-mptt \
+ ${PYTHON_PKGNAMEPREFIX}pygments>=1.6:${PORTSDIR}/textproc/py-pygments \
+ ${PYTHON_PKGNAMEPREFIX}requests>=1.0.0:${PORTSDIR}/www/py-requests
+
+USE_GITHUB= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+PYDISTUTILS_AUTOPLIST= yes
+
+GH_ACCOUNT= bartTC
+GH_COMMIT= 129be43
+
+post-patch:
+ @${CP} ${FILESDIR}/MANIFEST.in ${WRKSRC}
+
+.include <bsd.port.mk>
diff --git a/www/py-django-dpaste/distinfo b/www/py-django-dpaste/distinfo
new file mode 100644
index 000000000000..29e06cd6a2f6
--- /dev/null
+++ b/www/py-django-dpaste/distinfo
@@ -0,0 +1,2 @@
+SHA256 (dpaste-2.0.tar.gz) = d6704e01765a9e83d85729708be6464271c4e8a6fd65552f9c24d03d169dcc5f
+SIZE (dpaste-2.0.tar.gz) = 113097
diff --git a/www/py-django-dpaste/files/MANIFEST.in b/www/py-django-dpaste/files/MANIFEST.in
new file mode 100644
index 000000000000..488d8afa25c9
--- /dev/null
+++ b/www/py-django-dpaste/files/MANIFEST.in
@@ -0,0 +1,3 @@
+include *.rst LICENSE
+recursive-include dpaste/templates *
+recursive-include dpaste/static *
diff --git a/www/py-django-dpaste/files/patch-setup.py b/www/py-django-dpaste/files/patch-setup.py
new file mode 100644
index 000000000000..e7bdd0334841
--- /dev/null
+++ b/www/py-django-dpaste/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- ./setup.py.orig 2013-12-07 23:20:33.881977668 +1100
++++ ./setup.py 2013-12-07 23:20:46.477070760 +1100
+@@ -24,7 +24,7 @@
+
+ packages=find_packages(),
+ package_data={'dpaste': ['static/*.*', 'templates/*.*']},
+- scripts=('manage.py',),
++ include_package_data=True,
+ install_requires=(
+ 'django>=1.4',
+ 'django-mptt>=0.6.0',
diff --git a/www/py-django-dpaste/pkg-descr b/www/py-django-dpaste/pkg-descr
new file mode 100644
index 000000000000..1836b85b82f4
--- /dev/null
+++ b/www/py-django-dpaste/pkg-descr
@@ -0,0 +1,5 @@
+dpaste is a Django based pastebin. It's intended to run separately but its
+also possible to be installed into an existing Django project like a regular
+app. You can find a live example on dpaste.de
+
+WWW: https://github.com/bartTC/dpaste/
diff --git a/www/py-django-dpaste/pkg-plist b/www/py-django-dpaste/pkg-plist
new file mode 100644
index 000000000000..8fb5cc4556d5
--- /dev/null
+++ b/www/py-django-dpaste/pkg-plist
@@ -0,0 +1 @@
+@comment $FreeBSD$