aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/caps-lv2/Makefile2
-rw-r--r--audio/ncmpcpp/Makefile2
-rw-r--r--comms/uarduno/Makefile2
-rw-r--r--emulators/hatari/Makefile1
-rw-r--r--graphics/aseprite/Makefile11
-rw-r--r--graphics/kix-kmod/Makefile2
-rw-r--r--math/acalc/Makefile2
-rw-r--r--math/blis/Makefile2
-rw-r--r--math/flint2/Makefile1
-rw-r--r--math/gap/Makefile5
-rw-r--r--math/qalculate/Makefile2
-rw-r--r--multimedia/cuse4bsd-kmod/Makefile8
-rw-r--r--multimedia/nordlicht/Makefile5
-rw-r--r--multimedia/pwcbsd/Makefile2
-rw-r--r--net-mgmt/pmacct/Makefile1
-rw-r--r--net/aoe/Makefile1
-rw-r--r--net/intel-em-kmod/Makefile1
-rw-r--r--net/isboot-kmod/Makefile1
-rw-r--r--net/ng_mikrotik_eoip/Makefile2
-rw-r--r--news/nntpcache/Makefile1
-rw-r--r--print/pecl-pdflib/Makefile2
-rw-r--r--textproc/ffe/Makefile2
-rw-r--r--textproc/rubygem-cld3/Makefile4
23 files changed, 13 insertions, 49 deletions
diff --git a/audio/caps-lv2/Makefile b/audio/caps-lv2/Makefile
index 026a2d974458..9e61eca83b8c 100644
--- a/audio/caps-lv2/Makefile
+++ b/audio/caps-lv2/Makefile
@@ -12,8 +12,6 @@ COMMENT= LV2 version of the C* Audio Plugin Suite
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_powerpc64= fails to build: cc1plus: unrecognized command line option -std=c++11
-
BUILD_DEPENDS= lv2>0:audio/lv2
USES= gmake localbase
diff --git a/audio/ncmpcpp/Makefile b/audio/ncmpcpp/Makefile
index cd07b45f1963..46efa854f8a8 100644
--- a/audio/ncmpcpp/Makefile
+++ b/audio/ncmpcpp/Makefile
@@ -19,8 +19,6 @@ LIB_DEPENDS= libmpdclient.so:audio/libmpdclient \
libboost_filesystem.so:devel/boost-libs \
libcurl.so:ftp/curl
-BROKEN_powerpc64= fails to compile: tags.cpp: undefined reference to TagLib::String::to8Bit
-
USES= compiler:c++14-lang iconv libtool localbase ncurses:port pkgconfig readline tar:bzip2
GNU_CONFIGURE= yes
USE_GNOME= glib20
diff --git a/comms/uarduno/Makefile b/comms/uarduno/Makefile
index e4c8f5d0276a..6b725473c55f 100644
--- a/comms/uarduno/Makefile
+++ b/comms/uarduno/Makefile
@@ -12,8 +12,6 @@ COMMENT= FreeBSD Kernel Driver for the Arduino Uno USB interface
LICENSE= BSD4CLAUSE
-BROKEN_powerpc64= fails to compile: pcpu.h: error: size of array '__assert_0' is negative
-
USES= kmod uidfix
# some test targets need a predictable source directory
diff --git a/emulators/hatari/Makefile b/emulators/hatari/Makefile
index 9a712f4edd18..f3ad88c34f46 100644
--- a/emulators/hatari/Makefile
+++ b/emulators/hatari/Makefile
@@ -14,7 +14,6 @@ LICENSE_FILE= ${WRKSRC}/gpl.txt
BROKEN_aarch64= fails to configure: error: unrecognized CPU type
BROKEN_armv6= fails to configure: CMake Error: Generator: execution of make failed
-BROKEN_powerpc64= fails to compile: sysdeps.h: redefinition of typedef 'uae_u8'
LIB_DEPENDS= libportaudio.so:audio/portaudio \
libpng.so:graphics/png
diff --git a/graphics/aseprite/Makefile b/graphics/aseprite/Makefile
index 6c8c641f6fd2..5ee95759b13e 100644
--- a/graphics/aseprite/Makefile
+++ b/graphics/aseprite/Makefile
@@ -15,6 +15,11 @@ LICENSE_NAME= END-USER LICENSE AGREEMENT FOR ASEPRITE
LICENSE_FILE= ${WRKSRC}/EULA.txt
LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
+BROKEN_aarch64= fails to compile: undefined reference to __va_copy
+BROKEN_armv6= fails to compile: undefined reference to __va_copy
+BROKEN_armv7= fails to compile: undefined reference to __va_copy
+BROKEN_sparc64= fails to compile: vsnprintf is not a member of std
+
EXTRACT_DEPENDS= ${NONEXISTENT}:x11/pixman:extract
LIB_DEPENDS= liballeg.so:devel/allegro \
libcmark.so:textproc/cmark \
@@ -30,12 +35,6 @@ LIB_DEPENDS= liballeg.so:devel/allegro \
libtinyxml.so:textproc/tinyxml \
libzstd.so:archivers/zstd
-BROKEN_aarch64= fails to compile: undefined reference to __va_copy
-BROKEN_armv6= fails to compile: undefined reference to __va_copy
-BROKEN_armv7= fails to compile: undefined reference to __va_copy
-BROKEN_powerpc64= fails to compile: arena.h: Failed assertion: "arena_mapbits_allocated_get(chunk, pageind) != 0"
-BROKEN_sparc64= fails to compile: vsnprintf is not a member of std
-
USES= cmake:outsource compiler:c++11-lib iconv:wchar_t jpeg localbase:ldflags pkgconfig ssl
USE_GITHUB= yes
GH_TUPLE= aseprite:libarchive:c51dbfc:libarchive/third_party/libarchive
diff --git a/graphics/kix-kmod/Makefile b/graphics/kix-kmod/Makefile
index 5c41d09d6507..dbff252dbd07 100644
--- a/graphics/kix-kmod/Makefile
+++ b/graphics/kix-kmod/Makefile
@@ -12,8 +12,6 @@ PKGNAMESUFFIX= -kmod
MAINTAINER= jon@witchspace.com
COMMENT= Graphical screensaver kernel module
-BROKEN_powerpc64= fails to compile: pcpu.h: size of array '__assert_0' is negative
-
USES= kmod
MAKE_ENV+= WERROR=
diff --git a/math/acalc/Makefile b/math/acalc/Makefile
index 881239486ad9..3c081b92f333 100644
--- a/math/acalc/Makefile
+++ b/math/acalc/Makefile
@@ -13,8 +13,6 @@ LICENSE= BSD4CLAUSE
DEPRECATED= Qt4 has been EOL since december 2015
EXPIRATION_DATE= 2019-03-15
-BROKEN_powerpc64= fails to compile: cc1plus: unrecognized command line option "-std=c++11"
-
USE_GITHUB= yes
GH_ACCOUNT= anpp
diff --git a/math/blis/Makefile b/math/blis/Makefile
index 3dbc79fcfffc..d5183c1b77a3 100644
--- a/math/blis/Makefile
+++ b/math/blis/Makefile
@@ -14,8 +14,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= bash:shells/bash \
llvm60>=0:devel/llvm60
-BROKEN_powerpc64= fails to configure: common.mk:118: Unable to determine compiler vendor
-
OPTIONS_DEFINE= PARA CBLAS
PARA_DESC= use pthread parallelization
CBLAS_DESC= build the CBLAS compatibility layer
diff --git a/math/flint2/Makefile b/math/flint2/Makefile
index efb51e3b0c83..6d99c412299b 100644
--- a/math/flint2/Makefile
+++ b/math/flint2/Makefile
@@ -19,7 +19,6 @@ BROKEN_armv6= fails to compile: invokes x86 assembler
BROKEN_armv7= fails to compile: invokes x86 assembler
BROKEN_mips= fails to compile: invokes x86 assembler
BROKEN_mips64= fails to compile: invokes x86 assembler
-BROKEN_powerpc64= fails to compile: invokes x86 assembler
LIB_DEPENDS= libgmp.so:math/gmp \
libmpfr.so:math/mpfr
diff --git a/math/gap/Makefile b/math/gap/Makefile
index b4973fc262ec..4fba7dd0f096 100644
--- a/math/gap/Makefile
+++ b/math/gap/Makefile
@@ -14,10 +14,9 @@ COMMENT= GAP is a system for computational discrete algebra
LICENSE= GPLv2+
-LIB_DEPENDS= libgmp.so:math/gmp
-
BROKEN_aarch64= fails to link: undefined reference to SyAllocBags
-BROKEN_powerpc64= fails to package: 2_manifolds_54.scb: No such file or directory
+
+LIB_DEPENDS= libgmp.so:math/gmp
USES= gmake shebangfix tar:bzip2
SHEBANG_FILES= configure \
diff --git a/math/qalculate/Makefile b/math/qalculate/Makefile
index 7d26c89eab74..bb4166d7aac7 100644
--- a/math/qalculate/Makefile
+++ b/math/qalculate/Makefile
@@ -14,8 +14,6 @@ COMMENT= Multi-purpose desktop calculator (GTK+3 frontend)
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_powerpc64= fails to compile: main.cc: undefined reference to Calculator::temporaryCategory[abi:cxx11]()
-
LIB_DEPENDS= libqalculate.so:math/libqalculate
RUN_DEPENDS= gnuplot:math/gnuplot
diff --git a/multimedia/cuse4bsd-kmod/Makefile b/multimedia/cuse4bsd-kmod/Makefile
index 5ed327210c38..1a14648716ca 100644
--- a/multimedia/cuse4bsd-kmod/Makefile
+++ b/multimedia/cuse4bsd-kmod/Makefile
@@ -9,15 +9,15 @@ MASTER_SITES= http://www.selasky.org/hans_petter/distfiles/ \
MAINTAINER= hselasky@FreeBSD.org
COMMENT= Cuse4BSD character device loopback driver for userspace
-CONFLICTS= video4bsd-kmod*
-
BROKEN_armv6= fails to compile: implicit declaration of function 'cp15_pmccntr_get' is invalid in C99
-BROKEN_powerpc64= fails to compile: pcpu.h: error: size of array '__assert_0' is negative
+
+CONFLICTS= video4bsd-kmod*
KMODNAME= cuse4bsd
LIBDIR= ${PREFIX}/lib
INCLUDEDIR= ${PREFIX}/include
MANDIR= ${PREFIX}/man/man
+USES= kmod tar:bzip2 uidfix
USE_LDCONFIG= yes
PLIST_SUB= KMODNAME="${KMODNAME}" \
@@ -27,8 +27,6 @@ PLIST_SUB= KMODNAME="${KMODNAME}" \
OPTIONS_DEFINE= DEBUG
-USES= kmod tar:bzip2 uidfix
-
.include <bsd.port.options.mk>
MAKE_ARGS+= PTHREAD_LIBS="-lpthread"
diff --git a/multimedia/nordlicht/Makefile b/multimedia/nordlicht/Makefile
index 1b840bde4adc..e4f70c2ce03f 100644
--- a/multimedia/nordlicht/Makefile
+++ b/multimedia/nordlicht/Makefile
@@ -13,6 +13,8 @@ COMMENT= Create moodbars from video files
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE.md
+BROKEN_aarch64= Fails to install: runaway process
+
BUILD_DEPENDS= help2man:misc/help2man
LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg \
libpopt.so:devel/popt \
@@ -25,9 +27,6 @@ USE_LDCONFIG= yes
PLIST_SUB= PORTVERSION=${PORTVERSION}
-BROKEN_aarch64= Fails to install: runaway process
-BROKEN_powerpc64= Does not build
-
SHEBANG_FILES= utils/mpv-nordlicht
OPTIONS_DEFINE= EXAMPLES
diff --git a/multimedia/pwcbsd/Makefile b/multimedia/pwcbsd/Makefile
index 14cc01964edb..bca68302e43c 100644
--- a/multimedia/pwcbsd/Makefile
+++ b/multimedia/pwcbsd/Makefile
@@ -14,8 +14,6 @@ COMMENT= The Linux pwc webcam driver ported to FreeBSD
LICENSE= GPLv2
-BROKEN_powerpc64= fails to compile: pcpu.h:187: error: size of array '__assert_0' is negative
-
CONFLICTS= pwcview-[0-9]*
SSP_UNSAFE= kernel module does not support ssp
diff --git a/net-mgmt/pmacct/Makefile b/net-mgmt/pmacct/Makefile
index 93447d413692..6663cbe468f1 100644
--- a/net-mgmt/pmacct/Makefile
+++ b/net-mgmt/pmacct/Makefile
@@ -13,7 +13,6 @@ COMMENT= Accounting and aggregation tool for IPv4 and IPv6 traffic
LICENSE= GPLv2
BROKEN_aarch64= fails to build: undefined reference to sbrk
-BROKEN_powerpc64= fails to build: cc: Internal error: Segmentation fault (program ld)
USE_RC_SUBR= pmacctd nfacctd sfacctd
SUB_FILES= pkg-message
diff --git a/net/aoe/Makefile b/net/aoe/Makefile
index 5b2d44406dcc..f982c2496537 100644
--- a/net/aoe/Makefile
+++ b/net/aoe/Makefile
@@ -14,7 +14,6 @@ COMMENT= FreeBSD driver for ATA over Ethernet (AoE)
BROKEN_aarch64= fails to compile: redefinition of frame
BROKEN_armv6= fails to compile: implicit declaration of function 'cp15_pmccntr_get' is invalid in C99
BROKEN_armv7= fails to compile: redefinition of frame
-BROKEN_powerpc64= fails to compile: pcpu.h: size of array '__assert_0' is negative
BROKEN_sparc64= fails to compile: redefinition of frame
USES= kmod
diff --git a/net/intel-em-kmod/Makefile b/net/intel-em-kmod/Makefile
index dc9d821b96c5..2b25b6308153 100644
--- a/net/intel-em-kmod/Makefile
+++ b/net/intel-em-kmod/Makefile
@@ -11,7 +11,6 @@ MAINTAINER= freebsd@intel.com
COMMENT= Gigabit FreeBSD Base Drivers for Intel(R) Ethernet
BROKEN_armv6= fails to compile: implicit declaration of function 'cp15_pmccntr_get' is invalid in C99
-BROKEN_powerpc64= fails to compile: pcpu.h: size of array '__assert_0' is negative
MAX_NETMAP_OSVERSION= 1199999 # Doesn't build w/NETMAP on 12
diff --git a/net/isboot-kmod/Makefile b/net/isboot-kmod/Makefile
index 6e54ef7bac86..b697cbae5951 100644
--- a/net/isboot-kmod/Makefile
+++ b/net/isboot-kmod/Makefile
@@ -15,7 +15,6 @@ LICENSE= BSD2CLAUSE
BROKEN_aarch64= fails to compile: /usr/src/sys/sys/bus.h:724:10: fatal error: 'device_if.h' file not found
BROKEN_armv6= fails to compile: implicit declaration of function 'cp15_pmccntr_get' is invalid in C99
BROKEN_armv7= fails to compile: /usr/src/sys/sys/bus.h:724:10: fatal error: 'device_if.h' file not found
-BROKEN_powerpc64= fails to compile: pcpu.h: size of array '__assert_0' is negative
USES= kmod uidfix
SUB_FILES= pkg-message
diff --git a/net/ng_mikrotik_eoip/Makefile b/net/ng_mikrotik_eoip/Makefile
index 3a274ace5e3a..14a3025cc26f 100644
--- a/net/ng_mikrotik_eoip/Makefile
+++ b/net/ng_mikrotik_eoip/Makefile
@@ -11,8 +11,6 @@ COMMENT= Netgraph node for Mikrotik EoIP tunneling
LICENSE= BSD2CLAUSE
-BROKEN_powerpc64= fails to compile: pcpu.h: size of array '__assert_0' is negative
-
SSP_UNSAFE= kernel module does not support ssp
OPTIONS_DEFINE= PTABLE
diff --git a/news/nntpcache/Makefile b/news/nntpcache/Makefile
index a89d55adc960..609fb74b61f1 100644
--- a/news/nntpcache/Makefile
+++ b/news/nntpcache/Makefile
@@ -12,7 +12,6 @@ COMMENT= News caching/anti-spam/server-merging system
BROKEN_aarch64= fails to link: missing sbrk
BROKEN_mips64= fails to build: qemu: uncaught target signal 11 (Segmentation fault) - core dumped
-BROKEN_powerpc64= fails to install: ./mmap_tests: Quit (core dumped)
NO_CDROM= Free for individuals and non-military, non-profit organisations only
diff --git a/print/pecl-pdflib/Makefile b/print/pecl-pdflib/Makefile
index fd690b510f46..c44f6dbf1547 100644
--- a/print/pecl-pdflib/Makefile
+++ b/print/pecl-pdflib/Makefile
@@ -12,8 +12,6 @@ LICENSE= PHP30
LIB_DEPENDS= libpdf.so:print/pdflib
-BROKEN_powerpc64= Does not build
-
USES= php:pecl
USE_PHP= gd:build
PHP_MODNAME= pdf
diff --git a/textproc/ffe/Makefile b/textproc/ffe/Makefile
index b2139e1ddb7f..23248e890e72 100644
--- a/textproc/ffe/Makefile
+++ b/textproc/ffe/Makefile
@@ -13,8 +13,6 @@ COMMENT= Flat file extractor
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_powerpc64= fails to compile: unrecognized command line option "-Wmaybe-uninitialized"
-
USES= makeinfo localbase
GNU_CONFIGURE= yes
diff --git a/textproc/rubygem-cld3/Makefile b/textproc/rubygem-cld3/Makefile
index f41d7d0f2cf9..53ec0476de3a 100644
--- a/textproc/rubygem-cld3/Makefile
+++ b/textproc/rubygem-cld3/Makefile
@@ -11,13 +11,11 @@ COMMENT= Compact Language Detection for Ruby
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_powerpc64= fails to install: Error installing cld3-3.1.2.gem: Failed to build gem native extension
-
RUN_DEPENDS= protobuf>0:devel/protobuf \
rubygem-ffi>0:devel/rubygem-ffi
-USE_RUBY= yes
USES= gem pkgconfig
+USE_RUBY= yes
## do-install here to prevent removal of ext
do-install: