aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-openxpki-client-scep/Makefile30
-rw-r--r--security/p5-openxpki-client-scep/distinfo3
-rw-r--r--security/p5-openxpki-client-scep/pkg-descr24
-rw-r--r--security/p5-openxpki-client-scep/pkg-plist7
5 files changed, 65 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 102534bd2c24..a1ff2d2efb97 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -467,6 +467,7 @@
SUBDIR += p5-openxpki-client
SUBDIR += p5-openxpki-client-cli
SUBDIR += p5-openxpki-client-html-mason
+ SUBDIR += p5-openxpki-client-scep
SUBDIR += pad
SUBDIR += pam-mysql
SUBDIR += pam-pgsql
diff --git a/security/p5-openxpki-client-scep/Makefile b/security/p5-openxpki-client-scep/Makefile
new file mode 100644
index 000000000000..bd2568ef252d
--- /dev/null
+++ b/security/p5-openxpki-client-scep/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-openxpki-client-scep
+# Date created: 03 Oct 2006
+# Whom: svysh
+#
+# $FreeBSD$
+#
+
+PORTNAME= openxpki-client-scep
+PORTVERSION= 0.9.421
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= openxpki
+PKGNAMEPREFIX= p5-
+DISTNAME= OpenXPKI-Client-SCEP-${PORTVERSION}
+DIST_SUBDIR= openxpki
+
+MAINTAINER= svysh@cryptocom.ru
+COMMENT= Client for SCEP requests to openxpki server
+
+BUILD_DEPENDS= \
+ ${SITE_PERL}/Config/Std.pm:${PORTSDIR}/devel/p5-Config-Std \
+ ${SITE_PERL}/OpenXPKI/Client.pm:${PORTSDIR}/security/p5-openxpki-client
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= OpenXPKI::Client::SCEP.3
+USE_PERL5= yes
+USE_GMAKE= yes
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/security/p5-openxpki-client-scep/distinfo b/security/p5-openxpki-client-scep/distinfo
new file mode 100644
index 000000000000..3dc55713df86
--- /dev/null
+++ b/security/p5-openxpki-client-scep/distinfo
@@ -0,0 +1,3 @@
+MD5 (openxpki/OpenXPKI-Client-SCEP-0.9.421.tar.gz) = 70e28aeddcc7b13b0918e806ca765295
+SHA256 (openxpki/OpenXPKI-Client-SCEP-0.9.421.tar.gz) = c3c89bcc69cb9e131a353f0eb228090e9abc4bdc1c453812bf89d4cc54f97753
+SIZE (openxpki/OpenXPKI-Client-SCEP-0.9.421.tar.gz) = 8052
diff --git a/security/p5-openxpki-client-scep/pkg-descr b/security/p5-openxpki-client-scep/pkg-descr
new file mode 100644
index 000000000000..dccf2ae39cd6
--- /dev/null
+++ b/security/p5-openxpki-client-scep/pkg-descr
@@ -0,0 +1,24 @@
+A collection of ports for the OpenXPKI suite - Perl based trustcenter
+software for PKI: server and client parts along with deployment tools.
+
+p5-openxpki: core for server part
+p5-openxpki-client: base class for actual clients
+p5-openxpki-i18n: internationalization of the user interface
+p5-openxpki-client-cli: command line interface to local OpenXPKI daemon
+p5-openxpki-client-html-mason: web interface to local OpenXPKI daemon
+p5-openxpki-client-scep: set of SCEP tools
+p5-openxpki-client-soap-lite: set of SOAP-Lite tools
+p5-openxpki-deployment: set or deployment tools
+
+Dependencies of OpenXPKI ports ("A --> B" means that port B depends on port A):
+
+ p5-openxpki-client <-- p5-openxpki (server) --> p5-openxpki-i18n
+ \
+ \ | p5-openxpki-client-cli, p5-openxpki-client-html-mason,
+ \--> | p5-openxpki-client-scep, p5-openxpki-client-soap-lite,
+ | p5-openxpki-deployment.
+Notes:
+I18n is needed for the English interface too. For effective use of deployment,
+it is recommended to install at least one of the clients: ...-cli or ...-mason.
+
+WWW: http://www.openxpki.org/
diff --git a/security/p5-openxpki-client-scep/pkg-plist b/security/p5-openxpki-client-scep/pkg-plist
new file mode 100644
index 000000000000..f8cec01e1f39
--- /dev/null
+++ b/security/p5-openxpki-client-scep/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/OpenXPKI/Client/SCEP.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenXPKI/Client/SCEP/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenXPKI/Client/SCEP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenXPKI/Client
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenXPKI
+@dirrmtry %%SITE_PERL%%/OpenXPKI/Client
+@dirrmtry %%SITE_PERL%%/OpenXPKI