aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/postgresql-plv8js/Makefile4
-rw-r--r--databases/postgresql84-pltcl/Makefile2
-rw-r--r--databases/postgresql93-contrib/Makefile6
-rw-r--r--databases/postgresql93-docs/Makefile2
-rw-r--r--databases/postgresql93-plperl/Makefile2
-rw-r--r--databases/postgresql93-plpython/Makefile2
-rw-r--r--databases/postgresql93-pltcl/Makefile2
-rw-r--r--databases/postgresql94-contrib/Makefile4
-rw-r--r--databases/postgresql94-docs/Makefile2
-rw-r--r--databases/postgresql94-plperl/Makefile2
-rw-r--r--databases/postgresql94-plpython/Makefile2
-rw-r--r--databases/postgresql94-pltcl/Makefile2
12 files changed, 13 insertions, 19 deletions
diff --git a/databases/postgresql-plv8js/Makefile b/databases/postgresql-plv8js/Makefile
index eedb7d930a9b..9a58ee4b27e1 100644
--- a/databases/postgresql-plv8js/Makefile
+++ b/databases/postgresql-plv8js/Makefile
@@ -13,10 +13,8 @@ COMMENT= PL/v8js procedural language for PostgreSQL database
LIB_DEPENDS+= libv8.so:${PORTSDIR}/lang/v8
-USES= gmake perl5 zip
+USES= gmake perl5 zip pgsql:9.1+
USE_PERL5= build
-USE_PGSQL= yes
-WANT_PGSQL_VER= 91+
PLIST_SUB+= PORTVERSION="${PORTVERSION}"
.include <bsd.port.mk>
diff --git a/databases/postgresql84-pltcl/Makefile b/databases/postgresql84-pltcl/Makefile
index 6abeadc992fe..e030e650238e 100644
--- a/databases/postgresql84-pltcl/Makefile
+++ b/databases/postgresql84-pltcl/Makefile
@@ -1,6 +1,6 @@
# Created by: Palle Girgensohn <girgen@partitur.se>
# $FreeBSD$
-WANT_PGSQL_VER?=8.4
+WANT_PGSQL_VER?= 8.4
.include "${.CURDIR}/../postgresql91-pltcl/Makefile"
diff --git a/databases/postgresql93-contrib/Makefile b/databases/postgresql93-contrib/Makefile
index 825c5fc224c3..acb54a20b531 100644
--- a/databases/postgresql93-contrib/Makefile
+++ b/databases/postgresql93-contrib/Makefile
@@ -12,11 +12,9 @@ COMMENT= The contrib utilities from the PostgreSQL distribution
LIB_DEPENDS= libxslt.so:${PORTSDIR}/textproc/libxslt \
libxml2.so:${PORTSDIR}/textproc/libxml2
-USE_PGSQL= yes
-DEFAULT_PGSQL_VER=93
-MASTERDIR= ${.CURDIR}/../postgresql${DEFAULT_PGSQL_VER}-server
+MASTERDIR= ${.CURDIR}/../postgresql93-server
-USES= bison
+USES= bison pgsql:9.3
BUILD_DIRS= src/port src/common contrib
INSTALL_DIRS= contrib
diff --git a/databases/postgresql93-docs/Makefile b/databases/postgresql93-docs/Makefile
index db7e81f0bdce..4a28c75ca643 100644
--- a/databases/postgresql93-docs/Makefile
+++ b/databases/postgresql93-docs/Makefile
@@ -1,6 +1,6 @@
# Created by: Palle Girgensohn <girgen@pingpong.net>
# $FreeBSD$
-WANT_PGSQL_VER=93
+WANT_PGSQL_VER=9.3
.include "${.CURDIR}/../postgresql91-docs/Makefile"
diff --git a/databases/postgresql93-plperl/Makefile b/databases/postgresql93-plperl/Makefile
index f38d90695389..3eaf2ad27fa9 100644
--- a/databases/postgresql93-plperl/Makefile
+++ b/databases/postgresql93-plperl/Makefile
@@ -1,6 +1,6 @@
# Created by: Palle Girgensohn <girgen@partitur.se>
# $FreeBSD$
-WANT_PGSQL_VER= 93
+WANT_PGSQL_VER= 9.3
.include "${.CURDIR}/../postgresql90-plperl/Makefile"
diff --git a/databases/postgresql93-plpython/Makefile b/databases/postgresql93-plpython/Makefile
index 7a94bc0d5070..f12fdc68b1ca 100644
--- a/databases/postgresql93-plpython/Makefile
+++ b/databases/postgresql93-plpython/Makefile
@@ -1,5 +1,5 @@
# $FreeBSD$
-WANT_PGSQL_VER= 93
+WANT_PGSQL_VER= 9.3
.include "${.CURDIR}/../postgresql90-plpython/Makefile"
diff --git a/databases/postgresql93-pltcl/Makefile b/databases/postgresql93-pltcl/Makefile
index 0c21bc9f989d..58d41f055f93 100644
--- a/databases/postgresql93-pltcl/Makefile
+++ b/databases/postgresql93-pltcl/Makefile
@@ -1,6 +1,6 @@
# Created by: Palle Girgensohn <girgen@partitur.se>
# $FreeBSD$
-WANT_PGSQL_VER= 93
+WANT_PGSQL_VER= 9.3
.include "${.CURDIR}/../postgresql91-pltcl/Makefile"
diff --git a/databases/postgresql94-contrib/Makefile b/databases/postgresql94-contrib/Makefile
index 45a8b2ed6b7f..808604c01a40 100644
--- a/databases/postgresql94-contrib/Makefile
+++ b/databases/postgresql94-contrib/Makefile
@@ -12,11 +12,9 @@ COMMENT= The contrib utilities from the PostgreSQL distribution
LIB_DEPENDS= libxslt.so:${PORTSDIR}/textproc/libxslt \
libxml2.so:${PORTSDIR}/textproc/libxml2
-USE_PGSQL= yes
-DEFAULT_VERSIONS=pgsql=94
MASTERDIR= ${.CURDIR}/../postgresql94-server
-USES= bison
+USES= bison pgsql:9.4
BUILD_DIRS= src/port src/common contrib
INSTALL_DIRS= contrib
diff --git a/databases/postgresql94-docs/Makefile b/databases/postgresql94-docs/Makefile
index 755aac07d8b3..dc29473d72e7 100644
--- a/databases/postgresql94-docs/Makefile
+++ b/databases/postgresql94-docs/Makefile
@@ -1,6 +1,6 @@
# Created by: Palle Girgensohn <girgen@pingpong.net>
# $FreeBSD$
-WANT_PGSQL_VER=94
+WANT_PGSQL_VER=9.4
.include "${.CURDIR}/../postgresql91-docs/Makefile"
diff --git a/databases/postgresql94-plperl/Makefile b/databases/postgresql94-plperl/Makefile
index 603971fdbd5b..931c6a10e3b8 100644
--- a/databases/postgresql94-plperl/Makefile
+++ b/databases/postgresql94-plperl/Makefile
@@ -2,6 +2,6 @@
# $FreeBSD$
PORTREVISION= 0
-WANT_PGSQL_VER= 94
+WANT_PGSQL_VER= 9.4
.include "${.CURDIR}/../postgresql90-plperl/Makefile"
diff --git a/databases/postgresql94-plpython/Makefile b/databases/postgresql94-plpython/Makefile
index 19611fb5474d..0a32973197a9 100644
--- a/databases/postgresql94-plpython/Makefile
+++ b/databases/postgresql94-plpython/Makefile
@@ -1,6 +1,6 @@
# $FreeBSD$
PORTREVISION= 0
-WANT_PGSQL_VER= 94
+WANT_PGSQL_VER= 9.4
.include "${.CURDIR}/../postgresql90-plpython/Makefile"
diff --git a/databases/postgresql94-pltcl/Makefile b/databases/postgresql94-pltcl/Makefile
index 156af92863db..103ae06fe73a 100644
--- a/databases/postgresql94-pltcl/Makefile
+++ b/databases/postgresql94-pltcl/Makefile
@@ -1,6 +1,6 @@
# Created by: Palle Girgensohn <girgen@partitur.se>
# $FreeBSD$
-WANT_PGSQL_VER= 94
+WANT_PGSQL_VER= 9.4
.include "${.CURDIR}/../postgresql91-pltcl/Makefile"