aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/last.fm/Makefile2
-rw-r--r--audio/last.fm/files/patch-src_mp3transcode_mp3transcode.cpp11
2 files changed, 12 insertions, 1 deletions
diff --git a/audio/last.fm/Makefile b/audio/last.fm/Makefile
index ef073a765425..739d8820c2f7 100644
--- a/audio/last.fm/Makefile
+++ b/audio/last.fm/Makefile
@@ -28,7 +28,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"
-BROKEN= Does not install
+USE_GCC=4.2+
.endif
post-patch:
diff --git a/audio/last.fm/files/patch-src_mp3transcode_mp3transcode.cpp b/audio/last.fm/files/patch-src_mp3transcode_mp3transcode.cpp
new file mode 100644
index 000000000000..4f9fe9e64aed
--- /dev/null
+++ b/audio/last.fm/files/patch-src_mp3transcode_mp3transcode.cpp
@@ -0,0 +1,11 @@
+--- src/mp3transcode/mp3transcode.cpp.orig 2007-09-27 17:37:07.000000000 +0300
++++ src/mp3transcode/mp3transcode.cpp 2008-09-08 01:43:36.000000000 +0300
+@@ -281,7 +281,7 @@
+ {
+ int length;
+ int cnt;
+- length = qMin( numBytes, ssize_t( getDecodedBufferFilled() ) );
++ length = qMin( numBytes, getDecodedBufferFilled() );
+
+ while (length > 0)
+ {