aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/panoglview/Makefile13
-rw-r--r--graphics/panoglview/distinfo4
-rw-r--r--graphics/panoglview/files/patch-configure15
3 files changed, 22 insertions, 10 deletions
diff --git a/graphics/panoglview/Makefile b/graphics/panoglview/Makefile
index 4ffd606d6382..c26c71e329d0 100644
--- a/graphics/panoglview/Makefile
+++ b/graphics/panoglview/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= panoglview
-PORTVERSION= 0.2.1
-PORTREVISION= 4
+PORTVERSION= 0.2.2
CATEGORIES= graphics
MASTER_SITES= SF/hugin/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -15,12 +14,11 @@ MAINTAINER= ii@any.com.ru
COMMENT= Panorama viewer using OpenGL
GNU_CONFIGURE= yes
-CONFIGURE_ENV= WX_CONFIG_NAME=wxgtk2-${WX_VERSION}-config \
+CONFIGURE_ENV= WX_CONFIG_NAME=${WX_CONFIG} \
PATH="$${PATH}:${LOCALBASE}/bin"
-LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib -lwx_gtk2_gl-${WX_VERSION}
+LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
CFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
CXXFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include -ftemplate-depth-64
-USE_XORG= x11
USE_GMAKE= yes
USE_WX= 2.6+
@@ -29,7 +27,7 @@ WX_CONF_ARGS= relative
PLIST_FILES= bin/panoglview
-OPTIONS= UNICODE "Use UNICODE version of the wxgtk (NLS broken!)" off
+OPTIONS= UNICODE "Use UNICODE version of the wxgtk" on
.include <bsd.port.pre.mk>
@@ -39,10 +37,9 @@ BROKEN= Does not configure on powerpc
.if defined(WITH_UNICODE)
WX_UNICODE= yes
-WX_RC= wxrc-gtk2u-${WX_VERSION}
CONFIGURE_ARGS+= --with-unicode
.else
-WX_RC= wxrc-gtk2-${WX_VERSION}
+.undef WX_UNICODE
CONFIGURE_ARGS+= --without-unicode
.endif
diff --git a/graphics/panoglview/distinfo b/graphics/panoglview/distinfo
index 020a64fa14cc..4478929ae69f 100644
--- a/graphics/panoglview/distinfo
+++ b/graphics/panoglview/distinfo
@@ -1,2 +1,2 @@
-SHA256 (panoglview-0.2.1.tar.gz) = 28de4375cd3234d87b563e8807925aa0c234f393c9d9f34562aa8913c8ab8fcf
-SIZE (panoglview-0.2.1.tar.gz) = 467291
+SHA256 (panoglview-0.2.2.tar.gz) = 0726c5cde08e41c88d9e1002f2743dc7f7d39d553d49605a7cf4b8bb9d47349a
+SIZE (panoglview-0.2.2.tar.gz) = 341134
diff --git a/graphics/panoglview/files/patch-configure b/graphics/panoglview/files/patch-configure
new file mode 100644
index 000000000000..ccda441a8458
--- /dev/null
+++ b/graphics/panoglview/files/patch-configure
@@ -0,0 +1,15 @@
+--- configure.orig 2008-07-23 21:14:06.000000000 +0000
++++ configure 2011-12-28 14:19:01.165970190 +0000
+@@ -3911,11 +3911,7 @@
+ " >&2;}
+ { (exit 1); exit 1; }; }
+ else
+- if test "x$with_unicode" = 'xyes' ; then
+- WX_GL_LIBS="`$WX_CONFIG_PATH --gl-libs`"
+- else
+- WX_GL_LIBS="`$WX_CONFIG_PATH --unicode --gl-libs`"
+- fi
++ WX_GL_LIBS="`$WX_CONFIG_WITH_ARGS --gl-libs`"
+
+ fi
+