aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/Uses/imake.mk10
-rw-r--r--Mk/bsd.commands.mk2
-rw-r--r--devel/imake/Makefile1
-rw-r--r--devel/imake/files/patch-imake.c21
-rw-r--r--devel/imake/files/patch-xmkmf.cpp24
-rw-r--r--editors/asedit/Makefile3
-rw-r--r--emulators/spim/Makefile2
-rw-r--r--games/cosmo/Makefile3
-rw-r--r--graphics/xmagv/Makefile1
-rw-r--r--graphics/xpx/Makefile3
-rw-r--r--japanese/canna-lib/Makefile3
-rw-r--r--japanese/canna-server/Makefile4
-rw-r--r--misc/magicpoint/Makefile2
-rw-r--r--print/xdvi/Makefile3
-rw-r--r--security/xspy/Makefile3
-rw-r--r--x11-clocks/mouseclock/Makefile11
-rw-r--r--x11-clocks/mouseclock/files/patch-Imakefile23
-rw-r--r--x11-wm/fvwm/Makefile5
-rw-r--r--x11/xgrab/Makefile4
-rw-r--r--x11/xxkb/Makefile2
20 files changed, 66 insertions, 64 deletions
diff --git a/Mk/Uses/imake.mk b/Mk/Uses/imake.mk
index ca4aca66f501..b71fc41bcecb 100644
--- a/Mk/Uses/imake.mk
+++ b/Mk/Uses/imake.mk
@@ -7,6 +7,7 @@
# Feature: imake
# Usage: USES=imake
# Valid ARGS: env: do not define any target
+# notall: do not pass -a to xmkmf
#
.if !defined(_INCLUDE_USES_IMAKE_MK)
@@ -15,6 +16,8 @@ _INCLUDE_USES_IMAKE_MK= yes
.if defined(imake_ARGS)
.if ${imake_ARGS} == env
IMAKE_ENV_ONLY= yes
+.elif ${imake_ARGS} == notall
+IMAKE_NOTALL= yes
.else
IGNORE= USES=imake ${imake_ARGS} is not a valid argument
.endif
@@ -36,12 +39,15 @@ BUILD_DEPENDS+= tradcpp:${PORTSDIR}/devel/tradcpp
.endif
MAKE_ENV+= IMAKECPP=${IMAKECPP} IMAKECPPFLAGS="${IMAKECPPFLAGS}"
CONFIGURE_ENV+= IMAKECPP=${IMAKECPP} IMAKECPPFLAGS="${IMAKECPPFLAGS}"
-MAKE_ARGS+= IMAKE_DEFINES="${IMAKECPPFLAGS}"
+
+.if !defined(IMAKE_NOTALL)
+XMKMF_ARGS+= -a
+.endif
.if !defined(IMAKE_ENV_ONLY)
.if !target(do-configure)
do-configure:
- @(cd ${CONFIGURE_WRKSRC}; ${SETENV} ${MAKE_ENV} ${XMKMF})
+ @(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${MAKE_ENV} ${XMKMF} ${XMKMF_ARGS})
.endif
.if !defined(NO_INSTALL_MANPAGES)
diff --git a/Mk/bsd.commands.mk b/Mk/bsd.commands.mk
index 5eb0230c9518..3da333dbf329 100644
--- a/Mk/bsd.commands.mk
+++ b/Mk/bsd.commands.mk
@@ -97,7 +97,7 @@ UNMAKESELF_CMD?= ${LOCALBASE}/bin/unmakeself
UNZIP_CMD?= ${LOCALBASE}/bin/unzip
WHICH?= /usr/bin/which
XARGS?= /usr/bin/xargs
-XMKMF?= ${LOCALBASE}/bin/xmkmf -a
+XMKMF?= ${LOCALBASE}/bin/xmkmf
YACC?= /usr/bin/yacc
XZ?= -Mmax
diff --git a/devel/imake/Makefile b/devel/imake/Makefile
index 6e2b3111285e..be0a13e36a2d 100644
--- a/devel/imake/Makefile
+++ b/devel/imake/Makefile
@@ -3,6 +3,7 @@
PORTNAME= imake
PORTVERSION= 1.0.6
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel
diff --git a/devel/imake/files/patch-imake.c b/devel/imake/files/patch-imake.c
index ff5609748481..6fc194f876a5 100644
--- a/devel/imake/files/patch-imake.c
+++ b/devel/imake/files/patch-imake.c
@@ -1,6 +1,21 @@
---- imake.c.orig Tue Jan 30 14:57:37 2007
-+++ imake.c Tue Jan 30 14:55:59 2007
-@@ -1153,29 +1153,17 @@
+--- imake.c.orig 2013-07-23 06:53:04.000000000 +0200
++++ imake.c 2013-08-31 14:57:48.000000000 +0200
+@@ -531,6 +531,14 @@
+ AddCppArg(p);
+ }
+ }
++ if ((p = getenv("IMAKECPPFLAGS"))) {
++ AddCppArg(p);
++ for (; *p; p++)
++ if (*p == ' ') {
++ *p++ = '\0';
++ AddCppArg(p);
++ }
++ }
+ if ((p = getenv("IMAKECPP")))
+ cpp = p;
+ if ((p = getenv("IMAKEMAKE")))
+@@ -1142,29 +1150,17 @@
int mib[2];
size_t len;
int osrel = 0;
diff --git a/devel/imake/files/patch-xmkmf.cpp b/devel/imake/files/patch-xmkmf.cpp
deleted file mode 100644
index 75e496452af7..000000000000
--- a/devel/imake/files/patch-xmkmf.cpp
+++ /dev/null
@@ -1,24 +0,0 @@
---- xmkmf.cpp.orig 2012-03-08 06:47:32.000000000 +0100
-+++ xmkmf.cpp 2013-06-28 11:55:04.174394058 +0200
-@@ -8,7 +8,7 @@
- topdir=
- curdir=.
- do_all=
--imake_defines=
-+imake_defines="${IMAKECPPFLAGS}"
-
- while [ $# -gt 0 ]
- do
-@@ -64,3 +64,12 @@
- imake $imake_defines $args
- ;;
- esac
-+
-+if [ -f "Makefile" ];then
-+ if [ -n "$CC" ];then
-+ sed -i "" -e "s| CC = cc| CC = $CC|" Makefile
-+ fi
-+ if [ -n "$CXX" ];then
-+ sed -i "" -e "s| CXX = c++| CXX = $CXX|" Makefile
-+ fi
-+fi
diff --git a/editors/asedit/Makefile b/editors/asedit/Makefile
index 85b69bf2ce73..921311b8cabd 100644
--- a/editors/asedit/Makefile
+++ b/editors/asedit/Makefile
@@ -12,9 +12,8 @@ EXTRACT_SUFX= .tar.Z
MAINTAINER= ports@FreeBSD.org
COMMENT= Text editor for X/Motif
-USES= imake motif
+USES= imake:notall motif
USE_XORG= ice sm x11 xext xmu xp xt
-XMKMF= xmkmf
MAN1= asedit.1
diff --git a/emulators/spim/Makefile b/emulators/spim/Makefile
index 2bbb8e43ae94..ee10f4f09f4f 100644
--- a/emulators/spim/Makefile
+++ b/emulators/spim/Makefile
@@ -34,7 +34,7 @@ MAN1+= xspim.1
post-build:
.if ${PORT_OPTIONS:MGUI}
- @(cd ${WRKSRC}/xspim && ${SETENV} ${MAKE_ENV} ${XMKMF} && \
+ @(cd ${WRKSRC}/xspim && ${SETENV} ${MAKE_ENV} ${XMKMF} ${XMKMF_ARGS} && \
${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE})
.endif
diff --git a/games/cosmo/Makefile b/games/cosmo/Makefile
index 08025817ee85..5ef0cfc8c57b 100644
--- a/games/cosmo/Makefile
+++ b/games/cosmo/Makefile
@@ -22,9 +22,8 @@ NO_CDROM= Possible copyright infringement
WRKSRC= ${WRKDIR}/cosmo2
DIST_SUBDIR= cosmo
-USES= imake
+USES= imake:notall
USE_XORG= x11 xext
-XMKMF= xmkmf
NO_INSTALL_MANPAGES= yes
post-install:
diff --git a/graphics/xmagv/Makefile b/graphics/xmagv/Makefile
index 46247b2f8ee0..a2539e02e99e 100644
--- a/graphics/xmagv/Makefile
+++ b/graphics/xmagv/Makefile
@@ -16,7 +16,6 @@ USES= imake:env
WRKSRC= ${WRKDIR}/${PORTNAME}
GNU_CONFIGURE= yes
USE_XORG= x11 xext
-XMKMF= xmkmf
MANLANG= . ja
MAN1= xmagv.1
diff --git a/graphics/xpx/Makefile b/graphics/xpx/Makefile
index 9a59ff8fcfbd..499dd73ac370 100644
--- a/graphics/xpx/Makefile
+++ b/graphics/xpx/Makefile
@@ -13,9 +13,8 @@ COMMENT= Simple pixel editing tool to generate data for KISS
WRKSRC= ${WRKDIR}/${PORTNAME}
-USES= imake
+USES= imake:notall
USE_XORG= x11 xext
-XMKMF= xmkmf
DOCSDIR= ${PREFIX}/share/doc/ja/${PORTNAME}
PORTDOCS= xpx.doc xpxrc.eg
diff --git a/japanese/canna-lib/Makefile b/japanese/canna-lib/Makefile
index 7dcefd6fd578..59a78f55ac9a 100644
--- a/japanese/canna-lib/Makefile
+++ b/japanese/canna-lib/Makefile
@@ -13,7 +13,7 @@ DISTNAME= Canna${PORTVERSION:S/.//g}
MAINTAINER= hrs@FreeBSD.org
COMMENT= A Kana-to-Kanji conversion system, library part
-USES= imake
+USES= imake:notall
USE_BZIP2= yes
USE_GCC= any
USE_LDCONFIG= yes
@@ -24,7 +24,6 @@ PLIST_SUB= METAFILE="${METAFILE}" \
ALL_TARGET= canna
INSTALL_TARGET= instsgs
-XMKMF= xmkmf
METAFILE= ${DATADIR_REL}/canna-lib-dic.meta
diff --git a/japanese/canna-server/Makefile b/japanese/canna-server/Makefile
index 87c0fd468182..6279a5b369eb 100644
--- a/japanese/canna-server/Makefile
+++ b/japanese/canna-server/Makefile
@@ -19,7 +19,6 @@ USES= imake
USE_GCC= any
USE_RC_SUBR= canna
USE_BZIP2= yes
-ALL_TARGET= canna
INSTALL_TARGET= instserver instclient
PLIST_SUB= METAFILE="${METAFILE}" \
MTREE_CMD="${MTREE_CMD}"
@@ -46,9 +45,6 @@ MLINKS= uilib.3 XKanjiControl.3 uilib.3 XLookupKanjiString.3 uilib.3 \
METAFILE= ${DATADIR_REL}/canna-server-dic.meta
-post-configure:
- @cd ${CONFIGURE_WRKSRC} && ${SETENV} ${MAKE_ENV} ${XMKMF}
-
post-install:
@cd ${INSTALL_WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} install.man
${MTREE_CMD} -cdink uname,gname,mode,nochange \
diff --git a/misc/magicpoint/Makefile b/misc/magicpoint/Makefile
index 7c786cc9703b..2f72854ccfbf 100644
--- a/misc/magicpoint/Makefile
+++ b/misc/magicpoint/Makefile
@@ -83,7 +83,7 @@ post-patch:
${WRKSRC}/configure
post-configure:
- (cd ${CONFIGURE_WRKSRC} && ${SETENV} ${MAKE_ENV} ${XMKMF})
+ (cd ${CONFIGURE_WRKSRC} && ${SETENV} ${MAKE_ENV} ${XMKMF} ${XMKMF_ARGS})
cd ${WRKSRC}/contrib/xmindpath && \
${SH} ${CONFIGURE_SCRIPT} --prefix=${PREFIX}
diff --git a/print/xdvi/Makefile b/print/xdvi/Makefile
index 765f96855166..31bce59d110b 100644
--- a/print/xdvi/Makefile
+++ b/print/xdvi/Makefile
@@ -16,12 +16,11 @@ COMMENT= DVI previewer for the X Window System
CONFLICTS= teTeX-*
-USES= gmake imake
+USES= gmake imake:notall
USE_XORG= ice sm x11 xaw xext xmu xt xpm
PKGINSTALL= ${WRKDIR}/pkg-install
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
PLIST_SUB= LOCALBASE=${LOCALBASE}
-XMKMF= xmkmf
.if defined(PACKAGE_BUILDING)
SCRIPTS_ENV= PACKAGE_BUILDING=${PACKAGE_BUILDING}
.else
diff --git a/security/xspy/Makefile b/security/xspy/Makefile
index d840855d0e3d..6ef685165443 100644
--- a/security/xspy/Makefile
+++ b/security/xspy/Makefile
@@ -11,9 +11,8 @@ MAINTAINER= onatan@gmail.com
COMMENT= A utility for monitoring keystrokes on remote X servers
WRKSRC= ${WRKDIR}/${PORTNAME}
-USES= imake
+USES= imake:notall
USE_XORG= x11
-XMKMF= xmkmf
ALL_TARGET= xspy
diff --git a/x11-clocks/mouseclock/Makefile b/x11-clocks/mouseclock/Makefile
index 416880fc84d6..2ddfc1984d19 100644
--- a/x11-clocks/mouseclock/Makefile
+++ b/x11-clocks/mouseclock/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mouseclock
PORTVERSION= 1.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11-clocks
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= X11/clocks
@@ -11,13 +11,8 @@ MASTER_SITE_SUBDIR= X11/clocks
MAINTAINER= ports@FreeBSD.org
COMMENT= Display the current time using the X root cursor
-USES= imake
-USE_GMAKE= yes
-USE_XORG= x11 xext
-NO_INSTALL_MANPAGES= yes
-
-post-configure:
- @${TOUCH} ${WRKSRC}/mouseclock.man
+USES= imake:notall
+USE_XORG= x11
post-install:
.if !defined(NOPORTDOCS)
diff --git a/x11-clocks/mouseclock/files/patch-Imakefile b/x11-clocks/mouseclock/files/patch-Imakefile
new file mode 100644
index 000000000000..f380fd00b7cf
--- /dev/null
+++ b/x11-clocks/mouseclock/files/patch-Imakefile
@@ -0,0 +1,23 @@
+--- Imakefile.orig 1996-05-05 18:51:27.000000000 +0200
++++ Imakefile 2013-09-01 17:04:26.000000000 +0200
+@@ -1,16 +1,10 @@
+
+-#define IHaveSubdirs
+-#define PassCDebugFlags 'CDEBUGFLAGS=$(CDEBUGFLAGS)'
++OBJS = mouseclock.o
++SRCS = mouseclock.c
++SYS_LIBRARIES = $(XONLYLIB)
+
+- DEPLIBS = $(DEPXLIB)
+-LOCAL_LIBRARIES = $(XLIB)
+- CDEBUGFLAGS =
+- CCOPTIONS = -O3 -s -pipe -Wall
+
+-AllTarget(mouseclock)
+-
+-MakeMakeSubdirs($(SUBDIRS),install)
+-SimpleProgramTarget(mouseclock)
++ComplexProgramTargetNoMan(mouseclock)
+
+ arc : clean
+ (cd .. ; tar zcvf mouseclock.tar.gz mouseclock)
diff --git a/x11-wm/fvwm/Makefile b/x11-wm/fvwm/Makefile
index 0294efb80b14..5cc6bae18b47 100644
--- a/x11-wm/fvwm/Makefile
+++ b/x11-wm/fvwm/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fvwm
PORTVERSION= 1.24r
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11-wm
MASTER_SITES= ftp://ftp.fvwm.org/pub/fvwm/version-1/
@@ -11,17 +11,16 @@ MAINTAINER= dinoex@FreeBSD.org
COMMENT= The fvwm window manager
NO_LATEST_LINK= yes
-MAKE_JOBS_UNSAFE= yes
USES= imake
USE_XORG= xbitmaps xpm xext x11 xmu
-ALL_TARGET= Makefiles all
MAN1= FvwmAudio.1 FvwmAuto.1 FvwmBacker.1 FvwmBanner.1 FvwmClean.1 \
FvwmDebug.1 FvwmIconBox.1 FvwmIdent.1 FvwmPager.1 FvwmSave.1 \
FvwmSaveDesk.1 FvwmScroll.1 FvwmWinList.1 GoodStuff.1 fvwm.1 \
xpmroot.1
pre-configure:
+ @${REINPLACE_CMD} -e '/DependSubdirs/y,/*#, ,' ${WRKSRC}/Imakefile
${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
${WRKSRC}/configure.h \
${WRKSRC}/sample.fvwmrc/system.fvwmrc
diff --git a/x11/xgrab/Makefile b/x11/xgrab/Makefile
index 7cc45a890fad..667c49c96530 100644
--- a/x11/xgrab/Makefile
+++ b/x11/xgrab/Makefile
@@ -15,13 +15,11 @@ COMMENT= X11 image grabber
BUILD_DEPENDS= xrdb:${PORTSDIR}/x11/xrdb
-USES= display:build imake
+USES= display:build imake:notall
USE_XORG= x11
MAKE_FLAGS= BINDIR=${PREFIX}/bin MANDIR=${PREFIX}/man/man1 \
XAPPLOADDIR=${PREFIX}/lib/X11/app-defaults -f
-# "make depend" blows up
-XMKMF= xmkmf
CFLAGS+= -Wno-error=return-type
MAN1= xgrab.1 xgrabsc.1
diff --git a/x11/xxkb/Makefile b/x11/xxkb/Makefile
index 87aab5d552e5..45f7a7c87017 100644
--- a/x11/xxkb/Makefile
+++ b/x11/xxkb/Makefile
@@ -25,7 +25,7 @@ OPTIONS_DEFINE= LIBRSVG2 DOCS
.if ${PORT_OPTIONS:MLIBRSVG2}
LIB_DEPENDS= rsvg-2:${PORTSDIR}/graphics/librsvg2
-XMKMF= xmkmf -a -DWITH_SVG_SUPPORT
+XMKMF_ARGS= -DWITH_SVG_SUPPORT
.endif
post-build: