aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/kcachegrind/Makefile31
-rw-r--r--devel/kcachegrind/distinfo2
-rw-r--r--devel/kcachegrind/pkg-descr4
-rw-r--r--devel/kcachegrind/pkg-plist34
5 files changed, 72 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 01bb5257c5ab..a35e474280c0 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -356,6 +356,7 @@
SUBDIR += jrtplib
SUBDIR += jude_take
SUBDIR += kaptain
+ SUBDIR += kcachegrind
SUBDIR += kdbg
SUBDIR += kdesdk3
SUBDIR += kdevelop
diff --git a/devel/kcachegrind/Makefile b/devel/kcachegrind/Makefile
new file mode 100644
index 000000000000..ebc195c4f029
--- /dev/null
+++ b/devel/kcachegrind/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: KCachegrind
+# Date created: Jun 3 2004
+# Whom: Simon Barner <barner@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kcachegrind
+PORTVERSION= 0.4.5
+CATEGORIES= devel kde
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= kcachegrind
+
+MAINTAINER= barner@gmx.de
+COMMENT= Profiling Visualization Tool
+
+BUILD_DEPENDS= mcopidl:${PORTSDIR}/audio/arts
+RUN_DEPENDS= calltree:${PORTSDIR}/devel/calltree
+
+CONFLICTS= kdesdk3-[0-9]*
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_KDELIBS_VER=3
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||g' -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>
diff --git a/devel/kcachegrind/distinfo b/devel/kcachegrind/distinfo
new file mode 100644
index 000000000000..40705bde3bf0
--- /dev/null
+++ b/devel/kcachegrind/distinfo
@@ -0,0 +1,2 @@
+MD5 (kcachegrind-0.4.5.tar.gz) = d195aa468fd643811ffe09f6e6491e9c
+SIZE (kcachegrind-0.4.5.tar.gz) = 960382
diff --git a/devel/kcachegrind/pkg-descr b/devel/kcachegrind/pkg-descr
new file mode 100644
index 000000000000..fa7a06477769
--- /dev/null
+++ b/devel/kcachegrind/pkg-descr
@@ -0,0 +1,4 @@
+KCachegrind is a visualization tool for the profiling data generated by
+Cachegrind (which is part of valgrind) and Calltree.
+
+WWW: http://kcachegrind.sourceforge.net
diff --git a/devel/kcachegrind/pkg-plist b/devel/kcachegrind/pkg-plist
new file mode 100644
index 000000000000..c18bfa7dd4c1
--- /dev/null
+++ b/devel/kcachegrind/pkg-plist
@@ -0,0 +1,34 @@
+bin/dprof2calltree
+bin/hotshot2calltree
+bin/kcachegrind
+bin/op2calltree
+bin/pprof2calltree
+share/applnk/Development/kcachegrind.desktop
+share/apps/kcachegrind/icons/hicolor/16x16/actions/fromrec.png
+share/apps/kcachegrind/icons/hicolor/16x16/actions/percent.png
+share/apps/kcachegrind/icons/hicolor/16x16/actions/recrec.png
+share/apps/kcachegrind/icons/hicolor/16x16/actions/torec.png
+share/apps/kcachegrind/icons/hicolor/22x22/actions/percent.png
+share/apps/kcachegrind/icons/hicolor/32x32/actions/percent.png
+share/apps/kcachegrind/kcachegrindui.rc
+share/apps/kcachegrind/tips
+share/doc/HTML/en/kcachegrind/index.docbook
+share/doc/HTML/en/kcachegrind/index.cache.bz2
+share/icons/hicolor/32x32/apps/kcachegrind.png
+share/icons/hicolor/48x48/apps/kcachegrind.png
+share/icons/locolor/16x16/apps/kcachegrind.png
+share/icons/locolor/32x32/apps/kcachegrind.png
+share/locale/de/LC_MESSAGES/kcachegrind.mo
+share/locale/fr/LC_MESSAGES/kcachegrind.mo
+share/locale/it/LC_MESSAGES/kcachegrind.mo
+share/mimelnk/application/x-kcachegrind.desktop
+@dirrm share/apps/kcachegrind/icons/hicolor/32x32/actions
+@dirrm share/apps/kcachegrind/icons/hicolor/32x32
+@dirrm share/apps/kcachegrind/icons/hicolor/22x22/actions
+@dirrm share/apps/kcachegrind/icons/hicolor/22x22
+@dirrm share/apps/kcachegrind/icons/hicolor/16x16/actions
+@dirrm share/apps/kcachegrind/icons/hicolor/16x16
+@dirrm share/apps/kcachegrind/icons/hicolor
+@dirrm share/apps/kcachegrind/icons
+@dirrm share/apps/kcachegrind
+@dirrm share/doc/HTML/en/kcachegrind