aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/postfix/Makefile8
-rw-r--r--mail/postfix26/Makefile8
-rw-r--r--mail/postfix27/Makefile8
-rw-r--r--mail/postfix28/Makefile8
4 files changed, 24 insertions, 8 deletions
diff --git a/mail/postfix/Makefile b/mail/postfix/Makefile
index 028f1ba0cfc5..9277c93611aa 100644
--- a/mail/postfix/Makefile
+++ b/mail/postfix/Makefile
@@ -83,6 +83,10 @@ MLINKS= sendmail.1 mailq.1 \
HTML1= SOHO_README.html body_checks.5.html bounce.5.html postfix-power.png \
scache.8.html tlsmgr.8.html
+.if ${OSVERSION} >= 800037
+KRB5_EXTR= -lhx509
+.endif
+
.if !defined(DEBUG)
MAKEFILEFLAGS+= DEBUG=
.endif
@@ -128,7 +132,7 @@ _REQUIRE+= dovecot
.if defined(WITH_SASLKRB)
.if defined(WITH_SASLKRB5) || defined(WITH_SASLKMIT)
-BROKEN= Select only one SASL Kerberos option
+BROKEN= Select only one SASL Kerberos option
.endif
POSTFIX_AUXLIBS+= -lkrb -lcrypto -lcom_err
.endif
@@ -137,7 +141,7 @@ POSTFIX_AUXLIBS+= -lkrb -lcrypto -lcom_err
.if defined(WITH_SASLKRB) || defined(WITH_SASLKMIT)
BROKEN= Select only one SASL Kerberos option
.endif
-POSTFIX_AUXLIBS+= -lkrb5 -lcrypto -lcrypt -lcom_err -lasn1 -lroken
+POSTFIX_AUXLIBS+= -lkrb5 ${KRB5_EXTR} -lcrypto -lcrypt -lcom_err -lasn1 -lroken
.endif
.if defined(WITH_SASLKMIT)
diff --git a/mail/postfix26/Makefile b/mail/postfix26/Makefile
index 028f1ba0cfc5..9277c93611aa 100644
--- a/mail/postfix26/Makefile
+++ b/mail/postfix26/Makefile
@@ -83,6 +83,10 @@ MLINKS= sendmail.1 mailq.1 \
HTML1= SOHO_README.html body_checks.5.html bounce.5.html postfix-power.png \
scache.8.html tlsmgr.8.html
+.if ${OSVERSION} >= 800037
+KRB5_EXTR= -lhx509
+.endif
+
.if !defined(DEBUG)
MAKEFILEFLAGS+= DEBUG=
.endif
@@ -128,7 +132,7 @@ _REQUIRE+= dovecot
.if defined(WITH_SASLKRB)
.if defined(WITH_SASLKRB5) || defined(WITH_SASLKMIT)
-BROKEN= Select only one SASL Kerberos option
+BROKEN= Select only one SASL Kerberos option
.endif
POSTFIX_AUXLIBS+= -lkrb -lcrypto -lcom_err
.endif
@@ -137,7 +141,7 @@ POSTFIX_AUXLIBS+= -lkrb -lcrypto -lcom_err
.if defined(WITH_SASLKRB) || defined(WITH_SASLKMIT)
BROKEN= Select only one SASL Kerberos option
.endif
-POSTFIX_AUXLIBS+= -lkrb5 -lcrypto -lcrypt -lcom_err -lasn1 -lroken
+POSTFIX_AUXLIBS+= -lkrb5 ${KRB5_EXTR} -lcrypto -lcrypt -lcom_err -lasn1 -lroken
.endif
.if defined(WITH_SASLKMIT)
diff --git a/mail/postfix27/Makefile b/mail/postfix27/Makefile
index 028f1ba0cfc5..9277c93611aa 100644
--- a/mail/postfix27/Makefile
+++ b/mail/postfix27/Makefile
@@ -83,6 +83,10 @@ MLINKS= sendmail.1 mailq.1 \
HTML1= SOHO_README.html body_checks.5.html bounce.5.html postfix-power.png \
scache.8.html tlsmgr.8.html
+.if ${OSVERSION} >= 800037
+KRB5_EXTR= -lhx509
+.endif
+
.if !defined(DEBUG)
MAKEFILEFLAGS+= DEBUG=
.endif
@@ -128,7 +132,7 @@ _REQUIRE+= dovecot
.if defined(WITH_SASLKRB)
.if defined(WITH_SASLKRB5) || defined(WITH_SASLKMIT)
-BROKEN= Select only one SASL Kerberos option
+BROKEN= Select only one SASL Kerberos option
.endif
POSTFIX_AUXLIBS+= -lkrb -lcrypto -lcom_err
.endif
@@ -137,7 +141,7 @@ POSTFIX_AUXLIBS+= -lkrb -lcrypto -lcom_err
.if defined(WITH_SASLKRB) || defined(WITH_SASLKMIT)
BROKEN= Select only one SASL Kerberos option
.endif
-POSTFIX_AUXLIBS+= -lkrb5 -lcrypto -lcrypt -lcom_err -lasn1 -lroken
+POSTFIX_AUXLIBS+= -lkrb5 ${KRB5_EXTR} -lcrypto -lcrypt -lcom_err -lasn1 -lroken
.endif
.if defined(WITH_SASLKMIT)
diff --git a/mail/postfix28/Makefile b/mail/postfix28/Makefile
index 028f1ba0cfc5..9277c93611aa 100644
--- a/mail/postfix28/Makefile
+++ b/mail/postfix28/Makefile
@@ -83,6 +83,10 @@ MLINKS= sendmail.1 mailq.1 \
HTML1= SOHO_README.html body_checks.5.html bounce.5.html postfix-power.png \
scache.8.html tlsmgr.8.html
+.if ${OSVERSION} >= 800037
+KRB5_EXTR= -lhx509
+.endif
+
.if !defined(DEBUG)
MAKEFILEFLAGS+= DEBUG=
.endif
@@ -128,7 +132,7 @@ _REQUIRE+= dovecot
.if defined(WITH_SASLKRB)
.if defined(WITH_SASLKRB5) || defined(WITH_SASLKMIT)
-BROKEN= Select only one SASL Kerberos option
+BROKEN= Select only one SASL Kerberos option
.endif
POSTFIX_AUXLIBS+= -lkrb -lcrypto -lcom_err
.endif
@@ -137,7 +141,7 @@ POSTFIX_AUXLIBS+= -lkrb -lcrypto -lcom_err
.if defined(WITH_SASLKRB) || defined(WITH_SASLKMIT)
BROKEN= Select only one SASL Kerberos option
.endif
-POSTFIX_AUXLIBS+= -lkrb5 -lcrypto -lcrypt -lcom_err -lasn1 -lroken
+POSTFIX_AUXLIBS+= -lkrb5 ${KRB5_EXTR} -lcrypto -lcrypt -lcom_err -lasn1 -lroken
.endif
.if defined(WITH_SASLKMIT)