aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/apg/Makefile4
-rw-r--r--security/apg/distinfo2
-rw-r--r--security/apg/files/patch-aa16
3 files changed, 10 insertions, 12 deletions
diff --git a/security/apg/Makefile b/security/apg/Makefile
index bd880a4ecd89..deaaddcb5f18 100644
--- a/security/apg/Makefile
+++ b/security/apg/Makefile
@@ -6,11 +6,9 @@
#
PORTNAME= apg
-PORTVERSION= 2.0.0
+PORTVERSION= 2.1.0
CATEGORIES= security
MASTER_SITES= http://www.adel.nursat.kz/apg/download/
-DISTRELTAG= final
-DISTNAME= ${PORTNAME}-${PORTVERSION}${DISTRELTAG}
MAINTAINER= roam@FreeBSD.org
diff --git a/security/apg/distinfo b/security/apg/distinfo
index 743b33a66e2f..ebd05b405e95 100644
--- a/security/apg/distinfo
+++ b/security/apg/distinfo
@@ -1 +1 @@
-MD5 (apg-2.0.0final.tar.gz) = e7d9faaa9d815037681ee75fc0198c46
+MD5 (apg-2.1.0.tar.gz) = 402769cce2c5ffef9806993d93c5b56d
diff --git a/security/apg/files/patch-aa b/security/apg/files/patch-aa
index 303b4ddcd1b4..89340e111829 100644
--- a/security/apg/files/patch-aa
+++ b/security/apg/files/patch-aa
@@ -1,5 +1,5 @@
---- Makefile 21 May 2002 10:01:23 -0000 1.1.1.3
-+++ Makefile 21 May 2002 10:07:25 -0000 1.5
+--- Makefile 20 Sep 2002 07:24:50 -0000 1.1.1.4
++++ Makefile 20 Sep 2002 07:27:21 -0000 1.6
@@ -1,12 +1,12 @@
##################################################################
# You can modify CC variable if you have compiler other than GCC
@@ -29,16 +29,16 @@
cygwin: standalone
apg:
-- ${CC} ${FLAGS} ${LIBS} ${LIBM} -D${CRYPTED_PASS} -D${USE_SHA} -o ${PROGNAME} ${SOURCES}
-+ ${CC} ${CFLAGS} ${LIBS} ${LIBM} -D${CRYPTED_PASS} -D${USE_SHA} -o ${PROGNAME} ${SOURCES}
+- ${CC} ${FLAGS} -D${CRYPTED_PASS} -D${USE_SHA} -o ${PROGNAME} ${SOURCES} ${LIBS} ${LIBM}
++ ${CC} ${CFLAGS} -D${CRYPTED_PASS} -D${USE_SHA} -o ${PROGNAME} ${SOURCES} ${LIBS} ${LIBM}
apgd:
-- ${CC} ${FLAGS} ${CS_LIBS} ${LIBM} -DCLISERV -D${USE_SHA} -o ${CS_PROGNAME} ${SOURCES}
-+ ${CC} ${CFLAGS} ${CS_LIBS} ${LIBM} -DCLISERV -D${USE_SHA} -o ${CS_PROGNAME} ${SOURCES}
+- ${CC} ${FLAGS} -DCLISERV -D${USE_SHA} -o ${CS_PROGNAME} ${SOURCES} ${CS_LIBS} ${LIBM}
++ ${CC} ${CFLAGS} -DCLISERV -D${USE_SHA} -o ${CS_PROGNAME} ${SOURCES} ${CS_LIBS} ${LIBM}
apgbfm:
-- ${CC} ${FLAGS} ${LIBM} -o ${BFM_PROGNAME} ${BFM_SOURCES}
-+ ${CC} ${CFLAGS} ${LIBM} -o ${BFM_PROGNAME} ${BFM_SOURCES}
+- ${CC} ${FLAGS} -o ${BFM_PROGNAME} ${BFM_SOURCES} ${LIBM}
++ ${CC} ${CFLAGS} -o ${BFM_PROGNAME} ${BFM_SOURCES} ${LIBM}
strip:
strip ${PROGNAME}