aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/xaira/Makefile52
-rw-r--r--textproc/xaira/distinfo3
-rw-r--r--textproc/xaira/files/patch-configure.in51
-rw-r--r--textproc/xaira/files/pkg-message.in11
-rw-r--r--textproc/xaira/files/xaira-server.in18
-rw-r--r--textproc/xaira/pkg-descr18
-rw-r--r--textproc/xaira/pkg-plist22
8 files changed, 176 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index dee7897d48a0..d719eb228233 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -996,6 +996,7 @@
SUBDIR += words
SUBDIR += wv
SUBDIR += wv2
+ SUBDIR += xaira
SUBDIR += xalan-c
SUBDIR += xalan-j
SUBDIR += xerces-c
diff --git a/textproc/xaira/Makefile b/textproc/xaira/Makefile
new file mode 100644
index 000000000000..190ef6a065e3
--- /dev/null
+++ b/textproc/xaira/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: xaira
+# Date created: 10 September 2007
+# Whom: Mathias Monnerville <mathias@monnerville.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xaira
+PORTVERSION= 1.23
+CATEGORIES= textproc
+MASTER_SITES= SF
+
+MAINTAINER= mathias@monnerville.com
+COMMENT= XML Aware Indexing and Retrieval Architecture
+
+LIB_DEPENDS= xerces-c:${PORTSDIR}/textproc/xerces-c2 \
+ icuio:${PORTSDIR}/devel/icu
+BUILD_DEPENDS= ${LIBTOOL}:${PORTSDIR}/devel/libtool15
+
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS= aclocal:19 autoconf:259 libtool:15
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+
+USE_RC_SUBR= xaira-server
+SUB_FILES+= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+OPTIONS= PHP5 "Build PHP5 extension" no
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PHP5)
+BUILD_DEPENDS+= php5>=5:${PORTSDIR}/lang/php5
+CONFIGURE_ARGS+= --with-php5=`${LOCALBASE}/bin/php-config --include-dir`
+PLIST_FILES+= lib/libphpXaira.a \
+ lib/libphpXaira.la \
+ lib/libphpXaira.so \
+ lib/libphpXaira.so.0
+.endif
+
+post-patch:
+ @${FIND} ${WRKSRC} -name Makefile.am -exec \
+ ${REINPLACE_CMD} -e 's,^AM_CPPFLAGS.*$$,& $${icu_cppflags},' {} \;
+
+pre-configure:
+ @${CP} ${LIBTOOL_SHAREDIR}/libltdl/acinclude.m4 ${WRKSRC}/
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/textproc/xaira/distinfo b/textproc/xaira/distinfo
new file mode 100644
index 000000000000..dd3ac0eac4d2
--- /dev/null
+++ b/textproc/xaira/distinfo
@@ -0,0 +1,3 @@
+MD5 (xaira-1.23.tar.gz) = 40b0b5f1b7b07586d8d590543c2c5a39
+SHA256 (xaira-1.23.tar.gz) = 57a65b4b23e6d7c7914a76856d337f4477f0bd3c6e20458630b13edecfaf4c7c
+SIZE (xaira-1.23.tar.gz) = 946753
diff --git a/textproc/xaira/files/patch-configure.in b/textproc/xaira/files/patch-configure.in
new file mode 100644
index 000000000000..97e4e344874c
--- /dev/null
+++ b/textproc/xaira/files/patch-configure.in
@@ -0,0 +1,51 @@
+--- configure.in Wed Dec 20 21:53:46 2006
++++ configure.in.new Thu Feb 8 13:08:41 2007
+@@ -3,8 +3,8 @@
+ AC_PROG_CXX
+ AC_PROG_LIBTOOL
+ AC_CHECK_HEADERS(asm/byteorder.h netinet/in.h errno.h crypt.h)
+-AC_CHECK_HEADERS(unicode/uversion.h,,[AC_MSG_ERROR(cannot find ICU headers)])
+-AC_CHECK_HEADERS(xercesc/util/XercesVersion.hpp,,[AC_MSG_ERROR(cannot find xercesc headers)])
++#AC_CHECK_HEADERS(unicode/uversion.h,,[AC_MSG_ERROR(cannot find ICU headers)])
++#AC_CHECK_HEADERS(xercesc/util/XercesVersion.hpp,,[AC_MSG_ERROR(cannot find xercesc headers)])
+ AC_CHECK_HEADERS(zlib.h,,[AC_MSG_ERROR(cannot find zlib.h)])
+ AC_CHECK_TYPES(socklen_t,,,[
+ #include <sys/types.h>
+@@ -16,13 +16,22 @@
+ AC_CHECK_FUNC(gethostbyname, ,[AC_CHECK_LIB(nsl, gethostbyname)])
+ AC_CHECK_LIB(crypt,crypt)
+
+-dnl Platform-specific Makefile setup
+-case "${host}" in
+- *-*-cygwin*) ICU="-lsicuin -lsicuuc -lsicudt" ;ICUS=" -DU_STATIC_IMPLEMENTATION";;
+- *) ICU="-licui18n -licuuc -licudata";ICUS="";;
+-esac
+
+-
++dnl ICU checks
++AC_CHECK_PROG(ICU_CONFIG, icu-config, yes)
++
++if test x$ICU_CONFIG = xyes; then
++ dnl Platform-specific Makefile setup
++ icu_ldflags=`icu-config --ldflags`
++ icu_cppflags=`icu-config --cppflags`
++ case "${host}" in
++ *-*-cygwin*) ICU="-lsicuin -lsicuuc -lsicudt" ;ICUS=" -DU_STATIC_IMPLEMENTATION";;
++ *) ICU="${icu_ldflags}";ICUS="";;
++ esac
++else
++ AC_MSG_ERROR([ICU is required but is not installed on your system])
++fi
++
+ AC_MSG_CHECKING([whether to install Axis CPP support])
+ if test "x$AXISCPP_DEPLOY" != "x" && test -d $AXISCPP_DEPLOY;
+ then
+@@ -51,6 +60,8 @@
+ AC_SUBST(ACCESSLOG)
+ AC_SUBST(PHPPATH)
+ AC_SUBST(PHPEXT)
++AC_SUBST(icu_ldflags)
++AC_SUBST(icu_cppflags)
+
+ AC_OUTPUT(Makefile indexer/Makefile server/Makefile oldserver/Makefile xaira_daemon/Makefile xaira_proxy/Makefile samples/Makefile xaira_soap/Makefile xaira_test/Makefile xaira_php/Makefile)
+
diff --git a/textproc/xaira/files/pkg-message.in b/textproc/xaira/files/pkg-message.in
new file mode 100644
index 000000000000..594d7af9bd8c
--- /dev/null
+++ b/textproc/xaira/files/pkg-message.in
@@ -0,0 +1,11 @@
+*********************************************************************
+Installation notes:
+
+To start xaira server from startup, add xaira_enable="YES"
+in /etc/rc.conf.
+
+Also, you have to specify the path to the corpus parameter file:
+
+xaira_flags="-p /path/to/your/corpus_parameter_file"
+
+*********************************************************************
diff --git a/textproc/xaira/files/xaira-server.in b/textproc/xaira/files/xaira-server.in
new file mode 100644
index 000000000000..97546e033922
--- /dev/null
+++ b/textproc/xaira/files/xaira-server.in
@@ -0,0 +1,18 @@
+#!/bin/sh
+#
+
+# Add the following line to /etc/rc.conf to enable xaira:
+#
+# xaira_enable="YES"
+
+# PROVIDE: sarad
+
+. %%RC_SUBR%%
+
+name="xaira"
+rcvar=`set_rcvar`
+
+command=%%PREFIX%%/sbin/xaira_daemon
+
+load_rc_config $name
+run_rc_command "$1"
diff --git a/textproc/xaira/pkg-descr b/textproc/xaira/pkg-descr
new file mode 100644
index 000000000000..5018b3c1c285
--- /dev/null
+++ b/textproc/xaira/pkg-descr
@@ -0,0 +1,18 @@
+Xaira is an XML Aware Indexing and Retrieval Application
+designed to allow fast access to large corpora marked up
+in XML.
+
+Xaira is the current name for a new version of SARA, the text
+searching software originally developed at OUCS for use with
+the British National Corpus.
+
+This new version has been entirely re-written as a general
+purpose XML search engine, which will operate on any corpus
+of well-formed XML documents. It is however best used with
+TEI-conformant documents.
+
+Xaira has full Unicode support. This means you can use it to
+search and display text in any language, provided you have a
+suitable Unicode font installed on your system.
+
+WWW: http://www.xaira.org
diff --git a/textproc/xaira/pkg-plist b/textproc/xaira/pkg-plist
new file mode 100644
index 000000000000..02e570fe0657
--- /dev/null
+++ b/textproc/xaira/pkg-plist
@@ -0,0 +1,22 @@
+bin/indexer
+bin/solve
+bin/xaira_test
+include/XairoHeader.h
+lib/libSaraServer.a
+lib/libSaraServer.la
+lib/libSaraServer.so
+lib/libSaraServer.so.0
+lib/libXaira.a
+lib/libXaira.la
+lib/libXaira.so
+lib/libXaira.so.0
+lib/libXairaProxy.a
+lib/libXairaProxy.la
+lib/libXairaProxy.so
+lib/libXairaProxy.so.0
+sbin/xaira_daemon
+%%DATADIR%%/cql.xsd
+%%DATADIR%%/xgrammar.xsd
+@dirrm %%DATADIR%%
+@dirrmtry share/nls/en_US.US-ASCII
+@dirrmtry share/nls/POSIX