aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--archivers/lbrate/Makefile4
-rw-r--r--comms/zssh/Makefile2
-rw-r--r--mail/vm-pop3d/Makefile6
-rw-r--r--net/ntalk/Makefile2
4 files changed, 7 insertions, 7 deletions
diff --git a/archivers/lbrate/Makefile b/archivers/lbrate/Makefile
index ba1b359293c5..9621808a69f6 100644
--- a/archivers/lbrate/Makefile
+++ b/archivers/lbrate/Makefile
@@ -17,8 +17,8 @@ LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
MAN1= lbrate.1
post-patch:
- @${PERL} -pi -e "s,^CC,#CC,g ; s,^PREFIX,#PREFIX,g ; \
- s,%%LOCALBASE%%,${LOCALBASE},g" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e "s,^CC|^PREFIX,#,g" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e "s,%%LOCALBASE%%,${LOCALBASE},g" ${WRKSRC}/Makefile
post-install:
.if !defined(NOPORTDOCS)
diff --git a/comms/zssh/Makefile b/comms/zssh/Makefile
index 804969ed268f..01b7cfe9adb0 100644
--- a/comms/zssh/Makefile
+++ b/comms/zssh/Makefile
@@ -21,6 +21,6 @@ HAS_CONFIGURE= yes
MAN1= zssh.1 ztelnet.1
post-configure:
- @${PERL} -pi -e 's,^prefix.*,prefix = ${PREFIX},g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's,^prefix.*,prefix = ${PREFIX},g' ${WRKSRC}/Makefile
.include <bsd.port.mk>
diff --git a/mail/vm-pop3d/Makefile b/mail/vm-pop3d/Makefile
index 8c9f55e54dc2..09603f662638 100644
--- a/mail/vm-pop3d/Makefile
+++ b/mail/vm-pop3d/Makefile
@@ -36,9 +36,9 @@ pre-patch:
@${ECHO} ""
post-patch:
- @${PERL} -pi -e "s@LIBS -ldl@LIBS@" ${WRKSRC}/configure
- @${PERL} -pi -e "s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/vm-pop3d.h
- @${SED} -e "s=%%PREFIX%%=${PREFIX}=g" ${FILESDIR}/vm-pop3d.sh > ${WRKSRC}/vm-pop3d.sh.sample
+ @${REINPLACE_CMD} -e "s@LIBS -ldl@LIBS@" ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/vm-pop3d.h
+ @${SED} -e "s,%%PREFIX%%,${PREFIX},g" ${FILESDIR}/vm-pop3d.sh > ${WRKSRC}/vm-pop3d.sh.sample
post-install:
${INSTALL_MAN} ${WRKSRC}/vm-pop3d.8 ${MAN8PREFIX}/man/man8
diff --git a/net/ntalk/Makefile b/net/ntalk/Makefile
index 38be778eb434..1e23eec6f07a 100644
--- a/net/ntalk/Makefile
+++ b/net/ntalk/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= gslin@ccca.nctu.edu.tw
ALL_TARGET= ${PORTNAME}
post-patch:
- @${PERL} -pi -e "s,-lpthread,${PTHREAD_LIBS},g" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e "s,-lpthread,${PTHREAD_LIBS},g" ${WRKSRC}/Makefile
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin