aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/claws-mail/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/mail/claws-mail/Makefile b/mail/claws-mail/Makefile
index 9f183a52bda3..2617463860a2 100644
--- a/mail/claws-mail/Makefile
+++ b/mail/claws-mail/Makefile
@@ -7,6 +7,7 @@
PORTNAME= claws-mail
PORTVERSION= 2.10.0
+PORTREVISION= 1
CATEGORIES= mail news ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sylpheed-claws
@@ -63,6 +64,7 @@ OPTIONS= ALL "Enable all options." off \
LDAP "Enable LDAP support." off \
SA_PLUG "Enable SpamAssassin support." off \
SSL "Enable OpenSSL support." on \
+ STARTUP "Enable startup notification support." on \
THEMES "Install additional themes." on
.include <bsd.port.pre.mk>
@@ -166,6 +168,13 @@ CONFIGURE_ARGS+= --enable-ipv6
CONFIGURE_ARGS+= --disable-ipv6
.endif
+.if !defined(WITHOUT_STARTUP) || defined(WITH_ALL)
+LIB_DEPENDS+= startup-notification-1.0:${PORTSDIR}/x11/startup-notification
+CONFIGURE_ARGS+= --enable-startup-notification
+.else
+CONFIGURE_ARGS+= --disable-startup-notification
+.endif
+
post-extract:
.if !defined(WITHOUT_THEMES)
@${MKDIR} ${WRKSRC}/themes