aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/netbox/Makefile2
-rw-r--r--net-mgmt/netbox/distinfo6
-rw-r--r--net-mgmt/netbox/files/patch-netbox_users_views.py16
3 files changed, 20 insertions, 4 deletions
diff --git a/net-mgmt/netbox/Makefile b/net-mgmt/netbox/Makefile
index ccf44e3d6053..da62903a1768 100644
--- a/net-mgmt/netbox/Makefile
+++ b/net-mgmt/netbox/Makefile
@@ -2,7 +2,7 @@
PORTNAME= netbox
DISTVERSIONPREFIX= v
-DISTVERSION= 2.6.7
+DISTVERSION= 2.6.8
CATEGORIES= net-mgmt
MAINTAINER= kai@FreeBSD.org
diff --git a/net-mgmt/netbox/distinfo b/net-mgmt/netbox/distinfo
index 12921440019d..f53556c7552e 100644
--- a/net-mgmt/netbox/distinfo
+++ b/net-mgmt/netbox/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1572671276
-SHA256 (netbox-community-netbox-v2.6.7_GH0.tar.gz) = 530d5f49df79ca9f0deab469d9a48349a6386751895188036f99aea16639fcda
-SIZE (netbox-community-netbox-v2.6.7_GH0.tar.gz) = 2416096
+TIMESTAMP = 1575996489
+SHA256 (netbox-community-netbox-v2.6.8_GH0.tar.gz) = fb146bdb0369e59034f24b1523ec5025575b3fb9ad473896fd43fc9faffdc9b0
+SIZE (netbox-community-netbox-v2.6.8_GH0.tar.gz) = 2416523
diff --git a/net-mgmt/netbox/files/patch-netbox_users_views.py b/net-mgmt/netbox/files/patch-netbox_users_views.py
new file mode 100644
index 000000000000..77685215ebb7
--- /dev/null
+++ b/net-mgmt/netbox/files/patch-netbox_users_views.py
@@ -0,0 +1,16 @@
+Fix exception on password change page for local users
+
+Obtained from:
+https://github.com/netbox-community/netbox/commit/3b03d68ac70be1b5b9912d0a4d2a5fecd25cede4
+
+--- netbox/users/views.py.orig 2019-12-10 15:47:48 UTC
++++ netbox/users/views.py
+@@ -96,7 +96,7 @@ class ChangePasswordView(LoginRequiredMixin, View):
+
+ def get(self, request):
+ # LDAP users cannot change their password here
+- if getattr(request.user, 'ldap_username'):
++ if getattr(request.user, 'ldap_username', None):
+ messages.warning(request, "LDAP-authenticated user credentials cannot be changed within NetBox.")
+ return redirect('user:profile')
+