aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/frotz/Makefile27
-rw-r--r--games/frotz/pkg-descr5
-rw-r--r--games/frotz/pkg-plist5
3 files changed, 21 insertions, 16 deletions
diff --git a/games/frotz/Makefile b/games/frotz/Makefile
index 076f7cd90bc9..b531ba370712 100644
--- a/games/frotz/Makefile
+++ b/games/frotz/Makefile
@@ -7,26 +7,39 @@
PORTNAME= frotz
PORTVERSION= 2.43
+PORTREVISION= 1
CATEGORIES= games
-MASTER_SITES= ftp://ftp.ifarchive.org/if-archive/infocom/interpreters/frotz/ \
- http://wuarchive.wustl.edu/doc/misc/if-archive/infocom/interpreters/frotz/ \
+MASTER_SITES= SF \
http://www.ifarchive.org/if-archive/infocom/interpreters/frotz/
MAINTAINER= ports@FreeBSD.org
COMMENT= Infocom games interpreter
+LICENSE= GPLv2 # (or later)
+
MAKE_ARGS= CC="${CC}" OPTS="${CFLAGS}" PREFIX="${PREFIX}" \
- CONFIG_DIR="${PREFIX}/etc" INCL="" LIB=""
+ CONFIG_DIR="${PREFIX}/etc" SOUND_DEFS="-DOSS_SOUND" \
+ SOUND_DEV="/dev/dsp" INCL="" LIB=""
+MAKE_JOBS_SAFE= yes
MAN6= frotz.6
+PORTDOCS= BUGS HOW_TO_PLAY README
+PORTEXAMPLES= frotz.conf-big frotz.conf-small
+PLIST_FILES= bin/frotz
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/frotz ${PREFIX}/bin
- @${INSTALL_MAN} ${WRKSRC}/doc/frotz.6 ${MANPREFIX}/man/man6
+ ${INSTALL_PROGRAM} ${WRKSRC}/frotz ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/doc/frotz.6 ${MANPREFIX}/man/man6
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for file in BUGS HOW_TO_PLAY README
- @${INSTALL_MAN} ${WRKSRC}/${file} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+.for ex in ${PORTEXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${ex} ${EXAMPLESDIR}
.endfor
.endif
diff --git a/games/frotz/pkg-descr b/games/frotz/pkg-descr
index a716650c6a37..f44d30b0cdb2 100644
--- a/games/frotz/pkg-descr
+++ b/games/frotz/pkg-descr
@@ -7,7 +7,4 @@ to transfer the story files. There is an increasing number
of new games available on the Internet. Check the if-archive
at ftp.ifarchive.org.
-WWW: http://www.cs.csubak.edu/~dgriffi/proj/frotz/
-
- -Adam
- adam-ports@blacktabby.org
+WWW: http://frotz.sourceforge.net/
diff --git a/games/frotz/pkg-plist b/games/frotz/pkg-plist
deleted file mode 100644
index a629939bb830..000000000000
--- a/games/frotz/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-bin/frotz
-%%PORTDOCS%%share/doc/frotz/BUGS
-%%PORTDOCS%%share/doc/frotz/HOW_TO_PLAY
-%%PORTDOCS%%share/doc/frotz/README
-%%PORTDOCS%%@dirrm share/doc/frotz