aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--astro/merkaartor/Makefile45
-rw-r--r--editors/tea/Makefile32
-rw-r--r--editors/texmakerx/Makefile31
3 files changed, 32 insertions, 76 deletions
diff --git a/astro/merkaartor/Makefile b/astro/merkaartor/Makefile
index 21774b74e7c7..71cba5e23ec0 100644
--- a/astro/merkaartor/Makefile
+++ b/astro/merkaartor/Makefile
@@ -9,46 +9,33 @@ MASTER_SITES= http://merkaartor.be/attachments/download/301/ \
https://secure.ohos.nl/downloads/
MAINTAINER= dev2@heesakkers.info
-COMMENT= An openstreetmap mapping program
+COMMENT= Openstreetmap mapping program
LICENSE= GPLv2
-LIB_DEPENDS= gdal:${PORTSDIR}/graphics/gdal \
- proj:${PORTSDIR}/graphics/proj
+LIB_DEPENDS= libgdal.so:${PORTSDIR}/graphics/gdal \
+ libproj.so:${PORTSDIR}/graphics/proj
-NO_STAGE= yes
USE_BZIP2= yes
USE_LDCONFIG= yes
-USE_QT4= qmake_build uic_build moc_build rcc_build \
+USE_QT4= uic_build moc_build rcc_build \
gui network svg webkit xml imageformats script scripttools
-.if exists(${LOCALBASE}/bin/gnome-session)
-INSTALLS_ICONS= yes
-.endif
-
-QMAKEFLAGS= PREFIX=${PREFIX}
-
-OPTIONS_DEFINE= GEOIMAGE ZBAR DEBUG
-GEOIMAGE_DESC= Enable geotagged images (needs exiv2)
-ZBAR_DESC= Read barcodes from walking papers
+OPTIONS_DEFINE= GEOIMAGE ZBAR DEBUG NLS
OPTIONS_DEFAULT= GEOIMAGE
-.include <bsd.port.options.mk>
+GEOIMAGE_DESC= Enable geotagged images (needs exiv2)
+GEOIMAGE_QMAKE_ON= GEOIMAGE=1
+GEOIMAGE_LIB_DEPENDS= libexiv2.so:${PORTSDIR}/graphics/exiv2
-.if ${PORT_OPTIONS:MGEOIMAGE}
-QMAKEFLAGS+= GEOIMAGE=1
-LIB_DEPENDS+= exiv2:${PORTSDIR}/graphics/exiv2
-.endif
+ZBAR_DESC= Read barcodes from walking papers
+ZBAR_QMAKE_ON= ZBAR=1
+ZBAR_LIB_DEPENDS= libzbar.so:${PORTSDIR}/graphics/zbar
-.if ${PORT_OPTIONS:MZBAR}
-QMAKEFLAGS+= ZBAR=1
-LIB_DEPENDS+= zbar:${PORTSDIR}/graphics/zbar
-.endif
+DEBUG_QMAKE_OFF= NODEBUG=1 RELEASE=1
-.if empty(PORT_OPTIONS:MDEBUG)
-QMAKEFLAGS+= NODEBUG=1 RELEASE=1
-.endif
+.include <bsd.port.options.mk>
.if empty(PORT_OPTIONS:MNLS)
PLIST_SUB+= NLS="@comment "
@@ -57,11 +44,7 @@ PLIST_SUB+= NLS=""
USE_QT4+= linguist_build
pre-build:
- @cd ${WRKSRC}/translations && lrelease-qt4 ../src/src.pro
+ @cd ${WRKSRC}/translations && ${LRELEASE} ../src/src.pro
.endif
-do-configure:
- @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${QMAKE} ${QMAKEFLAGS}
-
.include <bsd.port.mk>
diff --git a/editors/tea/Makefile b/editors/tea/Makefile
index 31b54d02f635..bed5727a968d 100644
--- a/editors/tea/Makefile
+++ b/editors/tea/Makefile
@@ -16,8 +16,9 @@ OPTIONS_RADIO= SPELL
OPTIONS_RADIO_SPELL= ASPELL HUNSPELL
OPTIONS_DEFAULT= ASPELL
+USES= qmake
USE_BZIP2= yes
-USE_QT4= gui moc_build qmake_build rcc_build
+USE_QT4= gui moc_build rcc_build
PLIST_FILES= bin/tea share/pixmaps/tea_icon_v2.png
PORTDOCS= *
@@ -25,21 +26,13 @@ PORTDOCS= *
DESKTOP_ENTRIES="TEA" "" "${PREFIX}/share/pixmaps/tea_icon_v2.png" \
"${PORTNAME}" "" ""
-.include <bsd.port.options.mk>
+ASPELL_LIB_DEPENDS= libaspell.so:${PORTSDIR}/textproc/aspell
+ASPELL_QMAKE_ON= USE_ASPELL=true
+ASPELL_QMAKE_OFF= USE_ASPELL=false
-.if ${PORT_OPTIONS:MASPELL}
-LIB_DEPENDS+= libaspell.so:${PORTSDIR}/textproc/aspell
-QMAKEFLAGS+= USE_ASPELL=true
-.else
-QMAKEFLAGS+= USE_ASPELL=false
-.endif
-
-.if ${PORT_OPTIONS:MHUNSPELL}
-LIB_DEPENDS+= libhunspell-1.3.so:${PORTSDIR}/textproc/hunspell
-QMAKEFLAGS+= USE_HUNSPELL=true
-.else
-QMAKEFLAGS+= USE_HUNSPELL=false
-.endif
+HUNSPELL_LIB_DEPENDS= libhunspell-1.3.so:${PORTSDIR}/textproc/hunspell
+HUNSPELL_QMAKE_ON= USE_HUNSPELL=true
+HUNSPELL_QMAKE_OFF= USE_HUNSPELL=false
post-patch:
@${REINPLACE_CMD} -e \
@@ -47,14 +40,9 @@ post-patch:
@${REINPLACE_CMD} -e \
's|/usr/include|${LOCALBASE}/include|' ${WRKSRC}/src.pro
-do-configure:
- @cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} ${QMAKEFLAGS}
-
do-install:
- (cd ${WRKSRC}/bin \
- && ${INSTALL_PROGRAM} tea ${STAGEDIR}${PREFIX}/bin)
- (cd ${WRKSRC}/icons \
- && ${INSTALL_DATA} tea_icon_v2.png ${STAGEDIR}${PREFIX}/share/pixmaps)
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/tea ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/icons/tea_icon_v2.png ${STAGEDIR}${PREFIX}/share/pixmaps
(cd ${WRKSRC}/manuals \
&& ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
diff --git a/editors/texmakerx/Makefile b/editors/texmakerx/Makefile
index 329f5823bd7d..1d9413a2b0a6 100644
--- a/editors/texmakerx/Makefile
+++ b/editors/texmakerx/Makefile
@@ -9,37 +9,26 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/TexMakerX%20${PORTVERSION}
DISTNAME= ${PORTNAME}-${PORTVERSION:S:.0::}
MAINTAINER= lx@FreeBSD.org
-COMMENT= A LaTeX IDE derived from Texmaker
+COMMENT= LaTeX IDE derived from Texmaker
-LIB_DEPENDS= poppler:${PORTSDIR}/graphics/poppler \
- poppler-qt4:${PORTSDIR}/graphics/poppler-qt4
-RUN_DEPENDS= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme
+LIB_DEPENDS= libpoppler.so:${PORTSDIR}/graphics/poppler \
+ libpoppler-qt4.so:${PORTSDIR}/graphics/poppler-qt4
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}
-USE_GHOSTSCRIPT=yes
-USE_QT4= gui network xml moc_build qmake_build rcc_build \
+USES= dos2unix qmake
+USE_GHOSTSCRIPT_RUN= yes
+USE_QT4= gui network xml moc_build rcc_build \
uic_build qtestlib script
USE_TEX= latex dvipsk
-USE_DOS2UNIX= yes
-HAS_CONFIGURE= yes
INSTALLS_ICONS= yes
MAKE_JOBS_UNSAFE= yes
OPTIONS_DEFINE= XDVI GV
GV_DESC= View ps files with gv
+GV_RUN_DEPENDS= xdvi:${PORTSDIR}/print/xdvik
XDVI_DESC= View dvi files with xdvi
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MXDVI}
-RUN_DEPENDS+= xdvi:${PORTSDIR}/print/xdvik
-.endif
-
-.if ${PORT_OPTIONS:MGV}
-RUN_DEPENDS+= gv:${PORTSDIR}/print/gv
-.endif
+XDVI_RUN_DEPENDS= gv:${PORTSDIR}/print/gv
post-patch:
@${REINPLACE_CMD} -e 's,^\(utilities.path =\).*,\1 ${DATADIR},' \
@@ -47,8 +36,4 @@ post-patch:
-e 's,/usr/lib,${LOCALBASE}/lib,g' \
${WRKSRC}/${PORTNAME}.pro
-do-configure:
- @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${QMAKE} PREFIX=${PREFIX} ${PORTNAME}.pro
-
.include <bsd.port.mk>