aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/mdb/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/devel/mdb/Makefile b/devel/mdb/Makefile
index 1e5968658d48..bc73a80b5fa2 100644
--- a/devel/mdb/Makefile
+++ b/devel/mdb/Makefile
@@ -9,7 +9,7 @@ COMMENT= Solaris Modular Debugger
LICENSE= CDDL
-USES= uidfix
+USES= compiler uidfix
USE_GITHUB= yes
GH_ACCOUNT= bsdjhb
@@ -31,6 +31,15 @@ CFLAGS+= -DMDB_PREFIX=\\\"${PREFIX}\\\" -g
IGNORE= requires full source tree with CDDL sources
.endif
+.if ${OSVERSION} < 1300015 && ${COMPILER_TYPE} == "clang" && \
+ ${COMPILER_VERSION} >= 80
+# clang 8 cannot compile due to enum redefinitions in kernel.h
+BUILD_DEPENDS+= ${LOCALBASE}/bin/clang70:devel/llvm70
+CPP= ${LOCALBASE}/bin/clang-cpp70
+CC= ${LOCALBASE}/bin/clang70
+CXX= ${LOCALBASE}/bin/clang++70
+.endif
+
pre-install:
${MKDIR} ${STAGEDIR}${PREFIX}/lib/mdb/kvm/${MACHINE_ARCH}