aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/cfengine2/Makefile37
-rw-r--r--sysutils/cfengine2/distinfo2
-rw-r--r--sysutils/cfengine2/files/patch-ab11
-rw-r--r--sysutils/cfengine2/files/patch-ac28
-rw-r--r--sysutils/cfengine2/files/patch-ad37
-rw-r--r--sysutils/cfengine2/files/patch-ae15
-rw-r--r--sysutils/cfengine2/files/patch-af13
-rw-r--r--sysutils/cfengine2/files/patch-ag13
-rw-r--r--sysutils/cfengine2/files/patch-configure55
-rw-r--r--sysutils/cfengine2/files/patch-contrib::Makefile.in11
-rw-r--r--sysutils/cfengine2/files/patch-doc::Makefile.in24
-rw-r--r--sysutils/cfengine2/files/patch-doc::cfengine-Anomalies.info11
-rw-r--r--sysutils/cfengine2/pkg-plist36
13 files changed, 132 insertions, 161 deletions
diff --git a/sysutils/cfengine2/Makefile b/sysutils/cfengine2/Makefile
index b873c37ec393..a18fa0ea6763 100644
--- a/sysutils/cfengine2/Makefile
+++ b/sysutils/cfengine2/Makefile
@@ -1,41 +1,28 @@
-# New ports collection makefile for: cfengine
-# Date created: March 16, 1998
-# Whom: jseger@FreeBSD.org
+# New ports collection makefile for: cfengine2
+# Date created: 2002-07-29
+# Whom: fanf@FreeBSD.org
#
# $FreeBSD$
#
-PORTNAME= cfengine
-PORTVERSION= 1.6.3
-PORTREVISION= 3
+PORTNAME= cfengine2
+PORTVERSION= 2.0.3
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.iu.hio.no/pub/cfengine/ \
- ftp://ftp.sunsite.utk.edu/pub/cfengine/cfengine-ftp/ \
${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= cfengine-${PORTVERSION}
-MAINTAINER= gordon@FreeBSD.org
+MAINTAINER= fanf@FreeBSD.org
-.if defined(PACKAGE_BUILDING)
-BUILD_DEPENDS= latex:${PORTSDIR}/print/teTeX
-.endif
+LIB_DEPENDS= db4:${PORTSDIR}/databases/db4
-LIB_DEPENDS= db3:${PORTSDIR}/databases/db3
-.if defined(PACKAGE_BUILDING) && !exists(/usr/include/tcpd.h)
-LIB_DEPENDS+= wrap.7:${PORTSDIR}/security/tcp_wrapper
-.endif
+USE_OPENSSL= yes
-USE_GMAKE= yes
-USE_AUTOMAKE_VER=14
+# if we use GNU_CONFIGURE=yes then the binaries get installed with weird names
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX}
MAN8= cfengine.8
-pre-configure:
- @cd ${WRKSRC} && ${ACLOCAL} && ${AUTOHEADER}
-
-post-install:
-.if defined(NOPORTDOCS)
- @${RM} -rf ${PREFIX}/share/doc/${PORTNAME}
-.endif
-
.include <bsd.port.mk>
diff --git a/sysutils/cfengine2/distinfo b/sysutils/cfengine2/distinfo
index 78eea57961bf..2712f823bb2f 100644
--- a/sysutils/cfengine2/distinfo
+++ b/sysutils/cfengine2/distinfo
@@ -1 +1 @@
-MD5 (cfengine-1.6.3.tar.gz) = 5076ff2292a2a00acafc9849175384e3
+MD5 (cfengine-2.0.3.tar.gz) = 55df32a5856e5d267f895ec1dc6b2511
diff --git a/sysutils/cfengine2/files/patch-ab b/sysutils/cfengine2/files/patch-ab
deleted file mode 100644
index 61a20728638a..000000000000
--- a/sysutils/cfengine2/files/patch-ab
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/classes.c.orig Wed Oct 20 03:41:30 1999
-+++ src/classes.c Tue Apr 25 16:37:00 2000
-@@ -97,7 +97,7 @@
- "irix4","ip*","4*", /* irix4 */
- "irix", "ip*","*", /* irix */
- "irix64","ip*","*", /* irix64 */
-- "freebsd","i?86","*", /* freebsd */
-+ "freebsd","*","*", /* freebsd */
- "sunos","i86pc","5*", /* solarisx86 */
- "bsd","*","*", /* bsd 4.3 */
- "newsos","*","*", /* newsos4 */
diff --git a/sysutils/cfengine2/files/patch-ac b/sysutils/cfengine2/files/patch-ac
deleted file mode 100644
index 673d7d0c722d..000000000000
--- a/sysutils/cfengine2/files/patch-ac
+++ /dev/null
@@ -1,28 +0,0 @@
---- configure.in.orig Mon Jan 15 03:51:48 2001
-+++ configure.in Tue Jan 23 01:13:32 2001
-@@ -60,13 +60,13 @@
- AC_PROG_RANLIB
- AC_PROG_INSTALL
-
--AC_PATH_PROG(LATEX, latex, false, \
-+AC_PATH_PROG(LATEX, latex, true, \
- $PATH:$prefix/bin:/usr/bin:/usr/local/bin)
--AC_PATH_PROG(TEXI2DVI, texi2dvi, false, \
-+AC_PATH_PROG(TEXI2DVI, texi2dvi, true, \
- $PATH:$prefix/bin:/usr/bin:/usr/local/bin)
--AC_PATH_PROG(DVIPS, dvips, false, \
-+AC_PATH_PROG(DVIPS, dvips, true, \
- $PATH:$prefix/bin:/usr/bin:/usr/local/bin)
--AC_PATH_PROG(MAKEINFO, makeinfo, false, \
-+AC_PATH_PROG(MAKEINFO, makeinfo, true, \
- $PATH:$prefix/bin:/usr/bin:/usr/local/bin)
-
-
-@@ -262,7 +262,7 @@
- freebsd*)
- AC_DEFINE(FREEBSD)
-- CFLAGS="$CFLAGS -pthread"
-+ LIBS="$LIBS -ldes"
- AC_CHECK_HEADERS(pthread.h)
- ;;
- netbsd*)
diff --git a/sysutils/cfengine2/files/patch-ad b/sysutils/cfengine2/files/patch-ad
deleted file mode 100644
index f8a19a8ba386..000000000000
--- a/sysutils/cfengine2/files/patch-ad
+++ /dev/null
@@ -1,37 +0,0 @@
-This moves the documentation out of /usr/local/share/cfengine/{doc,html} into
-/usr/local/shared/doc/cfengine to keep it inline with the rest of the ports.
-
---- doc/Makefile.am.orig Fri Dec 1 19:24:39 2000
-+++ doc/Makefile.am Tue Jan 23 02:07:04 2001
-@@ -2,7 +2,7 @@
- info_TEXINFOS = cfengine-Reference.texinfo cfengine-Tutorial.texinfo
-
- # Info used in building and installing HTML files
--htmldir = $(pkgdatadir)/html
-+htmldir = $(datadir)/doc/cfengine
- htmlfiles = cfengine-Reference.html cfengine-Tutorial.html
- html_DATA = $(htmlfiles) cf-security.html
-
-@@ -14,18 +14,19 @@
- # then uncomment the reference to ps2
- psfiles = $(ps1) # $(ps2)
-
--psdir = $(pkgdatadir)/doc
-+psdir = $(datadir)/doc/cfengine
- ps_DATA = $(psfiles)
-
- # Make sure these get distributed with everything else.
- EXTRA_DIST = \
- texinfo.tex \
-- cf-security.html \
-+ $(html_DATA) \
-+ $(ps_DATA) \
- locks.latex \
- paper1.latex \
- paper2.latex
-
--SUFFIXES = html latex
-+SUFFIXES = .html .latex
-
- %.html : %.texinfo
- ${MAKEINFO} --html $<
diff --git a/sysutils/cfengine2/files/patch-ae b/sysutils/cfengine2/files/patch-ae
deleted file mode 100644
index 364e79ebecbb..000000000000
--- a/sysutils/cfengine2/files/patch-ae
+++ /dev/null
@@ -1,15 +0,0 @@
-This patch only makes sense if you subscribe to the FreeBSD port model.
-Basically this only works if you have installed BerkleyDB from the ports
-collection.
-
---- src/misc.c.orig Wed Jan 24 07:28:01 2001
-+++ src/misc.c Wed Mar 28 12:41:06 2001
-@@ -39,7 +39,7 @@
-
-
- #ifdef HAVE_DB_H
--# include <db.h>
-+#include <db3/db.h>
- #endif
-
- /*******************************************************************/
diff --git a/sysutils/cfengine2/files/patch-af b/sysutils/cfengine2/files/patch-af
deleted file mode 100644
index c7a33e7b209e..000000000000
--- a/sysutils/cfengine2/files/patch-af
+++ /dev/null
@@ -1,13 +0,0 @@
-Fix the linking so only cfd is linked with pthreads. This keeps cfengine
-from trying to use thread-unsafe resolver functions.
-
---- src/Makefile.am.orig Fri Aug 10 23:58:47 2001
-+++ src/Makefile.am Fri Aug 10 23:59:07 2001
-@@ -95,6 +95,7 @@
- patches.c
-
- cfd_LDADD = -L../pub -lpub $(LEXLIB)
-+cfd_LDFLAGS = -pthread $(LDFLAGS)
-
- cfrun_SOURCES = \
- cfrun.c \
diff --git a/sysutils/cfengine2/files/patch-ag b/sysutils/cfengine2/files/patch-ag
deleted file mode 100644
index 1a8101cb3542..000000000000
--- a/sysutils/cfengine2/files/patch-ag
+++ /dev/null
@@ -1,13 +0,0 @@
-This fixes the problem with cfd not finding the correct interfaces.
-
---- src/misc.c.orig Wed Jan 24 07:28:01 2001
-+++ src/misc.c Fri Aug 10 23:34:45 2001
-@@ -284,7 +284,7 @@
- list.ifc_len = sizeof(ifbuf);
- list.ifc_req = ifbuf;
-
--if (ioctl(fd, SIOCGIFCONF, &list) == -1 || (list.ifc_len < (sizeof(struct ifreq))))
-+if (ioctl(fd, OSIOCGIFCONF, &list) == -1 || (list.ifc_len < (sizeof(struct ifreq))))
- {
- CfLog(cferror,"Couldn't get interfaces","ioctl");
- exit(1);
diff --git a/sysutils/cfengine2/files/patch-configure b/sysutils/cfengine2/files/patch-configure
new file mode 100644
index 000000000000..9f5590039838
--- /dev/null
+++ b/sysutils/cfengine2/files/patch-configure
@@ -0,0 +1,55 @@
+Accept the -STABLE version of OpenSSL
+Use the correct #includes for sys/mount.h
+
+--- configure.orig Mon Jul 29 15:32:39 2002
++++ configure Mon Jul 29 15:35:41 2002
+@@ -3637,8 +3637,8 @@
+ if test x"$OPENSSL_LIB_DIR" = xno ; then
+ echo "$as_me:3638: result: no" >&5
+ echo "${ECHO_T}no" >&6
+- { { echo "$as_me:3640: error: This release of cfengine requires OpenSSL 0.9.6b or later" >&5
+-echo "$as_me: error: This release of cfengine requires OpenSSL 0.9.6b or later" >&2;}
++ { { echo "$as_me:3640: error: This release of cfengine requires OpenSSL 0.9.6a or later" >&5
++echo "$as_me: error: This release of cfengine requires OpenSSL 0.9.6a or later" >&2;}
+ { (exit 1); exit 1; }; }
+ else
+ if test x"$OPENSSL_LIB_DIR" = xyes ; then
+@@ -3700,7 +3700,7 @@
+ #include <openssl/opensslv.h>
+ int main(void)
+ {
+- if (OPENSSL_VERSION_NUMBER < 0x0090602fL)
++ if (OPENSSL_VERSION_NUMBER < 0x0090601fL)
+ exit(1);
+ exit(0);
+ }
+@@ -3723,8 +3723,8 @@
+ echo "$as_me: program exited with status $ac_status" >&5
+ echo "$as_me: failed program was:" >&5
+ cat conftest.$ac_ext >&5
+-{ { echo "$as_me:3726: error: This release of cfengine requires openssl 0.9.6b or later" >&5
+-echo "$as_me: error: This release of cfengine requires openssl 0.9.6b or later" >&2;}
++{ { echo "$as_me:3726: error: This release of cfengine requires openssl 0.9.6a or later" >&5
++echo "$as_me: error: This release of cfengine requires openssl 0.9.6a or later" >&2;}
+ { (exit 1); exit 1; }; }
+
+ fi
+@@ -4098,6 +4098,7 @@
+ cat >conftest.$ac_ext <<_ACEOF
+ #line 4099 "configure"
+ #include "confdefs.h"
++#include <sys/param.h>
+ #include <$ac_header>
+ _ACEOF
+ if { (eval echo "$as_me:4103: \"$ac_cpp conftest.$ac_ext\"") >&5
+@@ -8485,8 +8486,8 @@
+ echo "$as_me: WARNING: This version requires Berkeley db version 3.2 or" >&2;}
+ { echo "$as_me:8486: WARNING: later from www.sleepycat.com" >&5
+ echo "$as_me: WARNING: later from www.sleepycat.com" >&2;}
+-{ echo "$as_me:8488: WARNING: This version requires OpenSSL 0.9.6b or later" >&5
+-echo "$as_me: WARNING: This version requires OpenSSL 0.9.6b or later" >&2;}
++{ echo "$as_me:8488: WARNING: This version requires OpenSSL 0.9.6a or later" >&5
++echo "$as_me: WARNING: This version requires OpenSSL 0.9.6a or later" >&2;}
+ { echo "$as_me:8490: WARNING: from www.openssl.org" >&5
+ echo "$as_me: WARNING: from www.openssl.org" >&2;}
+ { echo "$as_me:8492: WARNING: " >&5
diff --git a/sysutils/cfengine2/files/patch-contrib::Makefile.in b/sysutils/cfengine2/files/patch-contrib::Makefile.in
new file mode 100644
index 000000000000..e512b51ae22f
--- /dev/null
+++ b/sysutils/cfengine2/files/patch-contrib::Makefile.in
@@ -0,0 +1,11 @@
+--- contrib/Makefile.in.orig Mon Jul 29 17:24:20 2002
++++ contrib/Makefile.in Mon Jul 29 17:26:30 2002
+@@ -33,7 +33,7 @@
+ mandir = @mandir@
+ includedir = @includedir@
+ oldincludedir = /usr/include
+-pkgdatadir = $(datadir)/@PACKAGE@
++pkgdatadir = $(datadir)/emacs/site-lisp
+ pkglibdir = $(libdir)/@PACKAGE@
+ pkgincludedir = $(includedir)/@PACKAGE@
+ top_builddir = ..
diff --git a/sysutils/cfengine2/files/patch-doc::Makefile.in b/sysutils/cfengine2/files/patch-doc::Makefile.in
new file mode 100644
index 000000000000..b4aed68cfe50
--- /dev/null
+++ b/sysutils/cfengine2/files/patch-doc::Makefile.in
@@ -0,0 +1,24 @@
+--- doc/Makefile.in.orig Sat Jun 22 08:36:43 2002
++++ doc/Makefile.in Mon Jul 29 17:19:22 2002
+@@ -88,10 +88,10 @@
+ man_MANS = cfengine.8
+ info_TEXINFOS = cfengine-Reference.texinfo cfengine-Tutorial.texinfo cfengine-Anomalies.texinfo
+
+-docdir = $(prefix)/doc/$(PACKAGE)-$(VERSION)
++#docdir = $(prefix)/doc/$(PACKAGE)-$(VERSION)
+ doc_DATA =
+ # Info used in building and installing HTML files
+-htmldir = $(pkgdatadir)/html
++htmldir = $(datadir)/doc/@PACKAGE@
+ htmlfiles = cfengine-Reference.html cfengine-Tutorial.html
+ html_DATA = $(htmlfiles)
+
+@@ -103,7 +103,7 @@
+ # then uncomment the reference to ps2
+ psfiles = $(ps1) # $(ps2)
+
+-psdir = $(pkgdatadir)/doc
++#psdir = $(pkgdatadir)/doc
+ ps_DATA = $(psfiles)
+
+ # Make sure these get distributed with everything else.
diff --git a/sysutils/cfengine2/files/patch-doc::cfengine-Anomalies.info b/sysutils/cfengine2/files/patch-doc::cfengine-Anomalies.info
new file mode 100644
index 000000000000..1c6e5cd9ccd8
--- /dev/null
+++ b/sysutils/cfengine2/files/patch-doc::cfengine-Anomalies.info
@@ -0,0 +1,11 @@
+--- doc/cfengine-Anomalies.info.orig Mon Jul 29 18:15:38 2002
++++ doc/cfengine-Anomalies.info Mon Jul 29 18:16:20 2002
+@@ -3,7 +3,7 @@
+
+ INFO-DIR-SECTION System Utilities
+ START-INFO-DIR-ENTRY
+-* cfengine Tutorial: (cfengine-Tutorial.info).
++* cfengine Anomalies: (cfengine-Anomalies.info).
+ Cfengine is a language based tool specifically
+ designed for configuring and maintaining BSD
+ and System-5-like operating systems attached
diff --git a/sysutils/cfengine2/pkg-plist b/sysutils/cfengine2/pkg-plist
index 50e59a2aba1f..5ecae01ae4eb 100644
--- a/sysutils/cfengine2/pkg-plist
+++ b/sysutils/cfengine2/pkg-plist
@@ -1,5 +1,7 @@
+@unexec install-info --delete %D/info/cfengine-Anomalies.info %D/info/dir
@unexec install-info --delete %D/info/cfengine-Reference.info %D/info/dir
@unexec install-info --delete %D/info/cfengine-Tutorial.info %D/info/dir
+info/cfengine-Anomalies.info
info/cfengine-Reference.info
info/cfengine-Reference.info-1
info/cfengine-Reference.info-2
@@ -8,24 +10,27 @@ info/cfengine-Reference.info-4
info/cfengine-Reference.info-5
info/cfengine-Reference.info-6
info/cfengine-Reference.info-7
+info/cfengine-Reference.info-8
info/cfengine-Tutorial.info
info/cfengine-Tutorial.info-1
info/cfengine-Tutorial.info-2
info/cfengine-Tutorial.info-3
info/cfengine-Tutorial.info-4
info/cfengine-Tutorial.info-5
+info/cfengine-Tutorial.info-6
+@exec install-info %D/info/cfengine-Anomalies.info %D/info/dir
@exec install-info %D/info/cfengine-Reference.info %D/info/dir
@exec install-info %D/info/cfengine-Tutorial.info %D/info/dir
-sbin/cfcron
-sbin/cfd
+sbin/cfagent
sbin/cfdoc
-sbin/cfengine
+sbin/cfenvd
+sbin/cfenvgraph
+sbin/cfexecd
sbin/cfkey
-sbin/cfmail
-sbin/cfmailfilter
sbin/cfrun
-sbin/cfwrap
+sbin/cfservd
sbin/vicf
+share/emacs/site-lisp/cfengine.el
share/cfengine/cf.chflags.example
share/cfengine/cf.freebsd.example
share/cfengine/cf.ftp.example
@@ -39,18 +44,13 @@ share/cfengine/cf.site.example
share/cfengine/cf.solaris.example
share/cfengine/cf.sun4.example
share/cfengine/cf.users.example
-share/cfengine/cfd.conf.example
-share/cfengine/cfdaily
-share/cfengine/cfengine.conf.example
-share/cfengine/cfengine.el
+share/cfengine/cfagent.conf-advanced.example
+share/cfengine/cfagent.conf.example
share/cfengine/cfrc.example
share/cfengine/cfrun.hosts.example
-share/cfengine/start-cfd
+share/cfengine/cfservd.conf.example
+share/cfengine/update.conf.example
+share/doc/cfengine/cfengine-Reference.html
+share/doc/cfengine/cfengine-Tutorial.html
@dirrm share/cfengine
-%%PORTDOCS%%share/doc/cfengine/cf-security.html
-%%PORTDOCS%%share/doc/cfengine/cfengine-Reference.html
-%%PORTDOCS%%share/doc/cfengine/cfengine-Tutorial.html
-%%PORTDOCS%%share/doc/cfengine/locks.ps
-%%PORTDOCS%%share/doc/cfengine/paper1.ps
-%%PORTDOCS%%share/doc/cfengine/paper2.ps
-%%PORTDOCS%%@dirrm share/doc/cfengine
+@dirrm share/doc/cfengine