aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/mod_security/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/www/mod_security/Makefile b/www/mod_security/Makefile
index a6d6bcd671d4..f5f4fffe098e 100644
--- a/www/mod_security/Makefile
+++ b/www/mod_security/Makefile
@@ -88,6 +88,8 @@ CONFIGURE_ARGS+= --without-curl
REINPLACE_ARGS= -i ""
AP_EXTRAS+= -DWITH_LIBXML2
+CONFIGURE_ARGS+= --with-apxs=${APXS} --with-pcre=${LOCALBASE}
+
post-patch:
@${REINPLACE_CMD} -e '\
s|SecRuleEngine On|SecRuleEngine DetectionOnly|; \
@@ -98,6 +100,7 @@ post-patch:
.if defined(WITH_LUA)
${REINPLACE_CMD} -e 's|%%LUA_VER%%|${LUA_VER}|' ${WRKSRC}/configure
.endif
+ ${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' ${WRKSRC}/configure
post-build:
.if defined(WITH_MLOGC)