aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--irc/hexchat/Makefile60
-rw-r--r--irc/hexchat/distinfo6
-rw-r--r--irc/hexchat/files/patch-meson.build44
-rw-r--r--irc/hexchat/files/patch-meson__options.txt11
-rw-r--r--irc/hexchat/files/patch-plugins_fishlim_meson.build8
-rw-r--r--irc/hexchat/files/patch-src__common__server.c6
-rw-r--r--irc/hexchat/files/patch-src__common__ssl.c38
-rw-r--r--irc/hexchat/pkg-descr2
-rw-r--r--irc/hexchat/pkg-plist111
9 files changed, 151 insertions, 135 deletions
diff --git a/irc/hexchat/Makefile b/irc/hexchat/Makefile
index 87da7f362c31..e2e68b5a3128 100644
--- a/irc/hexchat/Makefile
+++ b/irc/hexchat/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= hexchat
-PORTVERSION= 2.12.4
+PORTVERSION= 2.14.1
DISTVERSIONPREFIX= v
CATEGORIES= irc gnome ipv6
@@ -12,25 +12,22 @@ COMMENT= IRC chat program with GTK and Text Frontend
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= devel/autoconf-archive>0:devel/autoconf-archive
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:misc/iso-codes
LIB_DEPENDS= libproxy.so:net/libproxy \
libfontconfig.so:x11-fonts/fontconfig \
libdbus-1.so:devel/dbus \
libfreetype.so:print/freetype2
+RUN_DEPENDS= ${LOCALBASE}/share/xml/iso-codes/iso_639.xml:misc/iso-codes
-USES= autoreconf gmake desktop-file-utils libtool pkgconfig ssl
+USES= meson ninja desktop-file-utils libtool pkgconfig ssl shebangfix \
+ gettext-tools
USE_GNOME= cairo gtk20 intltool libxml2
USE_XORG= x11
USE_GITHUB= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-openssl --enable-gtkfe --disable-sysinfo \
- --with-pkgconfigdir=${LOCALBASE}/libdata/pkgconfig \
- LUA=lua-${LUA_VER}
+MESON_ARGS= -Dwith-ssl=true -Dwith-gtk=true -Dwith-sysinfo=false
INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
-MAKE_ARGS= OBJC="${CC}"
-
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib -lX11
@@ -38,8 +35,8 @@ SUB_FILES= pkg-message
PORTDOCS= *
-OPTIONS_DEFINE= CA_BUNDLE CANBERRA DBUS DOCS FISHLIM LUA NLS NOTIFY \
- PERL PYTHON SOCKS TEXTFE
+OPTIONS_DEFINE= CA_BUNDLE CANBERRA DBUS DOCS FISHLIM LUA NOTIFY \
+ PERL PYTHON TEXTFE
OPTIONS_DEFAULT= CA_BUNDLE CANBERRA DBUS NOTIFY PERL PYTHON
@@ -49,38 +46,31 @@ CA_BUNDLE_DESC= Include CA bundle for SSL verification
CANBERRA_DESC= Audio support via Libcanberra
FISHLIM_DESC= FiSHLiM plugin
TEXTFE_DESC= Text frontend
-SOCKS_DESC= SOCKS proxy support, FORBIDDEN in FreeBSD 10+
CA_BUNDLE_RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
+CA_BUNDLE_VARS= CA_BUNDLE="${LOCALBASE}/share/certs/ca-root-nss.crt"
+CA_BUNDLE_VARS_OFF= CA_BUNDLE=NULL
CANBERRA_LIB_DEPENDS= libcanberra.so:audio/libcanberra
-CANBERRA_CONFIGURE_ENABLE=libcanberra
+CANBERRA_MESON_TRUE= with-libcanberra
DBUS_LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib
-DBUS_CONFIGURE_ENABLE= dbus
+DBUS_MESON_TRUE= with-dbus
DBUS_USE= GNOME=gconf2
-FISHLIM_CONFIGURE_ENABLE=fishlim
-LUA_CONFIGURE_ENABLE= lua
+FISHLIM_MESON_TRUE= with-fishlim
+LUA_MESON_ON= -Dwith-lua=lua-${LUA_VER}
+LUA_MESON_OFF= -Dwith-lua=false
LUA_USES= lua
LUA_USE= GCC=any
-NLS_CONFIGURE_ENABLE= nls
-NLS_USES= gettext
-NLS_USES_OFF= gettext-tools # doesn't build otherwise
-NOTIFY_RUN_DEPENDS= notify-send:devel/libnotify
-NOTIFY_CONFIGURE_ENABLE=libnotify
-PERL_CONFIGURE_ENABLE= perl
+NOTIFY_LIB_DEPENDS= libnotify.so:devel/libnotify
+NOTIFY_MESON_TRUE= with-libnotify
+PERL_MESON_TRUE= with-perl
PERL_USES= perl5
-PYTHON_CONFIGURE_ENABLE=python
-PYTHON_USES= python
-SOCKS_LIB_DEPENDS= libsocks.so:net/dante
-SOCKS_CONFIGURE_ENABLE= socks
-TEXTFE_CONFIGURE_ENABLE=textfe
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MCA_BUNDLE}
-CA_BUNDLE= "${LOCALBASE}/share/certs/ca-root-nss.crt"
-.else
-CA_BUNDLE= NULL
-.endif
+PYTHON_MESON_ON= -Dwith-python=python-${PYTHON_VER}
+PYTHON_MESON_OFF= -Dwith-python=false
+PYTHON_USES= python:3.4+ shebangfix
+PYTHON_VARS= SHEBANG_FILES=meson_post_install.py
+PYTHON_VARS+= SHEBANG_FILES=plugins/perl/generate_header.py
+PYTHON_VARS+= SHEBANG_FILES=src/common/make-te.py
+TEXTFE_MESON_TRUE= with-text
post-patch:
@${REINPLACE_CMD} -e 's|%%CA_BUNDLE%%|${CA_BUNDLE}|' \
diff --git a/irc/hexchat/distinfo b/irc/hexchat/distinfo
index 601a571c14e4..ced655b22c21 100644
--- a/irc/hexchat/distinfo
+++ b/irc/hexchat/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1496752085
-SHA256 (hexchat-hexchat-v2.12.4_GH0.tar.gz) = eb9ebe45b1c9e39543517b48d63caa2f2736e82a8dbbd1da96132070752f8084
-SIZE (hexchat-hexchat-v2.12.4_GH0.tar.gz) = 2780008
+TIMESTAMP = 1521168316
+SHA256 (hexchat-hexchat-v2.14.1_GH0.tar.gz) = fcf96f54720f5284b8ac52964e7a5e406893069fc332535afa724f7d7d6a6a81
+SIZE (hexchat-hexchat-v2.14.1_GH0.tar.gz) = 2748286
diff --git a/irc/hexchat/files/patch-meson.build b/irc/hexchat/files/patch-meson.build
new file mode 100644
index 000000000000..b6535cd3b8d4
--- /dev/null
+++ b/irc/hexchat/files/patch-meson.build
@@ -0,0 +1,44 @@
+--- meson.build.orig 2018-03-14 02:26:31 UTC
++++ meson.build
+@@ -16,11 +16,21 @@ cc = meson.get_compiler('c')
+ libgio_dep = dependency('gio-2.0', version: '>= 2.34.0')
+ libgmodule_dep = dependency('gmodule-2.0')
+ global_deps = []
++libssl_dep_found = false
+ if cc.get_id() == 'msvc'
+ libssl_dep = cc.find_library('libeay32')
+ else
+ libssl_dep = dependency('openssl', version: '>= 0.9.8',
+- required: get_option('with-ssl'))
++ required: false)
++ if not libssl_dep.found()
++ libssl_dep = [
++ cc.find_library('ssl', required: get_option('with-ssl')),
++ cc.find_library('crypto', required: get_option('with-ssl'))
++ ]
++ libssl_dep_found = libssl_dep[0].found()
++ else
++ libssl_dep_found = libssl_dep.found()
++ endif
+ endif
+
+ config_h = configuration_data()
+@@ -49,7 +59,7 @@ config_h.set('GLIB_VERSION_MIN_REQUIRED'
+ config_h.set('HAVE_MEMRCHR', cc.has_function('memrchr'))
+ config_h.set('HAVE_STRINGS_H', cc.has_header('strings.h'))
+
+-if libssl_dep.found()
++if libssl_dep_found
+ config_h.set('HAVE_X509_GET_SIGNATURE_NID',
+ cc.has_function('X509_get_signature_nid', dependencies: libssl_dep)
+ )
+@@ -131,9 +141,6 @@ global_ldflags = []
+ test_ldflags = [
+ '-Wl,-z,relro',
+ '-Wl,-z,now',
+- # mingw
+- '-Wl,--dynamicbase',
+- '-Wl,--nxcompat',
+ ]
+ foreach ldflag : test_ldflags
+ if cc.has_argument(ldflag) and cc.links('int main (void) { return 0; }', args: ldflag)
diff --git a/irc/hexchat/files/patch-meson__options.txt b/irc/hexchat/files/patch-meson__options.txt
new file mode 100644
index 000000000000..149484c439ff
--- /dev/null
+++ b/irc/hexchat/files/patch-meson__options.txt
@@ -0,0 +1,11 @@
+--- meson_options.txt.orig 2018-03-14 02:26:31 UTC
++++ meson_options.txt
+@@ -39,7 +39,7 @@ option('with-exec', type: 'boolean',
+ option('with-fishlim', type: 'boolean',
+ description: 'Fish encryption plugin, requires openssl'
+ )
+-option('with-lua', type: 'string', value: 'luajit',
++option('with-lua', type: 'string',
+ description: 'Lua scripting plugin, value is pkg-config name to use or "false"'
+ )
+ option('with-perl', type: 'boolean',
diff --git a/irc/hexchat/files/patch-plugins_fishlim_meson.build b/irc/hexchat/files/patch-plugins_fishlim_meson.build
new file mode 100644
index 000000000000..057065674c23
--- /dev/null
+++ b/irc/hexchat/files/patch-plugins_fishlim_meson.build
@@ -0,0 +1,8 @@
+--- plugins/fishlim/meson.build.orig 2018-03-14 02:26:31 UTC
++++ plugins/fishlim/meson.build
+@@ -1,4 +1,4 @@
+-if not libssl_dep.found()
++if not libssl_dep_found
+ error('fish plugin requires openssl')
+ endif
+
diff --git a/irc/hexchat/files/patch-src__common__server.c b/irc/hexchat/files/patch-src__common__server.c
index f9189abceb83..3318f9b64aeb 100644
--- a/irc/hexchat/files/patch-src__common__server.c
+++ b/irc/hexchat/files/patch-src__common__server.c
@@ -1,11 +1,11 @@
---- src/common/server.c.orig 2016-12-10 14:30:51 UTC
+--- src/common/server.c.orig 2018-03-14 02:26:31 UTC
+++ src/common/server.c
-@@ -743,7 +743,7 @@ server_connect_success (server *serv)
+@@ -749,7 +749,7 @@ server_connect_success (server *serv)
/* it'll be a memory leak, if connection isn't terminated by
server_cleanup() */
serv->ssl = _SSL_socket (serv->ctx, serv->sok);
- if ((err = _SSL_set_verify (serv->ctx, ssl_cb_verify, NULL)))
-+ if ((err = _SSL_set_verify (serv->ctx, ssl_cb_verify, "/usr/local/share/certs/ca-root-nss.crt")))
++ if ((err = _SSL_set_verify (serv->ctx, ssl_cb_verify, "%%CA_BUNDLE%%")))
{
EMIT_SIGNAL (XP_TE_CONNFAIL, serv->server_session, err, NULL,
NULL, NULL, 0);
diff --git a/irc/hexchat/files/patch-src__common__ssl.c b/irc/hexchat/files/patch-src__common__ssl.c
deleted file mode 100644
index 56caccadcab8..000000000000
--- a/irc/hexchat/files/patch-src__common__ssl.c
+++ /dev/null
@@ -1,38 +0,0 @@
---- src/common/ssl.c.orig 2016-12-10 14:30:51 UTC
-+++ src/common/ssl.c
-@@ -176,7 +176,7 @@ _SSL_get_cert_info (struct cert_info *ce
- return 1;
-
- alg = OBJ_obj2nid (algor->algorithm);
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || LIBRESSL_VERSION_NUMBER
- sign_alg = OBJ_obj2nid (peer_cert->sig_alg->algorithm);
- #else
- sign_alg = X509_get_signature_nid (peer_cert);
-@@ -306,7 +306,7 @@ _SSL_socket (SSL_CTX *ctx, int sd)
-
- SSL_set_fd (ssl, sd);
-
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || LIBRESSL_VERSION_NUMBER
- method = ctx->method;
- #else
- method = SSL_CTX_get_ssl_method (ctx);
-@@ -328,7 +328,7 @@ _SSL_set_verify (SSL_CTX *ctx, void *ver
- __SSL_fill_err_buf ("SSL_CTX_set_default_verify_paths");
- return (err_buf);
- }
--/*
-+
- if (cacert)
- {
- if (!SSL_CTX_load_verify_locations (ctx, cacert, NULL))
-@@ -337,7 +337,7 @@ _SSL_set_verify (SSL_CTX *ctx, void *ver
- return (err_buf);
- }
- }
--*/
-+
- SSL_CTX_set_verify (ctx, SSL_VERIFY_PEER, verify_callback);
-
- return (NULL);
diff --git a/irc/hexchat/pkg-descr b/irc/hexchat/pkg-descr
index ea5f5d0bb86d..074040fdc40a 100644
--- a/irc/hexchat/pkg-descr
+++ b/irc/hexchat/pkg-descr
@@ -6,4 +6,4 @@ HexChat is based on XChat, but unlike XChat it's completely
free for both Windows and Unix-like systems.
Since XChat is Open Source, it's perfectly legal.
-WWW: http://hexchat.github.io/
+WWW: https://hexchat.github.io/
diff --git a/irc/hexchat/pkg-plist b/irc/hexchat/pkg-plist
index 9653c09fbd59..3498b5238bf5 100644
--- a/irc/hexchat/pkg-plist
+++ b/irc/hexchat/pkg-plist
@@ -5,64 +5,65 @@ lib/hexchat/plugins/checksum.so
%%FISHLIM%%lib/hexchat/plugins/fishlim.so
%%PERL%%lib/hexchat/plugins/perl.so
%%PYTHON%%lib/hexchat/plugins/python.so
+%%LUA%%%%LUA_LIBDIR%%/hexchat/plugins/lua.so
libdata/pkgconfig/hexchat-plugin.pc
man/man1/hexchat.1.gz
-share/appdata/hexchat.appdata.xml
-share/applications/hexchat.desktop
+share/metainfo/io.github.Hexchat.appdata.xml
+share/applications/io.github.Hexchat.desktop
%%DBUS%%share/dbus-1/services/org.hexchat.service.service
share/icons/hicolor/48x48/apps/hexchat.png
share/icons/hicolor/scalable/apps/hexchat.svg
-%%NLS%%share/locale/af/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/am/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/ast/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/az/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/be/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/bg/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/ca/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/cs/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/da/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/de/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/el/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/en_GB/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/es/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/et/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/eu/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/fi/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/fr/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/gl/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/gu/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/hi/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/hu/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/id/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/it/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/ja_JP/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/kn/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/ko/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/lt/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/lv/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/mk/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/ml/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/ms/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/nb/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/nl/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/no/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/pa/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/pl/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/pt/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/pt_BR/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/ru/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/rw/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/sk/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/sl/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/sq/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/sr/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/sr@latin/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/sv/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/th/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/tr/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/uk/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/vi/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/wa/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/zh_CN/LC_MESSAGES/hexchat.mo
-%%NLS%%share/locale/zh_TW/LC_MESSAGES/hexchat.mo
+share/locale/af/LC_MESSAGES/hexchat.mo
+share/locale/am/LC_MESSAGES/hexchat.mo
+share/locale/ast/LC_MESSAGES/hexchat.mo
+share/locale/az/LC_MESSAGES/hexchat.mo
+share/locale/be/LC_MESSAGES/hexchat.mo
+share/locale/bg/LC_MESSAGES/hexchat.mo
+share/locale/ca/LC_MESSAGES/hexchat.mo
+share/locale/cs/LC_MESSAGES/hexchat.mo
+share/locale/da/LC_MESSAGES/hexchat.mo
+share/locale/de/LC_MESSAGES/hexchat.mo
+share/locale/el/LC_MESSAGES/hexchat.mo
+share/locale/en_GB/LC_MESSAGES/hexchat.mo
+share/locale/es/LC_MESSAGES/hexchat.mo
+share/locale/et/LC_MESSAGES/hexchat.mo
+share/locale/eu/LC_MESSAGES/hexchat.mo
+share/locale/fi/LC_MESSAGES/hexchat.mo
+share/locale/fr/LC_MESSAGES/hexchat.mo
+share/locale/gl/LC_MESSAGES/hexchat.mo
+share/locale/gu/LC_MESSAGES/hexchat.mo
+share/locale/hi/LC_MESSAGES/hexchat.mo
+share/locale/hu/LC_MESSAGES/hexchat.mo
+share/locale/id/LC_MESSAGES/hexchat.mo
+share/locale/it/LC_MESSAGES/hexchat.mo
+share/locale/ja_JP/LC_MESSAGES/hexchat.mo
+share/locale/kn/LC_MESSAGES/hexchat.mo
+share/locale/ko/LC_MESSAGES/hexchat.mo
+share/locale/lt/LC_MESSAGES/hexchat.mo
+share/locale/lv/LC_MESSAGES/hexchat.mo
+share/locale/mk/LC_MESSAGES/hexchat.mo
+share/locale/ml/LC_MESSAGES/hexchat.mo
+share/locale/ms/LC_MESSAGES/hexchat.mo
+share/locale/nb/LC_MESSAGES/hexchat.mo
+share/locale/nl/LC_MESSAGES/hexchat.mo
+share/locale/no/LC_MESSAGES/hexchat.mo
+share/locale/pa/LC_MESSAGES/hexchat.mo
+share/locale/pl/LC_MESSAGES/hexchat.mo
+share/locale/pt/LC_MESSAGES/hexchat.mo
+share/locale/pt_BR/LC_MESSAGES/hexchat.mo
+share/locale/ru/LC_MESSAGES/hexchat.mo
+share/locale/rw/LC_MESSAGES/hexchat.mo
+share/locale/sk/LC_MESSAGES/hexchat.mo
+share/locale/sl/LC_MESSAGES/hexchat.mo
+share/locale/sq/LC_MESSAGES/hexchat.mo
+share/locale/sr/LC_MESSAGES/hexchat.mo
+share/locale/sr@latin/LC_MESSAGES/hexchat.mo
+share/locale/sv/LC_MESSAGES/hexchat.mo
+share/locale/th/LC_MESSAGES/hexchat.mo
+share/locale/tr/LC_MESSAGES/hexchat.mo
+share/locale/uk/LC_MESSAGES/hexchat.mo
+share/locale/vi/LC_MESSAGES/hexchat.mo
+share/locale/wa/LC_MESSAGES/hexchat.mo
+share/locale/zh_CN/LC_MESSAGES/hexchat.mo
+share/locale/zh_TW/LC_MESSAGES/hexchat.mo
share/pixmaps/hexchat.png