aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/heirloom-mailx/Makefile9
-rw-r--r--mail/nail/Makefile9
2 files changed, 10 insertions, 8 deletions
diff --git a/mail/heirloom-mailx/Makefile b/mail/heirloom-mailx/Makefile
index 0e59debdcafb..a0f7c3b9de21 100644
--- a/mail/heirloom-mailx/Makefile
+++ b/mail/heirloom-mailx/Makefile
@@ -13,15 +13,16 @@ MASTER_SITES= http://nail.berlios.de/archive/
MAINTAINER= ports@FreeBSD.org
COMMENT= BSD mail utility with MIME extensions
-LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
-
USE_BZIP2= yes
+USE_ICONV= yes
USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-openssl --with-rcfile="${PREFIX}/etc/nail.rc"
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-liconv"
-LDFLAGS= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= nail.1
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib -liconv
+
.include <bsd.port.mk>
diff --git a/mail/nail/Makefile b/mail/nail/Makefile
index 0e59debdcafb..a0f7c3b9de21 100644
--- a/mail/nail/Makefile
+++ b/mail/nail/Makefile
@@ -13,15 +13,16 @@ MASTER_SITES= http://nail.berlios.de/archive/
MAINTAINER= ports@FreeBSD.org
COMMENT= BSD mail utility with MIME extensions
-LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
-
USE_BZIP2= yes
+USE_ICONV= yes
USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-openssl --with-rcfile="${PREFIX}/etc/nail.rc"
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-liconv"
-LDFLAGS= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= nail.1
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib -liconv
+
.include <bsd.port.mk>