aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dns/bind9-devel/Makefile4
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl12
3 files changed, 11 insertions, 11 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index cc208de236d6..c89c2dcefb3b 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -40,13 +40,13 @@ LIB_DEPENDS= libxml2.so:textproc/libxml2
# XXX: remove tar:bz2
USES= cpe libedit ssl tar:bz2
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.13.1a0.2018.09.09
+ISCVERSION= 9.13.1a0.2018.09.11
# XXX: Remove gitlab
USE_GITLAB= yes
GL_SITE= https://gitlab.isc.org
GL_ACCOUNT= isc-projects
GL_PROJECT= bind9
-GL_COMMIT= d98de244c35cba90a00ac85810030d08255ce37a
+GL_COMMIT= 5cf8fc4bba6f61d493ed20e86037d799e20a43db
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index 3c359c5d245e..de254d5af668 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1536573567
-SHA256 (isc-projects-bind9-d98de244c35cba90a00ac85810030d08255ce37a_GL0.tar.gz) = 18c6c2911296dc57cba31d7f0e80028b3e7842f5ee1f6e557158bfff930e47b3
-SIZE (isc-projects-bind9-d98de244c35cba90a00ac85810030d08255ce37a_GL0.tar.gz) = 7263006
+TIMESTAMP = 1537183338
+SHA256 (isc-projects-bind9-5cf8fc4bba6f61d493ed20e86037d799e20a43db_GL0.tar.gz) = f9d6889803fc277d696f794a617456bbdfc97f8bd93b4f483d141bc1885a6c15
+SIZE (isc-projects-bind9-5cf8fc4bba6f61d493ed20e86037d799e20a43db_GL0.tar.gz) = 7263466
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index 2e0a406c1b19..573fa3e3f2b0 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,4 +1,4 @@
---- bin/named/config.c.orig 2018-09-10 00:21:25 UTC
+--- bin/named/config.c.orig 2018-09-11 19:56:29 UTC
+++ bin/named/config.c
@@ -174,12 +174,14 @@ options {\n\
max-recursion-queries 75;\n\
@@ -15,9 +15,9 @@
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2018-09-10 00:21:25 UTC
+--- bin/named/server.c.orig 2018-09-11 19:56:29 UTC
+++ bin/named/server.c
-@@ -4074,6 +4074,16 @@ configure_view(dns_view_t *view, dns_vie
+@@ -4075,6 +4075,16 @@ configure_view(dns_view_t *view, dns_vie
}
obj = NULL;
@@ -34,7 +34,7 @@
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2018-09-10 00:21:25 UTC
+--- lib/dns/include/dns/view.h.orig 2018-09-11 19:56:29 UTC
+++ lib/dns/include/dns/view.h
@@ -153,6 +153,8 @@ struct dns_view {
bool requestnsid;
@@ -45,7 +45,7 @@
dns_ttl_t maxncachettl;
uint32_t nta_lifetime;
uint32_t nta_recheck;
---- lib/dns/resolver.c.orig 2018-09-10 00:21:25 UTC
+--- lib/dns/resolver.c.orig 2018-09-11 19:56:29 UTC
+++ lib/dns/resolver.c
@@ -5758,6 +5758,18 @@ cache_name(fetchctx_t *fctx, dns_name_t
}
@@ -66,7 +66,7 @@
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2018-09-10 00:21:25 UTC
+--- lib/isccfg/namedconf.c.orig 2018-09-11 19:56:29 UTC
+++ lib/isccfg/namedconf.c
@@ -1920,6 +1920,8 @@ view_clauses[] = {
{ "max-acache-size", &cfg_type_sizenodefault,