aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/libdbi/Makefile6
-rw-r--r--www/mod_auth_pgsql/Makefile6
2 files changed, 8 insertions, 4 deletions
diff --git a/databases/libdbi/Makefile b/databases/libdbi/Makefile
index 6b5f40751623..fb583e8bee85 100644
--- a/databases/libdbi/Makefile
+++ b/databases/libdbi/Makefile
@@ -8,12 +8,13 @@
PORTNAME= libdbi
PORTVERSION= 0.6.7
+PORTREVISION= 1
CATEGORIES= databases devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://linux.ucla.edu/~dap24/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= seanc@FreeBSD.org
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
@@ -29,7 +30,8 @@ PLIST_SUB+= MYSQL="@comment "
.endif
.if defined(WITH_PGSQL)
-LIB_DEPENDS+= pq:${PORTSDIR}/databases/postgresql7
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
CONFIGURE_ARGS+= --with-pgsql
PLIST_SUB+= PGSQL=""
.else
diff --git a/www/mod_auth_pgsql/Makefile b/www/mod_auth_pgsql/Makefile
index de2d944be166..e11317c87e4c 100644
--- a/www/mod_auth_pgsql/Makefile
+++ b/www/mod_auth_pgsql/Makefile
@@ -6,14 +6,15 @@
PORTNAME= mod_auth_pgsql
PORTVERSION= 0.9.12
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.giuseppetanzilli.it/mod_auth_pgsql/dist/
-MAINTAINER= ports@freebsd.org
+MAINTAINER= seanc@FreeBSD.org
BUILD_DEPENDS= ${APXS}:${APACHE_PORT}
RUN_DEPENDS= ${LOCALBASE}/sbin/${AP_TARGET}:${APACHE_PORT}
-LIB_DEPENDS= pq.3:${PORTSDIR}/databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/a//}
@@ -22,6 +23,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/a//}
APXS?= ${LOCALBASE}/sbin/apxs
AP_PORT?= apache13
APACHE_PORT?= ${PORTSDIR}/www/${AP_PORT}
+POSTGRESQL_PORT?= databases/postgresql7
.if exists(${APXS})
APXS_WORKS!= ${APXS} -q TARGET 2>/dev/null || echo no