aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/Makefile1
-rw-r--r--games/nuclearchess/Makefile25
-rw-r--r--games/nuclearchess/distinfo3
-rw-r--r--games/nuclearchess/pkg-descr5
-rw-r--r--games/nuclearchess/pkg-plist37
5 files changed, 71 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 5cff5c774e85..3ca629c855f5 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -461,6 +461,7 @@
SUBDIR += noegnud-nethack-deet
SUBDIR += noegnud-slashem
SUBDIR += nonsense
+ SUBDIR += nuclearchess
SUBDIR += nwndata
SUBDIR += nwnusers
SUBDIR += oilwar
diff --git a/games/nuclearchess/Makefile b/games/nuclearchess/Makefile
new file mode 100644
index 000000000000..8ac56cfb8ec3
--- /dev/null
+++ b/games/nuclearchess/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: nuclearchess
+# Date Created: 2006-05-26
+# Whom: Shaun Amott <shaun@inerd.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nuclearchess
+PORTVERSION= 0.9.2
+CATEGORIES= games
+MASTER_SITES= http://user.cs.tu-berlin.de/~karlb/${PORTNAME}/ \
+ http://mirror.inerd.com/FreeBSD/distfiles/${PORTNAME}/
+
+MAINTAINER= shaun@inerd.com
+COMMENT= A chess variant designed to be short and fun for all players
+
+GNU_CONFIGURE= yes
+
+USE_SDL= sdl image
+
+CONFIGURE_ARGS= --prefix=${PREFIX} \
+ --localstatedir=${DATADIR} \
+ --program-prefix=
+
+.include <bsd.port.mk>
diff --git a/games/nuclearchess/distinfo b/games/nuclearchess/distinfo
new file mode 100644
index 000000000000..627217e22272
--- /dev/null
+++ b/games/nuclearchess/distinfo
@@ -0,0 +1,3 @@
+MD5 (nuclearchess-0.9.2.tar.gz) = 10d8b2a2890d6aaca1afe2cbc23f002a
+SHA256 (nuclearchess-0.9.2.tar.gz) = a7d485ccf1b1c88ffb54850265a19a368d3f89daf321332307b3c5f924f15a83
+SIZE (nuclearchess-0.9.2.tar.gz) = 1355944
diff --git a/games/nuclearchess/pkg-descr b/games/nuclearchess/pkg-descr
new file mode 100644
index 000000000000..bacb7835fc8f
--- /dev/null
+++ b/games/nuclearchess/pkg-descr
@@ -0,0 +1,5 @@
+NuclearChess is a chess variant. Whenever a piece is captured, both
+pieces and all pieces on neighbour fields die. Games are short and fun
+even for people who usually don't play chess.
+
+WWW: http://user.cs.tu-berlin.de/~karlb/nuclearchess/
diff --git a/games/nuclearchess/pkg-plist b/games/nuclearchess/pkg-plist
new file mode 100644
index 000000000000..88c3d938ea43
--- /dev/null
+++ b/games/nuclearchess/pkg-plist
@@ -0,0 +1,37 @@
+bin/nuclearchess
+%%DATADIR%%/gfx/SmallStone.png
+%%DATADIR%%/gfx/anim3.png
+%%DATADIR%%/gfx/bauer.png
+%%DATADIR%%/gfx/dame.png
+%%DATADIR%%/gfx/anim1.png
+%%DATADIR%%/gfx/anim4.png
+%%DATADIR%%/gfx/turm.png
+%%DATADIR%%/gfx/StoneFont.png
+%%DATADIR%%/gfx/anim10.png
+%%DATADIR%%/gfx/anim5.png
+%%DATADIR%%/gfx/black.png
+%%DATADIR%%/gfx/koenig.png
+%%DATADIR%%/gfx/anim11.png
+%%DATADIR%%/gfx/anim6.png
+%%DATADIR%%/gfx/white.png
+%%DATADIR%%/gfx/anim12.png
+%%DATADIR%%/gfx/anim7.png
+%%DATADIR%%/gfx/board.png
+%%DATADIR%%/gfx/laeufer.png
+%%DATADIR%%/gfx/wood.png
+%%DATADIR%%/gfx/anim13.png
+%%DATADIR%%/gfx/anim8.png
+%%DATADIR%%/gfx/bomb.png
+%%DATADIR%%/gfx/anim14.png
+%%DATADIR%%/gfx/anim9.png
+%%DATADIR%%/gfx/bombe.png
+%%DATADIR%%/gfx/anim15.png
+%%DATADIR%%/gfx/atom-rot.png
+%%DATADIR%%/gfx/button-light.png
+%%DATADIR%%/gfx/select.png
+%%DATADIR%%/gfx/anim2.png
+%%DATADIR%%/gfx/atom.png
+%%DATADIR%%/gfx/button.png
+%%DATADIR%%/gfx/springer.png
+@dirrm %%DATADIR%%/gfx
+@dirrm %%DATADIR%%