aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/jakarta-tomcat4/Makefile2
-rw-r--r--www/jakarta-tomcat4/files/tomcat4.sh.in4
-rw-r--r--www/jakarta-tomcat41/Makefile2
-rw-r--r--www/jakarta-tomcat41/files/tomcat41.sh.in4
-rw-r--r--www/jakarta-tomcat5/Makefile2
-rw-r--r--www/jakarta-tomcat5/files/tomcat50.sh.in4
-rw-r--r--www/tomcat41/Makefile2
-rw-r--r--www/tomcat41/files/tomcat41.sh.in4
-rw-r--r--www/tomcat55/Makefile1
-rw-r--r--www/tomcat55/files/tomcat55.sh.in4
-rw-r--r--www/tomcat6/Makefile1
-rw-r--r--www/tomcat6/files/tomcat55.sh.in4
-rw-r--r--www/tomcat7/Makefile1
-rw-r--r--www/tomcat7/files/tomcat55.sh.in4
14 files changed, 21 insertions, 18 deletions
diff --git a/www/jakarta-tomcat4/Makefile b/www/jakarta-tomcat4/Makefile
index 2bba62440534..a6920741b5f0 100644
--- a/www/jakarta-tomcat4/Makefile
+++ b/www/jakarta-tomcat4/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jakarta-tomcat
PORTVERSION= 4.0.6
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= www java
MASTER_SITES= http://distfiles.coredump.cn/ \
ftp://local-distfiles.freebsd.org.cn/pub/china-ports/liukang/
diff --git a/www/jakarta-tomcat4/files/tomcat4.sh.in b/www/jakarta-tomcat4/files/tomcat4.sh.in
index 2823c81ca7d1..bc87ede6d9d4 100644
--- a/www/jakarta-tomcat4/files/tomcat4.sh.in
+++ b/www/jakarta-tomcat4/files/tomcat4.sh.in
@@ -109,7 +109,7 @@ log_args=">> ${tomcat%%TOMCAT_VERSION%%_stdout_log} \
if [ -f $pidfile ]; then
read rc_pid junk < $pidfile
if [ ! -z "$rc_pid" ]; then
- procname=`ps -o comm= $rc_pid`
+ procname=`ps -o ucomm= $rc_pid`
fi
fi
@@ -128,7 +128,7 @@ pid_touch ()
}
tomcat%%TOMCAT_VERSION%%_stop() {
- rc_pid=$(check_pidfile $pidfile $procname)
+ rc_pid=$(check_pidfile $pidfile *$procname*)
if [ -z "$rc_pid" ]; then
[ -n "$rc_fast" ] && return 0
diff --git a/www/jakarta-tomcat41/Makefile b/www/jakarta-tomcat41/Makefile
index f2305da00ba3..045591ca3464 100644
--- a/www/jakarta-tomcat41/Makefile
+++ b/www/jakarta-tomcat41/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jakarta-tomcat
PORTVERSION= 4.1.31
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE_JAKARTA}
MASTER_SITE_SUBDIR= tomcat-4/v${PORTVERSION}/bin
diff --git a/www/jakarta-tomcat41/files/tomcat41.sh.in b/www/jakarta-tomcat41/files/tomcat41.sh.in
index 2823c81ca7d1..bc87ede6d9d4 100644
--- a/www/jakarta-tomcat41/files/tomcat41.sh.in
+++ b/www/jakarta-tomcat41/files/tomcat41.sh.in
@@ -109,7 +109,7 @@ log_args=">> ${tomcat%%TOMCAT_VERSION%%_stdout_log} \
if [ -f $pidfile ]; then
read rc_pid junk < $pidfile
if [ ! -z "$rc_pid" ]; then
- procname=`ps -o comm= $rc_pid`
+ procname=`ps -o ucomm= $rc_pid`
fi
fi
@@ -128,7 +128,7 @@ pid_touch ()
}
tomcat%%TOMCAT_VERSION%%_stop() {
- rc_pid=$(check_pidfile $pidfile $procname)
+ rc_pid=$(check_pidfile $pidfile *$procname*)
if [ -z "$rc_pid" ]; then
[ -n "$rc_fast" ] && return 0
diff --git a/www/jakarta-tomcat5/Makefile b/www/jakarta-tomcat5/Makefile
index 6eaf43020278..383d9e3b6f5b 100644
--- a/www/jakarta-tomcat5/Makefile
+++ b/www/jakarta-tomcat5/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jakarta-tomcat
PORTVERSION= 5.0.30
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE_JAKARTA}
MASTER_SITE_SUBDIR= tomcat-5/v${PORTVERSION}/bin
diff --git a/www/jakarta-tomcat5/files/tomcat50.sh.in b/www/jakarta-tomcat5/files/tomcat50.sh.in
index 2823c81ca7d1..bc87ede6d9d4 100644
--- a/www/jakarta-tomcat5/files/tomcat50.sh.in
+++ b/www/jakarta-tomcat5/files/tomcat50.sh.in
@@ -109,7 +109,7 @@ log_args=">> ${tomcat%%TOMCAT_VERSION%%_stdout_log} \
if [ -f $pidfile ]; then
read rc_pid junk < $pidfile
if [ ! -z "$rc_pid" ]; then
- procname=`ps -o comm= $rc_pid`
+ procname=`ps -o ucomm= $rc_pid`
fi
fi
@@ -128,7 +128,7 @@ pid_touch ()
}
tomcat%%TOMCAT_VERSION%%_stop() {
- rc_pid=$(check_pidfile $pidfile $procname)
+ rc_pid=$(check_pidfile $pidfile *$procname*)
if [ -z "$rc_pid" ]; then
[ -n "$rc_fast" ] && return 0
diff --git a/www/tomcat41/Makefile b/www/tomcat41/Makefile
index f2305da00ba3..045591ca3464 100644
--- a/www/tomcat41/Makefile
+++ b/www/tomcat41/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jakarta-tomcat
PORTVERSION= 4.1.31
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE_JAKARTA}
MASTER_SITE_SUBDIR= tomcat-4/v${PORTVERSION}/bin
diff --git a/www/tomcat41/files/tomcat41.sh.in b/www/tomcat41/files/tomcat41.sh.in
index 2823c81ca7d1..bc87ede6d9d4 100644
--- a/www/tomcat41/files/tomcat41.sh.in
+++ b/www/tomcat41/files/tomcat41.sh.in
@@ -109,7 +109,7 @@ log_args=">> ${tomcat%%TOMCAT_VERSION%%_stdout_log} \
if [ -f $pidfile ]; then
read rc_pid junk < $pidfile
if [ ! -z "$rc_pid" ]; then
- procname=`ps -o comm= $rc_pid`
+ procname=`ps -o ucomm= $rc_pid`
fi
fi
@@ -128,7 +128,7 @@ pid_touch ()
}
tomcat%%TOMCAT_VERSION%%_stop() {
- rc_pid=$(check_pidfile $pidfile $procname)
+ rc_pid=$(check_pidfile $pidfile *$procname*)
if [ -z "$rc_pid" ]; then
[ -n "$rc_fast" ] && return 0
diff --git a/www/tomcat55/Makefile b/www/tomcat55/Makefile
index d92c862ffad8..c311eefcdbc9 100644
--- a/www/tomcat55/Makefile
+++ b/www/tomcat55/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tomcat
PORTVERSION= 5.5.17
+PORTREVISION= 1
CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE}
MASTER_SITE_SUBDIR= tomcat/tomcat-5/v${PORTVERSION}/bin
diff --git a/www/tomcat55/files/tomcat55.sh.in b/www/tomcat55/files/tomcat55.sh.in
index 2823c81ca7d1..bc87ede6d9d4 100644
--- a/www/tomcat55/files/tomcat55.sh.in
+++ b/www/tomcat55/files/tomcat55.sh.in
@@ -109,7 +109,7 @@ log_args=">> ${tomcat%%TOMCAT_VERSION%%_stdout_log} \
if [ -f $pidfile ]; then
read rc_pid junk < $pidfile
if [ ! -z "$rc_pid" ]; then
- procname=`ps -o comm= $rc_pid`
+ procname=`ps -o ucomm= $rc_pid`
fi
fi
@@ -128,7 +128,7 @@ pid_touch ()
}
tomcat%%TOMCAT_VERSION%%_stop() {
- rc_pid=$(check_pidfile $pidfile $procname)
+ rc_pid=$(check_pidfile $pidfile *$procname*)
if [ -z "$rc_pid" ]; then
[ -n "$rc_fast" ] && return 0
diff --git a/www/tomcat6/Makefile b/www/tomcat6/Makefile
index d92c862ffad8..c311eefcdbc9 100644
--- a/www/tomcat6/Makefile
+++ b/www/tomcat6/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tomcat
PORTVERSION= 5.5.17
+PORTREVISION= 1
CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE}
MASTER_SITE_SUBDIR= tomcat/tomcat-5/v${PORTVERSION}/bin
diff --git a/www/tomcat6/files/tomcat55.sh.in b/www/tomcat6/files/tomcat55.sh.in
index 2823c81ca7d1..bc87ede6d9d4 100644
--- a/www/tomcat6/files/tomcat55.sh.in
+++ b/www/tomcat6/files/tomcat55.sh.in
@@ -109,7 +109,7 @@ log_args=">> ${tomcat%%TOMCAT_VERSION%%_stdout_log} \
if [ -f $pidfile ]; then
read rc_pid junk < $pidfile
if [ ! -z "$rc_pid" ]; then
- procname=`ps -o comm= $rc_pid`
+ procname=`ps -o ucomm= $rc_pid`
fi
fi
@@ -128,7 +128,7 @@ pid_touch ()
}
tomcat%%TOMCAT_VERSION%%_stop() {
- rc_pid=$(check_pidfile $pidfile $procname)
+ rc_pid=$(check_pidfile $pidfile *$procname*)
if [ -z "$rc_pid" ]; then
[ -n "$rc_fast" ] && return 0
diff --git a/www/tomcat7/Makefile b/www/tomcat7/Makefile
index d92c862ffad8..c311eefcdbc9 100644
--- a/www/tomcat7/Makefile
+++ b/www/tomcat7/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tomcat
PORTVERSION= 5.5.17
+PORTREVISION= 1
CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE}
MASTER_SITE_SUBDIR= tomcat/tomcat-5/v${PORTVERSION}/bin
diff --git a/www/tomcat7/files/tomcat55.sh.in b/www/tomcat7/files/tomcat55.sh.in
index 2823c81ca7d1..bc87ede6d9d4 100644
--- a/www/tomcat7/files/tomcat55.sh.in
+++ b/www/tomcat7/files/tomcat55.sh.in
@@ -109,7 +109,7 @@ log_args=">> ${tomcat%%TOMCAT_VERSION%%_stdout_log} \
if [ -f $pidfile ]; then
read rc_pid junk < $pidfile
if [ ! -z "$rc_pid" ]; then
- procname=`ps -o comm= $rc_pid`
+ procname=`ps -o ucomm= $rc_pid`
fi
fi
@@ -128,7 +128,7 @@ pid_touch ()
}
tomcat%%TOMCAT_VERSION%%_stop() {
- rc_pid=$(check_pidfile $pidfile $procname)
+ rc_pid=$(check_pidfile $pidfile *$procname*)
if [ -z "$rc_pid" ]; then
[ -n "$rc_fast" ] && return 0