aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/py-turbogears/Makefile5
-rw-r--r--www/py-turbogears/files/pkg-deinstall.in2
-rw-r--r--www/py-turbogears2/Makefile5
-rw-r--r--www/py-turbogears2/files/pkg-deinstall.in2
4 files changed, 8 insertions, 6 deletions
diff --git a/www/py-turbogears/Makefile b/www/py-turbogears/Makefile
index 5ddeb4c851fc..c05539164957 100644
--- a/www/py-turbogears/Makefile
+++ b/www/py-turbogears/Makefile
@@ -7,7 +7,7 @@
PORTNAME= TurboGears
PORTVERSION= 0.8.9
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www python
MASTER_SITES= http://nivi.interfree.it/distfiles/${PORTNAME}/ \
http://www.turbogears.org/download/eggs/
@@ -19,7 +19,7 @@ COMMENT= Python-Based Framework for Rapid Web Development
BUILD_DEPENDS= easy_install:${PORTSDIR}/devel/py-setuptools
RUN_DEPENDS= easy_install:${PORTSDIR}/devel/py-setuptools \
- ${PYTHON_SITELIBDIR}/kid/__init__.py:${PORTSDIR}/devel/py-kid \
+ ${PYTHON_SITELIBDIR}/${PYKID_EGG}/kid/__init__.py:${PORTSDIR}/devel/py-kid \
sqlobject-admin:${PORTSDIR}/databases/py-sqlobject \
${PYTHON_SITELIBDIR}/cherrypy/__init__.py:${PORTSDIR}/www/py-cherrypy-old \
${PYTHON_SITELIBDIR}/cElementTree.so:${PORTSDIR}/devel/py-celementtree \
@@ -57,5 +57,6 @@ RUN_DEPENDS+= cheetah:${PORTSDIR}/devel/py-cheetah
.endif
PYFORMENCODE_EGG!= ${MAKE} -f ${PORTSDIR}/www/py-formencode/Makefile -V PYFORMENCODE_EGG
+PYKID_EGG!= ${MAKE} -f ${PORTSDIR}/devel/py-kid/Makefile -V PYKID_EGG
.include <bsd.port.post.mk>
diff --git a/www/py-turbogears/files/pkg-deinstall.in b/www/py-turbogears/files/pkg-deinstall.in
index e184b62091c2..2d0f147f3ccf 100644
--- a/www/py-turbogears/files/pkg-deinstall.in
+++ b/www/py-turbogears/files/pkg-deinstall.in
@@ -5,7 +5,7 @@ PKGNAME=$1
case $2 in
DEINSTALL)
for f in %%EGGS%%
- do easy_install -x -m -D "%%PYTHON_SITELIBDIR%%/${f}"
+ do easy_install -q -x -m "%%PYTHON_SITELIBDIR%%/${f}"
done
;;
POST-DEINSTALL)
diff --git a/www/py-turbogears2/Makefile b/www/py-turbogears2/Makefile
index 5ddeb4c851fc..c05539164957 100644
--- a/www/py-turbogears2/Makefile
+++ b/www/py-turbogears2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= TurboGears
PORTVERSION= 0.8.9
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www python
MASTER_SITES= http://nivi.interfree.it/distfiles/${PORTNAME}/ \
http://www.turbogears.org/download/eggs/
@@ -19,7 +19,7 @@ COMMENT= Python-Based Framework for Rapid Web Development
BUILD_DEPENDS= easy_install:${PORTSDIR}/devel/py-setuptools
RUN_DEPENDS= easy_install:${PORTSDIR}/devel/py-setuptools \
- ${PYTHON_SITELIBDIR}/kid/__init__.py:${PORTSDIR}/devel/py-kid \
+ ${PYTHON_SITELIBDIR}/${PYKID_EGG}/kid/__init__.py:${PORTSDIR}/devel/py-kid \
sqlobject-admin:${PORTSDIR}/databases/py-sqlobject \
${PYTHON_SITELIBDIR}/cherrypy/__init__.py:${PORTSDIR}/www/py-cherrypy-old \
${PYTHON_SITELIBDIR}/cElementTree.so:${PORTSDIR}/devel/py-celementtree \
@@ -57,5 +57,6 @@ RUN_DEPENDS+= cheetah:${PORTSDIR}/devel/py-cheetah
.endif
PYFORMENCODE_EGG!= ${MAKE} -f ${PORTSDIR}/www/py-formencode/Makefile -V PYFORMENCODE_EGG
+PYKID_EGG!= ${MAKE} -f ${PORTSDIR}/devel/py-kid/Makefile -V PYKID_EGG
.include <bsd.port.post.mk>
diff --git a/www/py-turbogears2/files/pkg-deinstall.in b/www/py-turbogears2/files/pkg-deinstall.in
index e184b62091c2..2d0f147f3ccf 100644
--- a/www/py-turbogears2/files/pkg-deinstall.in
+++ b/www/py-turbogears2/files/pkg-deinstall.in
@@ -5,7 +5,7 @@ PKGNAME=$1
case $2 in
DEINSTALL)
for f in %%EGGS%%
- do easy_install -x -m -D "%%PYTHON_SITELIBDIR%%/${f}"
+ do easy_install -q -x -m "%%PYTHON_SITELIBDIR%%/${f}"
done
;;
POST-DEINSTALL)